Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Joined
Sep 22, 2018
Messages
6
Motherboard
Lenovo Y520-15IKBN-Clover
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050 Ti, 1920x1080
Mobile Phone
Android
Hello again , i have problem i want an external screen so because i cant use hdmi port ( because its connected to nvidia ) i buy usb c hub with hdmi port but is not working when i connected all usb ports in the hub work except the hdmi port and when i connect to the hdmi port the laptop restart . how can i solve it ?
 
Joined
Jul 29, 2016
Messages
56
Motherboard
Legions Y530
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Sorry, I misunderstood something. The SSDT-Y720.aml is an add-on SSDT, so no wonder I cannot find any I2C device entries. :rolleyes: I found a solution by using the ApplePS2SmartTouchPad.kext but it has no multitouch functionality. Is there any hope to make the Trackpad work without using that kext? Thanks!
Question: is your lock screen working ? Cause every time I try to lock then screen stays lock down mode few seconds then goes black screen, any problem in your end ?
 
Joined
Jul 29, 2016
Messages
56
Motherboard
Legions Y530
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Unfortunately, the repo does not have Y530 support in the mean time. However, there’s a possibility I might add support for it sometime in the future if I get enough data for the Y530 model.
Question: is your lock screen working ? Cause every time I try to lock then screen stays lock down mode few seconds then goes black screen, any problem in your end ?
 
Joined
Jul 31, 2018
Messages
6
Motherboard
Legion Y720
CPU
i5-7300HQ
Graphics
HD 630 / GTX 1060
Question: is your lock screen working ? Cause every time I try to lock then screen stays lock down mode few seconds then goes black screen, any problem in your end ?
Yes, I can confirm that. Same situation after update to 10.14.3
 
Joined
Jul 31, 2018
Messages
6
Motherboard
Legion Y720
CPU
i5-7300HQ
Graphics
HD 630 / GTX 1060
Does anyone have a working keyboard backlight + hotkey (Fn Space)?
 
Joined
Feb 9, 2019
Messages
1
Motherboard
Lenovo Legion Y520-15IKBN (Clover)
CPU
i5 7300HQ
Graphics
Intel HD Graphics 630 + Nvidia GTX 1050 1920x1080
Mobile Phone
iOS
I have successfully installed macOS Mojave according to this guide on my Y520. Sound works with AppleALC method injected on layout 28 (successfully switches on headphones and back, no lagging), IntelHD630 works (solved 7mb issue), also Bluetooth works on factory installed Intel 8265 WiFi/Bluetooth Card (successfully connected to AirPods and mobile internet on my iPhone via Bluetooth. So, there is a question is Wifi will work if Bluetooth worked?
 
Last edited:
Joined
Jul 31, 2018
Messages
6
Motherboard
Legion Y720
CPU
i5-7300HQ
Graphics
HD 630 / GTX 1060
Gentlemen! I have the following issues to fix:

  1. No keyboard backlight on Y720. Other function keys are working (Brightness, Volume)
  2. Strange behavior AirDrop: I can send files to my Hack from an iPhone but not from the Hack to the iPhone. AirDrop contacts on the hack are only visible when I search for AirDrop contacts on my iPhone. If I turn off Blutooth on the iPhone the contacts on the hack disappear. The iPhone itself is never visible on the Hack and Handoff also works only from iPhone to Hack, but not vice versa. Continuity Camera is not able to establish a connection to the iPhone. I have a BCM94352Z installed.
Any ideas? Thanks!
 
Joined
Jan 5, 2019
Messages
7
Motherboard
Lenovo Legion Y720
CPU
i7-7700HQ
Graphics
GTX 1060
Has anyone thought about trying to get the keyboard backlight to work? Would it be possible?
 
Joined
Feb 9, 2019
Messages
1
Motherboard
Lenovo Legion Y520
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + GTX 1050
Hello and thnx for creating such great guide @RehabMan, @the-braveknight.
Following your guide I created my first hackintosh with ease. I had a few problems though, I had to disable my Discrete graphics card to be able to boot up or it would reset before loading (black screen with apple icon and loading bar) ends.
After all I have one problem unsolved, though my blue-tooth works fine and connected to my blue-tooth mouse with no problems, yet I can't connect to wi-fi. Do u have any suggestions on solving this issue?
And I have 2 question:
  1. can I update this hackintosh?
  2. I did not set SMBIOS (actually idk how to do it), is it important to set it? if yes can u explain why or when it is important?
Thnx a lot.
 
Last edited:
Joined
Jan 13, 2017
Messages
249
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
HI to all. I try to install 10.14.3 on Y520 I use git method but there is problem with HD630. show only 7BM.
are someone have same problem ? and how to fix
 
Top