Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Joined
Jun 26, 2018
Messages
11
Motherboard
LENOVO Y520-15IKBN
CPU
I5-7300HQ/HM175
Graphics
HD 630 + GTX 1050
Mobile Phone
Android
Hello, I ve followed the steps buy I only get the Apple logo, it doesen t appear the bar.
Also, where I should put the SSDT
Thx
 
Joined
Oct 22, 2018
Messages
26
Motherboard
Lenovo Legion Y720
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + GTX 1060
Mobile Phone
iOS
UEFI Windows boot files can be rebuilt with BCDBOOT.EXE. You should read related Microsoft documentation.
I've been using Windows for a while now. I've lost Clover after rebuilding the boot files and I've been trying to get it back, but I couldn't do so using the efibootmgr. I've managed to boot into Mojave with my flash drive, but I couldn't mount the SYSTEM_DRV partition. I've done some research and found out that the problem is the Microsoft reserved disk, and the suggested way of solving it is to reinstall everything. is there a way to fix this without reinstalling?
update: I used the EFI mounting script you made and it worked!
 

Attachments

Last edited:
Joined
May 20, 2017
Messages
335
Motherboard
HP ENVY TS 14
CPU
i5-4200u
Graphics
HD 4400
Mobile Phone
Android
is it a good idea to follow this guide? i have legion y530...
 
Joined
Jul 29, 2016
Messages
13
Motherboard
Legions Y530
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
is it a good idea to follow this guide? i have legion y530...
I've taken this guide as reference and used creditor's excellent guidelines. Just i wouldn't use the git download method for y530 cause its mainly for y520, unless your pro at hackintosh and with clover to change it around.
and update the kext and SMBIOS since its coffee lake processor so its ideal to match close to SMBIOS's list
 
Joined
Jul 31, 2018
Messages
6
Motherboard
Legion Y720
CPU
i5-7300HQ
Graphics
HD 630 / GTX 1060
Hi, first of all Kudos for your work! I managed to install Mojave on my Y720. Almost everything is working thanks to your scripts. Since my Y720 has a ELAN Trackpad I tried to install the VoodooI2C kext, but the Trackpad isn't working. I noticed that during the DSDT patching all I2C devices were removed, so it is not possible to use the kext. Is this correct? If so, do you see an option to get those entries back somehow or use another method to make it work? A copy/paste from the original DSDT generates a lot of errors. Thank you so much!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,836
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
Hi, first of all Kudos for your work! I managed to install Mojave on my Y720. Almost everything is working thanks to your scripts. Since my Y720 has a ELAN Trackpad I tried to install the VoodooI2C kext, but the Trackpad isn't working. I noticed that during the DSDT patching all I2C devices were removed, so it is not possible to use the kext. Is this correct? If so, do you see an option to get those entries back somehow or use another method to make it work? A copy/paste from the original DSDT generates a lot of errors. Thank you so much!
As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/

please read the faq for proper hardware profile setup:
 
Joined
Jul 31, 2018
Messages
6
Motherboard
Legion Y720
CPU
i5-7300HQ
Graphics
HD 630 / GTX 1060
Sorry, I misunderstood something. The SSDT-Y720.aml is an add-on SSDT, so no wonder I cannot find any I2C device entries. :rolleyes: I found a solution by using the ApplePS2SmartTouchPad.kext but it has no multitouch functionality. Is there any hope to make the Trackpad work without using that kext? Thanks!
 
Joined
Sep 22, 2018
Messages
6
Motherboard
Lenovo Y520-15IKBN-Clover
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050 Ti, 1920x1080
Mobile Phone
Android
Hello again , i have problem i want an external screen so because i cant use hdmi port ( because its connected to nvidia ) i buy usb c hub with hdmi port but is not working when i connected all usb ports in the hub work except the hdmi port and when i connect to the hdmi port the laptop restart . how can i solve it ?
 
Joined
Jul 29, 2016
Messages
13
Motherboard
Legions Y530
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Sorry, I misunderstood something. The SSDT-Y720.aml is an add-on SSDT, so no wonder I cannot find any I2C device entries. :rolleyes: I found a solution by using the ApplePS2SmartTouchPad.kext but it has no multitouch functionality. Is there any hope to make the Trackpad work without using that kext? Thanks!
Question: is your lock screen working ? Cause every time I try to lock then screen stays lock down mode few seconds then goes black screen, any problem in your end ?
 
Top