Contribute
Register

[Guide] Lenovo Legion Y520/Y720 using Clover UEFI

Joined
May 28, 2014
Messages
24
Motherboard
LENOVO LEGION Y520-15IKBN - Clover UEFI
CPU
i7-7700HQ/HM175
Graphics
HD 630 + GTX 1050 (1920x1080)
What is your monitor model? My monitor model is LP156WF6-SPK3.Maybe this is the reason for the black screen?
Where did u check the monitor model?
 
Joined
Apr 5, 2011
Messages
49
Motherboard
Lenovo Y520-15ikbm (Clover UEFI)
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1060 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
My BIOS version is 5XCN20WW and I’m on APFS.
Please post your PR files when you can so I can compare them with mine. Are you using Rehabman's Clover or not and what version of Clover are you on?
 
Joined
Apr 5, 2011
Messages
49
Motherboard
Lenovo Y520-15ikbm (Clover UEFI)
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1060 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
Tried downgrading to 5XCN20WW and it didn't help.
 
Joined
Apr 5, 2011
Messages
49
Motherboard
Lenovo Y520-15ikbm (Clover UEFI)
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1060 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
What is your monitor model? My monitor model is LP156WF6-SPK3.Maybe this is the reason for the black screen?
My screen is LG Philips LP156WF6-SPK3, same as yours.
 
Joined
May 28, 2014
Messages
24
Motherboard
LENOVO LEGION Y520-15IKBN - Clover UEFI
CPU
i7-7700HQ/HM175
Graphics
HD 630 + GTX 1050 (1920x1080)
Here are my latest debug files. Still hanging on blank screen, can boot with -igfxvesa then I got intel hd 630 7mb dram.
Without this booting I'm booting blank screen whatever I try.
 

Attachments

Joined
May 28, 2014
Messages
24
Motherboard
LENOVO LEGION Y520-15IKBN - Clover UEFI
CPU
i7-7700HQ/HM175
Graphics
HD 630 + GTX 1050 (1920x1080)

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Did both still no success, new debug files attached with those 2 changes in place.
config.plist/ACPI/DisabledAML has SSDT-XCPM.aml listed,... as a result, it is not loading.
 
Joined
Jun 21, 2018
Messages
86
Motherboard
H170
CPU
7700HQ
Graphics
HD630 (1080p) + GTX 1060
@the-braveknight
So, um... since you have the same exact mode (with the 1060, storage and ram may be different) and have macos mojave installed, can you go into sleep and wake the system up and tell me if the cpu temp is higher by 2-4 degrees ?(if the gpu is on or not). Sorry about being so pushy about this, but reinstalling everything on my system would take like a week ( triple booting) and that's the only feature I'm interested in
 
Top