Contribute
Register

[Guide] Lenovo IdeaPad U330/U430/U530 using Clover UEFI

Joined
Aug 19, 2019
Messages
1
Motherboard
ASUS ROG STRIX H370-F
CPU
Intel Core i5 8600k
Graphics
XFX AMD Radeon HD 7950 3GB
Hi Rehabman,

I have used the U430 hack for 3 years now and planning to undertake another project. Essentially, planning on selling my U430 to get back some money while it's got value. Any recommendations for a good laptop to hack?. I'm thinking Lenovo T480 or Dell XPS new series.
 
Joined
Oct 8, 2014
Messages
87
Motherboard
Gigabyte GA-H97N-WiFi
CPU
i3-4360
Graphics
HD 4600
Hi RehabMan, I just started a fresh install for Mojave, wiped my drive clean. BIOS is still the same as I had it for High Sierra. Installation from USB went well but can't seem to be able to boot onto the target partition (Boot macOS from...). It goes in panic and reboots. This is always from USB clover, as I haven't accessed hard drive yet.

Also, I haven't bypassed APFS conversion.
My Clover screen gives me 5 options.

boot the installer from USB,
boot FileVault Prebooter from Preboot,
boot macOS install Prebooter from Preboot,
boot macOs from 'myHDD' and
Recovery Partition.

Heres my Clover folder:

I appreciate your help! :clap:
 

Attachments

  • EFI.zip
    2.3 MB · Views: 42
Last edited:
Joined
Jan 24, 2020
Messages
2
Motherboard
Lenovo Cherry 4a
CPU
i5 4200U
Graphics
HD 4400 + GT 730M
Hi there RehabMan. First of all thanks a million for this guide. I'd have never done it all, patches, sleep, pm and so on if it wasn't for your repositories. Now, I installed the Catalina 10.15.1 and it works flawlesly. Even an automatic update to Cat 10.15.2 occured in Clover, which started automatically when restarted. I realised it got intialised by itsself and I could'n stop it. But it went fine. I took the steps you wrote about that are necessary after each update and it's all fine.

But... I can't seem to get on with the touchpad. Yes it's Synaptics TM2334 but it is not recognised as a touchpad. Basic gestures do work like scroling. But there's no possibility to switch on one finger and two finger tap. So I have no functionality of wright and left mouse buttons with the trackpad.
 
Joined
Dec 10, 2010
Messages
31
Motherboard
Laptop Lenovo U430p
CPU
Intel> i5
Graphics
Intel HD4000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
hi all,
not sure this thread is still very active.
I did a new installation of mojave after having El capitan on my U430p
but i only have problems.
I could install mojave, with working wifi.
graphics seams unstable
no sound
battery and energy not functional

1- i was wondering if i need to fix mojave or directly go for a catalina install ?
2- which version of clover do you use ? (i tryed the latest from Rehabman but its old (4701RM), then v2.5k r5102UEFI...
3- in Post install when i install kext using ./install_downloads.sh, they are weirds info in terminal :
Warning: /AppleInternal/Library/Extensions: No such file or directory
(see attached screen grab)
4- my install was made in APSF format hard disk, not sure if this is why i have so many problems.
5- why is the config.plist which is copied at the end of the install set with a macbook 9,2 ? i thought U430 was macbook air 6,2 ?

thanks
 

Attachments

  • warnings.png
    warnings.png
    460.3 KB · Views: 24
  • EFI.zip
    2.3 MB · Views: 31
Last edited:
Joined
Jan 24, 2020
Messages
2
Motherboard
Lenovo Cherry 4a
CPU
i5 4200U
Graphics
HD 4400 + GT 730M
Yea, you can do both mojave and catalina with this tutorial and repositories. I tried both and both work with no problem, I stayed with mojave tho cause some of music software I use is still only mojave supported.
Anyway, yes it should be macbook air 6,2.
How come you made it with stock wifi working? Mine doesn't work. I'm planing to switch it to a supported card.

I can give the details of what clover I used with pendrive for instalation and what I installed later on my "macbook air's" disk.
Sorry, I just won't do it at the moment, after the whole day of working from home, I'm enjoying my beer and watching netflix. If that can wait, I'll give you the details tomorrow afternoon or monday-tuesday. Cheers.
 
Joined
Dec 10, 2010
Messages
31
Motherboard
Laptop Lenovo U430p
CPU
Intel> i5
Graphics
Intel HD4000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yea, you can do both mojave and catalina with this tutorial and repositories. I tried both and both work with no problem, I stayed with mojave tho cause some of music software I use is still only mojave supported.
Anyway, yes it should be macbook air 6,2.
How come you made it with stock wifi working? Mine doesn't work. I'm planing to switch it to a supported card.

I can give the details of what clover I used with pendrive for instalation and what I installed later on my "macbook air's" disk.
Sorry, I just won't do it at the moment, after the whole day of working from home, I'm enjoying my beer and watching netflix. If that can wait, I'll give you the details tomorrow afternoon or monday-tuesday. Cheers.

No, I replaced my wifi card years ago for El capitan use
Broadcom BCM94352HMB
It should work 100%, but mine on catalina is not providing bluetooth , something is failing in my install or the ID.

update:
-I used Clover 5107 in my last install
- most of the things work, except bluetooth

problems:
- when I change BIOS from Legacy to UEFI , i loose the proper graphics and can't have a decent visual.
- wondering why no Kexts are installed in S/L/E
-to solve my bluetooth and refering to RehabMan post '
The IDs on my broadcom card are: 14e4:43b1:106b:2154. Also reported as working is the same card with IDs: 14e4:43b1:106b:2123'
how can I change ID ?
- after sleep/wake the audio line out is generating parasite sound.
 
Last edited:
Joined
Jul 21, 2011
Messages
36
Motherboard
Lenovo U410 Touch
CPU
Core I7 2.0GHz
Graphics
Intel HD4000 and Geforce 710M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
No, I replaced my wifi card years ago for El capitan use
Broadcom BCM94352HMB
It should work 100%, but mine on catalina is not providing bluetooth , something is failing in my install or the ID.

update:
-I used Clover 5107 in my last install
- most of the things work, except bluetooth

problems:
- when I change BIOS from Legacy to UEFI , i loose the proper graphics and can't have a decent visual.
- wondering why no Kexts are installed in S/L/E
-to solve my bluetooth and refering to RehabMan post '
The IDs on my broadcom card are: 14e4:43b1:106b:2154. Also reported as working is the same card with IDs: 14e4:43b1:106b:2123'
how can I change ID ?
- after sleep/wake the audio line out is generating parasite sound.

Is your sleep working? I have everything working except that when my system wakes from sleep it reboots. For bluetooth you need to add bcrmbluetoothinjector.kext to make bluetooth work. Does that happen to you? I have a U430 touch. Can you share your EFI for catalina. Thanks
 
Joined
Dec 10, 2010
Messages
31
Motherboard
Laptop Lenovo U430p
CPU
Intel> i5
Graphics
Intel HD4000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Is your sleep working? I have everything working except that when my system wakes from sleep it reboots. For bluetooth you need to add bcrmbluetoothinjector.kext to make bluetooth work. Does that happen to you? I have a U430 touch. Can you share your EFI for catalina. Thanks
On catalina my system was not stable, by the way updating to 10.15.4. , my laptop started to reboot on screensaver.
wifi was working but it was not clean, it took 1min before starting and connecting, and bluetooth was absent.
find attached the clover i used, but i used many different :)

so, since this morning i re installed Mojave, and with basically the same EFI, I have wifi and bluetooth working...well all is working. So i think i will stick to Mojave for now.
but keep us aware about your install, i'm wondering if you can make it.
cheers
 

Attachments

  • EFI.zip
    3.4 MB · Views: 33
Joined
Jul 21, 2011
Messages
36
Motherboard
Lenovo U410 Touch
CPU
Core I7 2.0GHz
Graphics
Intel HD4000 and Geforce 710M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
On catalina my system was not stable, by the way updating to 10.15.4. , my laptop started to reboot on screensaver.
wifi was working but it was not clean, it took 1min before starting and connecting, and bluetooth was absent.
find attached the clover i used, but i used many different :)

so, since this morning i re installed Mojave, and with basically the same EFI, I have wifi and bluetooth working...well all is working. So i think i will stick to Mojave for now.
but keep us aware about your install, i'm wondering if you can make it.
cheers

Thanks for sharing your EFI. I only had problems with sleep and then reboots when i updated to 10.15.4 Catalina. I attached my EFI too just in case you want to try Catalina as we have the same wifi and bluetooth card. I saw your kext folder it was missing the airportbrcmfixup.kext (wifi), brcmbluetoothinjector and other brcm*.kext for the bluetooth. I was reading on different post that a lot has been problems with sleep, KP when they closed the lid, rebooting was happening after 10.15.4 update. My laptop was stable when I was in 10.15.3, meaning sleep has been working without issues. Let me know if it works if ever you try catalina again on your system.
 

Attachments

  • EFI.zip
    9.3 MB · Views: 57
Last edited:
Joined
Apr 5, 2020
Messages
3
Motherboard
Lenovo u330p
CPU
Intel I3-4010u
Graphics
Intel HD Graphic 4400
Mac
  1. MacBook Air
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hello, i have Lenovo u330p. EFI.zip in the last post will be good?
I want update my sierra to Catalina :O
 
Top