Contribute
Register

[Guide] Lenovo IdeaPad U330/U430/U530 using Clover UEFI

Joined
Mar 10, 2015
Messages
37
Motherboard
Lenovo ideapad s340-14iwl
CPU
i5-8265U
Graphics
UHD620
Mac
MacBook Pro
Mobile Phone
iOS
I have just update from sierra direct to mojave.

Some problems

1. No sound...my layout-ID is "2"

2. Airport Extreme kext to patch has no effect.

3. Brightness up and down keys are not make an issue.

4. When I open chrome ver.69.0.3497.100, graphic is garbling.

5. Other problems are not found yet.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have just update from sierra direct to mojave.

Some problems

1. No sound...my layout-ID is "2"

2. Airport Extreme kext to patch has no effect.

3. Brightness up and down keys are not make an issue.

4. When I open chrome ver.69.0.3497.100, graphic is garbling.

5. Other problems are not found yet.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
FYI: Guide moved to Mojave Laptop Guides forum.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
The gen_debug recommend to restart system and renew preboot.log.

I'll patch the file you recommend and notify you about results
Did you ever get around to this?
 
Joined
Nov 25, 2011
Messages
107
Motherboard
Lenovo u330 Touch
CPU
i7-4500U
Graphics
HD 4400
Mobile Phone
iOS
Hello, @RehabMan.

Being using your Guide to have my Lenovo u330 with macOS from Sierra's times.

Now I have High Sierra 10.13.4. Some days ago, I needed sound with my headphones. I realised the right channel sounded louder than the left one. Note: I suppose with the speakers is the same but I cannot perceive it.

So, I upgraded everything to the latest (latest Clover r4701, latest kexts...) from your Mojave guide.
Now, left channel doesn't sound; only the right one sounds. In Windows, the two audio channels work and they sound equally loud (using the same headphones).

I attach the debug files, thank you for helping me once more time.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello, @RehabMan.

Being using your Guide to have my Lenovo u330 with macOS from Sierra's times.

Now I have High Sierra 10.13.4. Some days ago, I needed sound with my headphones. I realised the right channel sounded louder than the left one. Note: I suppose with the speakers is the same but I cannot perceive it.

So, I upgraded everything to the latest (latest Clover r4701, latest kexts...) from your Mojave guide.
Now, left channel doesn't sound; only the right one sounds. In Windows, the two audio channels work and they sound equally loud (using the same headphones).

I attach the debug files, thank you for helping me once more time.
Your config.plist is not up-to-date. Make sure your copy of the repo is current, then read post #1, "Final config.plist".
 
Joined
Nov 25, 2011
Messages
107
Motherboard
Lenovo u330 Touch
CPU
i7-4500U
Graphics
HD 4400
Mobile Phone
iOS
Hello, Rehabman.
I have a Lenovo u330 touch, with Elan trackpad.
I upgraded my High Sierra to Mojave 10.14.3. It runs OK.
But I cannot upgrade to 10.14.5.
The process always stops at this point (image attached).
IMG-3395.JPG
I'm attaching, too, debug files.

Thank you very much,
 

Attachments

Joined
Nov 25, 2011
Messages
107
Motherboard
Lenovo u330 Touch
CPU
i7-4500U
Graphics
HD 4400
Mobile Phone
iOS
I think you will have to update Clover and your kexts first. Make sure not to forget the kexts in the EFI partition. Unfortunately, Rehabman's Clover fork has not been updated for a while, so you'll have to use the generic version for the time being.
Thanks for answering, @Dr.Tom-san.
I'll do it :)
 
Top