Contribute
Register

[Guide] Lenovo IdeaPad U330/U430/U530 using Clover UEFI

Joined
Jul 24, 2018
Messages
1
CPU
i5 4200
Graphics
HD 4400
I have lenovo u330p. Sierra is installed.
I have major of problem like no sound, no battery indicator, no brightness control.
So if i follow your lenovo u430 post installation,is it correct way ?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,973
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have lenovo u330p. Sierra is installed.
I have major of problem like no sound, no battery indicator, no brightness control.
So if i follow your lenovo u430 post installation,is it correct way ?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jul 29, 2015
Messages
1
CPU
i5
Graphics
HD 4400
Mac
MacBook Air
i have the same laptop lenovo u430 touch, but what wifi card that you can recommended me that passing the BIOS whitelist thing and compatible with mojave please

sorry for my poor english
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,973
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i have the same laptop lenovo u430 touch, but what wifi card that you can recommended me that passing the BIOS whitelist thing and compatible with mojave please

sorry for my poor english
Read post #1.
 
Joined
Aug 12, 2018
Messages
1
Motherboard
Lenovo U430p
CPU
i5 - 4200u
Graphics
Nvidia 730m
Great tutorial, thanks for all the work man.
Managed to get through the whole thing, clover booting from the SSD, but theres an issue I'm having - none of the kexts seem to have loaded on boot (graphics problems as well as unusable usb ports)
Its worth noting I've installed the kexts to L/E using kextbeast, added them to the EFI partition under kexts/other and the config.plist is the one hosted on your github repo.
Booting from usb seems to circumvent these issues which leads me to believe theres an issue with clover itself. Have also tried copying the EFI partition from the USB direct to the EFI partition on the laptop.
Any help is appreciated thanks.

Have attached the 2 most recent kernel panics, which might offer some insight - let me know if anything else is needed
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,973
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Great tutorial, thanks for all the work man.
Managed to get through the whole thing, clover booting from the SSD, but theres an issue I'm having - none of the kexts seem to have loaded on boot (graphics problems as well as unusable usb ports)
Its worth noting I've installed the kexts to L/E using kextbeast, added them to the EFI partition under kexts/other and the config.plist is the one hosted on your github repo.
Booting from usb seems to circumvent these issues which leads me to believe theres an issue with clover itself. Have also tried copying the EFI partition from the USB direct to the EFI partition on the laptop.
Any help is appreciated thanks.

Have attached the 2 most recent kernel panics, which might offer some insight - let me know if anything else is needed

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Nov 21, 2015
Messages
5
Motherboard
Lenovo U530 Touch
CPU
i7-4710u
Graphics
GT-730
Mobile Phone
Android
Hello RehabMan. Thank you very much for your guide. I am experiencing an error regarding the boot up when the patched SSDT is loaded. After the SSDT is installed/placed with `make install` it will cause an panic while booting.

I have attached the files required as stated in Problem Reporting.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,973
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello RehabMan. Thank you very much for your guide. I am experiencing an error regarding the boot up when the patched SSDT is loaded. After the SSDT is installed/placed with `make install` it will cause an panic while booting.

I have attached the files required as stated in Problem Reporting.
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Apr 10, 2013
Messages
48
Motherboard
GA Z77 DS3H
CPU
Intel Core i5 3750K
Graphics
Gigabyte GTX 650 Ti (2GB)
Mac
iMac
Mobile Phone
Android, iOS
Hello Mr. Rehabman, I know this thread should be used only to ask about High Sierra questions, although, I wanted to know if you'll make a guide for the new OS X Mojave and/or if you recommend to install it on the u430 Touch.
Thank you
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,973
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello Mr. Rehabman, I know this thread should be used only to ask about High Sierra questions, although, I wanted to know if you'll make a guide for the new OS X Mojave and/or if you recommend to install it on the u430 Touch.
Thank you
This guide already works with Mojave (either beta or master).
The beta branch contains some enhancements (patching via WhateverGreen/etc).

The beta branch will be merged into master later today.
 
Top