Contribute
Register

[Guide] Lenovo Ideapad 330S-14IKB Monterey 12.2.1

Joined
Jun 9, 2011
Messages
178
Motherboard
Gigabyte H107N-WiFi
CPU
i5-6500
Graphics
HD530
Mobile Phone
  1. Android
Sorry, I need some help here.

I followed the instructions (Section 1) in the first post to create the bootable installation disk. I successfully booted to OpenCore EFI bootloader on the USB thumb drive, but the OpenCore Boot Menu only has 1 item, i.e., "Reset NVRAM".
IMG_20220616_202549.jpg


I verified on another hackintosh box that the Monterey installer app on the USB thumb drive is able to run.

Here is the USB disk partition info:
Code:
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *15.9 GB    disk2
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk2s1
   2:                  Apple_HFS ⁨Install macOS Monterey⁩  15.6 GB    disk2s2

Here is the BIOS EFI boot selection.
IMG_20220616_202532.jpg



Edit: solved it by setting ScanPolicy to 0.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,065
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sorry, I need some help here.

I followed the instructions (Section 1) in the first post to create the bootable installation disk. I successfully booted to OpenCore EFI bootloader on the USB thumb drive, but the OpenCore Boot Menu only has 1 item, i.e., "Reset NVRAM".

I verified on another hackintosh box that the Monterey installer app on the USB thumb drive is able to run.

Here is the USB disk partition info:
Code:
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *15.9 GB    disk2
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk2s1
   2:                  Apple_HFS ⁨Install macOS Monterey⁩  15.6 GB    disk2s2
you will need to zip and upload your EFI
 
Joined
Jun 9, 2011
Messages
178
Motherboard
Gigabyte H107N-WiFi
CPU
i5-6500
Graphics
HD530
Mobile Phone
  1. Android
you will need to zip and upload your EFI
I simply downloaded the sample EFI from Github, then amended MLB, SystemSerialNumber and SystemUUID on config.plist with ProperTree. I did not edit any other fields.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,065
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Please see attached.

I simply downloaded the sample EFI from Github, then amended MLB, SystemSerialNumber and SystemUUID on config.plist with ProperTree. I did not edit any other fields.
and is it Monterey you are trying to boot?
 
Joined
Jun 9, 2011
Messages
178
Motherboard
Gigabyte H107N-WiFi
CPU
i5-6500
Graphics
HD530
Mobile Phone
  1. Android
and is it Monterey you are trying to boot?
I have trying to boot into the Monterey 12.4 installer that I have used the createinstallmedia tool to install onto the USB thumb drive. My IdeaPad 330S has a new, empty NVMe M.2 disk.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,065
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I have trying to boot into the Monterey 12.4 installer that I have used the createinstallmedia tool to install onto the USB thumb drive. My IdeaPad 330S has a new, empty NVMe M.2 disk.
you could try using HFSPlus.efi instead of OpenHfsPlus.efi

make sure bios settings are correct and the latest bios version

what make and model nvme is now in there?
 
Last edited:
Joined
Jun 9, 2011
Messages
178
Motherboard
Gigabyte H107N-WiFi
CPU
i5-6500
Graphics
HD530
Mobile Phone
  1. Android
you could try using HFSPlus.efi instead of OpenHfsPlus.efi

make sure bios settings are correct and the latest bios version

what make and model nvme is now in there?
Samsung 980 250GB NVMe M.2 and is corrected detected in BIOS setup.

BIOS is updated to the latest version: 7SCN36WW

I copied the working EFI of my other laptop to the USB thumbdrive, and booted it up on that laptop. The installer shows up.

Then, I reverted to the IdeaPad 330S EFI (github), but replaced the Release OC 0.78 files with the OC 0.78 Debug versions. And edited config.plist to enable debugging support. I have attached the debug logs. But here's the tail of the logs (I added "******" to highlight the pertinent errors):
Code:
155:937 00:247 OC: OcMiscLateInit...
156:183 00:245 OC: Translated HibernateMode None to 0
156:429 00:246 OC: Hibernation activation - Invalid Parameter, hibernation wake - no
156:675 00:246 OC: Panic log does not exist
156:922 00:246 OC: OcLoadKernelSupport...
157:168 00:246 OC: All green, starting boot management...
157:415 00:246 OC: Ready for takeoff in 0 us
157:661 00:245 OCB: Invalid device policy (200000/10F0103) for 7CD7A358 ************
157:941 00:279 OCB: Adding fs 7CD7A358 (E:1|L:1|P:Security Violation) - PciRoot(0x0)/Pci(0x14,0x0)/USB(0x2,0x0)/HD(1,GPT,6192E830-9C3F-44C9-8AD7-79B5C053AC57,0x28,0x64000) ************
158:187 00:246 OCB: Invalid device policy (200000/10F0103) for 7CD7A598 ************
158:434 00:246 OCB: Adding fs 7CD7A598 (E:1|L:0|P:Security Violation) - PciRoot(0x0)/Pci(0x14,0x0)/USB(0x2,0x0)/HD(2,GPT,D9811E54-0D2A-4688-B533-A245970A5D97,0x64028,0x1D08BB0) ************
158:681 00:246 OCB: Found 0 potentially bootable filesystems  ************
158:927 00:246 OCB: BootOrder/BootNext are not present or unsupported
159:173 00:246 OCB: Adding fs 2007C5F5 for 0 custom entries and nvram reset (aux shown)
159:420 00:246 OCB: Processing blessed list
159:665 00:245 OCB: Adding system entry Reset NVRAM
159:911 00:246 OCB: Registering entry Reset NVRAM [ResetNVRAM:NVRAMTool] (T:256|F:0|G:0|E:0|B:0) - <nil>
160:158 00:246 OCB: Showing menu...
160:404 00:246 OCHK: InitHotKeys
160:651 00:246 OCKM: Allocated key repeat context 7C570558 7C570858 7C570618
160:897 00:246 OCAE: Set screen resolution to 1920x1080 - Success
161:143 00:246 OCTY: Registered handler
Maybe the fault has to do with the "invalid device policy" error messages?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,065
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Samsung 980 250GB NVMe M.2 and is corrected detected in BIOS setup.

BIOS is updated to the latest version: 7SCN36WW

I copied the working EFI of my other laptop to the USB thumbdrive, and booted it up on that laptop. The installer shows up.

Then, I reverted to the IdeaPad 330S EFI (github), but replaced the Release OC 0.78 files with the OC 0.78 Debug versions. And edited config.plist to enable debugging support. I have attached the debug logs. But here's the tail of the logs (I added "******" to highlight the pertinent errors):
Code:
155:937 00:247 OC: OcMiscLateInit...
156:183 00:245 OC: Translated HibernateMode None to 0
156:429 00:246 OC: Hibernation activation - Invalid Parameter, hibernation wake - no
156:675 00:246 OC: Panic log does not exist
156:922 00:246 OC: OcLoadKernelSupport...
157:168 00:246 OC: All green, starting boot management...
157:415 00:246 OC: Ready for takeoff in 0 us
157:661 00:245 OCB: Invalid device policy (200000/10F0103) for 7CD7A358 ************
157:941 00:279 OCB: Adding fs 7CD7A358 (E:1|L:1|P:Security Violation) - PciRoot(0x0)/Pci(0x14,0x0)/USB(0x2,0x0)/HD(1,GPT,6192E830-9C3F-44C9-8AD7-79B5C053AC57,0x28,0x64000) ************
158:187 00:246 OCB: Invalid device policy (200000/10F0103) for 7CD7A598 ************
158:434 00:246 OCB: Adding fs 7CD7A598 (E:1|L:0|P:Security Violation) - PciRoot(0x0)/Pci(0x14,0x0)/USB(0x2,0x0)/HD(2,GPT,D9811E54-0D2A-4688-B533-A245970A5D97,0x64028,0x1D08BB0) ************
158:681 00:246 OCB: Found 0 potentially bootable filesystems  ************
158:927 00:246 OCB: BootOrder/BootNext are not present or unsupported
159:173 00:246 OCB: Adding fs 2007C5F5 for 0 custom entries and nvram reset (aux shown)
159:420 00:246 OCB: Processing blessed list
159:665 00:245 OCB: Adding system entry Reset NVRAM
159:911 00:246 OCB: Registering entry Reset NVRAM [ResetNVRAM:NVRAMTool] (T:256|F:0|G:0|E:0|B:0) - <nil>
160:158 00:246 OCB: Showing menu...
160:404 00:246 OCHK: InitHotKeys
160:651 00:246 OCKM: Allocated key repeat context 7C570558 7C570858 7C570618
160:897 00:246 OCAE: Set screen resolution to 1920x1080 - Success
161:143 00:246 OCTY: Registered handler
Maybe the fault has to do with the "invalid device policy" error messages?
set ScanPolicy to 0

also add -v to boot-args
 
Joined
Jun 9, 2011
Messages
178
Motherboard
Gigabyte H107N-WiFi
CPU
i5-6500
Graphics
HD530
Mobile Phone
  1. Android
set ScanPolicy to 0

also add -v to boot-args
ScanPolicy was "17760515" and after changing to "0", it works! Thank you so much!!! :)
 
Top