Contribute
Register

[Guide] Lenovo Ideapad 330S-14IKB Big Sur 11.2.3 Opencore

Joined
May 10, 2019
Messages
145
Motherboard
Lenovo Ideapad 330S-14IKB 81F400PFIN
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
How to enable trackpad prefpane?
I upgrade from Clover 5122 Catalina to OpenCore 0.6.3 Big Sur , everything fine except Alps prefpane. My rig is Yoga 500-15IBD.
Use the right VoodooI2C kexts according to your trackpad. The ones in my repo is VoodooCHID because mine is a windows precision trackpad. Yours may not be the same.
 
Joined
Jul 31, 2019
Messages
9
Motherboard
Lenovo IP 330s 14IKB 81F4
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
1605499435873.png

I have a problem that Windows cannot boot, when boot is selected the Windows logo appears and then immediately restarts
 
Joined
Apr 10, 2016
Messages
621
Motherboard
<< need model # >> See Forum Rules !!
CPU
I3 5020U
Graphics
Hd5500
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Use the right VoodooI2C kexts according to your trackpad. The ones in my repo is VoodooCHID because mine is a windows precision trackpad. Yours may not be the same.
View attachment 496287
I have a problem that Windows cannot boot, when boot is selected the Windows logo appears and then immediately restarts
OC has problem booting windows due to ACPI patch
I use rEFInd to tripleboot Big Sur, Win 10, and Android

Ah my prefpane now work, also battery status, I have to reorder kext load.
Screen Shot 2020-11-16 at 11.09.56.png
 
Joined
May 10, 2019
Messages
145
Motherboard
Lenovo Ideapad 330S-14IKB 81F400PFIN
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
View attachment 496287
I have a problem that Windows cannot boot, when boot is selected the Windows logo appears and then immediately restarts
My Windows boots just fine, but maybe that's because it's on my second disk. Try adding an entry via OpenCore configurator under Misc>Boot>Entries. You have to include the full path to your Windows boot efi.
You also might want to take a look at this.
 
Joined
Feb 2, 2019
Messages
28
Motherboard
Lenovo Ideapad 330s-15ikb
CPU
i5-8250u
Graphics
UHD620
Mobile Phone
  1. iOS
How much HDMI ports does your ideapad have? Maybe you could give me the exact model number. Trying to figure out some problems that occurred with my ideapad 330s 15ikb 81F5 after some latest kext updates. My video ports are mapped (internal LVDS and external HDMI) but somehow I get a black screen on external monitors when I wake the laptop. So I have to re plug the hdmi cable.
 
Joined
May 10, 2019
Messages
145
Motherboard
Lenovo Ideapad 330S-14IKB 81F400PFIN
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
How much HDMI ports does your ideapad have? Maybe you could give me the exact model number. Trying to figure out some problems that occurred with my ideapad 330s 15ikb 81F5 after some latest kext updates. My video ports are mapped (internal LVDS and external HDMI) but somehow I get a black screen on external monitors when I wake the laptop. So I have to re plug the hdmi cable.
Just one HDMI. Works just fine even after sleep including outputting audio to my TV. The exact model can already be seen under the motherboard description.
 
Joined
Feb 2, 2019
Messages
28
Motherboard
Lenovo Ideapad 330s-15ikb
CPU
i5-8250u
Graphics
UHD620
Mobile Phone
  1. iOS
do you have any wake or sleep issues? i´m asking because the frambuffer you´re using of the UDH617 has 3 ports in total (1 internal, 2 external DPs) and you didn´t disable the second external port. did you disable the second port in another way? maybe that could be an issue for my HDMI black screen problem
 
Joined
Jul 31, 2019
Messages
9
Motherboard
Lenovo IP 330s 14IKB 81F4
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
do you have any wake or sleep issues? i´m asking because the frambuffer you´re using of the UDH617 has 3 ports in total (1 internal, 2 external DPs) and you didn´t disable the second external port. did you disable the second port in another way? maybe that could be an issue for my HDMI black screen problem
try adding this argument at boot
igfxonln = 1
 
Joined
Jan 5, 2011
Messages
12
Motherboard
Gigabyte B365M DS3H
CPU
I7 9700KF
Graphics
Gigabyte RX 570 4GB
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I have a Lenovo 330S/I3-8130. I installed Big Sur and it was a success but I have a problem with my wifi. I have an Intel 8265 wifi card and it works great with Catalina so I removed all the Broadcom files and added the Intel kext files. I rebooted but got a kernel panic (MACH REBOOT). I put your EFI back and it's working again. I'm thinking that maybe the Intel kext files are causing the kernel panic so I just removed the Broadcom files from the KEXT folder and removed statements from Kernel using Property Tree (Snapshot). I did not add the Intel kext's to the KEXT folder yet. Same issue, what could be causing this issue?
Thanks!
 
Top