Contribute
Register

[Guide] Lenovo G50-80 post-installation, macOS Mojave 10.14.3

Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
This guide is originally posted on GitHub , now I'm sharing it here and hoping more people can learn something from this post.

Warning: Please read this guide carefully. Simply copying my configuration file is very likely to not work (because there are many different Lenovo G50-80 according to PSREF), although you can still play around. You should apply the same steps as mine to get your Hackintosh working on your laptop. If you still want to try, please download it here.

Happy hacking

Specs

Code:
Model: Lenovo G50-80
Bios version: B0CNA0WW
CPU: i5 5200U, HD 5500 Graphic
RAM: 8GB
Hard drive: Kingston 256 GB SSD + 1 TB Seagate HDD
Audio: Conexant CX20752
Ethernet: RTL8111

BIOS update and specs can be found at here, or simply use this link https://download.lenovo.com/consumer/mobiles/b0cna0ww.exe to download the BIOS update.

DSDT patches

See patches.txt. I only patched DSDT.aml and ignored all SSDT-*.aml.
Please follow the DSDT patching tutorial by RehabMan carefully, and you may find this video very helpful.
The patched results can be found at EFI/CLOVER/ACPI/patched.

Brightness adjustment keys

For me, my laptop use F11/F12 for brightness down/up, so I have to map these keys to brightness adjust methods. By following Patching DSDT/SSDT for LAPTOP backlight control, I found my laptop use EC query methods (ACPI) for those keys. (This is the case with most modern laptops.) The Consloe.log shows they are _Q11 and _Q12. So the patch I used for mapping these keys is (see also in patches.txt):

Code:
into method label _Q11 replace_content
begin
// Brightness Down\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0405)\n
end;
into method label _Q12 replace_content
begin
// Brightness Up\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0406)\n
end;

The ACPI debug version of my EFI configuration can be found at EFI_with_ACPI_DEBUG. I basically added the ACPIDebug.kext and then patched the DSDT with Add DSDT Debug Methods and Instrument EC Queries from https://github.com/RehabMan/OS-X-ACPI-Debug (add the source to MaciASL).
Bluetooth
Go to Windows device manager and find your bluetooth's vid and pid information:

Code:
USB\VID_105B&PID_E065&REV_0112
USB\VID_105B&PID_E065

Convert the hex to decimal using google search or any tool you prefer:

Code:
hex E065 == decimal 57445
hex 105B == decimal 4187

Add the following to S/L/E/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Contents/Info.plist -> IOKitPersonalities:

XML:
<dict>
    <key>Lenovo G50 80 Bluetooth</key>
    <string>com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport</string>
    <key>IOClass</key>
    <string>BroadcomBluetoothHostControllerUSBTransport</string>
    <key>IOProviderClass</key>
    <string>IOUSBHostDevice</string>
    <key>idProduct</key>
    <integer>57445</integer>
    <key>idVendor</key>
    <integer>4187</integer>
</dict>

A demo patched Info.plist can be found at Bluetooth/Info.plist.
Note that in order to let the native Bluetooth work, we have to boot into Windows or Linux first, and then restart into macOS. This is known as RAMUSB device firmware update problem. If you find any solution or want to discuss/fix this, please open an issue.

394987

Kexts

Note: All kexts used can be found at EFI/CLOVER/kexts/Other, and I prefer to only install kexts to EFI folder instead of /S/L/E or /L/E for better update experience.
  • Keyboard and trackpad: VoodooPS2Controller.kext (I used the debug version for testing keys are PS2 or ACPI). I personally would like to enable single tap on trackpad in System Preferences -> Trackpad -> Tap to click, also enable one-finger tap & drag in System Preferences -> Accessibility -> Mouse & Trackpad -> Trackpad options -> Enable dragging without drag lock.
  • Audio: AppleALC.kext + layout-id=3, HDMI audio fixed with WhateverGreen framebuffer patching, see here.
  • Ethernet: RealtekRTL8111.kext
  • Graphics: Lilu.kext + WhateverGreen.kext, note you will need use config_HD5300_5500_6000.plist by RehabMan to set stolenmem to 19 MB and cursormem to 9 MB, see this and this. Also, you should enable 'Legacy support' in BIOS's boot tab to avoid glitches, see this post.
  • Battery status: ACPIBatteryManager.kext + the [bat] Lenovo G50-70 DSDT patch
Further working
At present, everything is working except:
  1. Brightness adjustment -- Done
  2. Wake from sleep -- Unsolvable Disable sleep as a workaround, see my post on tonymacx86.
Links
  1. tonymacx86 FAQ
  2. The same model guide on tonymacx86
  3. Solve error when patching DSDTs
  4. Guide for i3 version of Lenovo G50-80 in tonymacx86
  5. Video guide for i3 version
  6. Get bluetooth vid & pid from windows
  7. Inject bluetooth kext
 
Last edited:
Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
Reserved.
 
Last edited:
Joined
Dec 17, 2017
Messages
228
Motherboard
Dell Inspiron 3543
CPU
i3-5005u
Graphics
Intel HD 5500 Graphics
Mac
  1. MacBook
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
I may have a solution, or at least something to narrow down why the broadwell black screen on wake occurs.

In hackintool, choose ig-platform-id 16260006, (which will be the one that will replace what you have currently) go to connectors, and make the LVDS as a dummy connector, making the Internal screen turn completely off (after reboot). Then plugin and external monitor, and change it to the correct connector (HDMI, DP, ect) Then reboot. Once rebooted plugin your external monitor and hopefully it will output your login screen. Put the laptop to sleep (fully sleep, 15-25 seconds) then wake it up, repeat this about 2-3 times, if the black screen problem does not occur, then we can confirm it is something with the internal display.
 
Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
Thanks for that information, I will try it out at weekend.
 
Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
I may have a solution, or at least something to narrow down why the broadwell black screen on wake occurs.

In hackintool, choose ig-platform-id 16260006, (which will be the one that will replace what you have currently) go to connectors, and make the LVDS as a dummy connector, making the Internal screen turn completely off (after reboot). Then plugin and external monitor, and change it to the correct connector (HDMI, DP, ect) Then reboot. Once rebooted plugin your external monitor and hopefully it will output your login screen. Put the laptop to sleep (fully sleep, 15-25 seconds) then wake it up, repeat this about 2-3 times, if the black screen problem does not occur, then we can confirm it is something with the internal display.
Yes, the external works perfectly like I have mentioned in https://www.tonymacx86.com/threads/...sleep-on-mojave-10-14-3-lenovo-g50-80.271315/
I think it's really strange, I don't know why macOS cannot wake my internal screen, but the external is okay!
 
Joined
Dec 17, 2017
Messages
228
Motherboard
Dell Inspiron 3543
CPU
i3-5005u
Graphics
Intel HD 5500 Graphics
Mac
  1. MacBook
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
Yes, and this is beyond of my knowledge.
 
Joined
Apr 3, 2019
Messages
2
Motherboard
MSI B450 tomahack
CPU
ryzen2200G
Graphics
VEGA 8
Hi JackLeeu,

my laptop :
Lenovo Z51-70
processor: i5 -5200U
graphics internal: HD 5500
GPU: AMD 375M(mine has broken and I have disabled it completely in the bios )


First of all, thanks for the guide. I was trying a Hackintosh my Lenovo Z51 from 2016 and never got this close achieving that.
I know you have suggested not to use your EFI file directly but I did(sorry for that). and you know what it worked flawlessly.

------what works------
Audio
Ethernet
USB ports

-------what does not work-------:crazy::|:thumbdown:cry:
Keyboard
trackpad

first, I followed this guide (https://kb.hackintoshisfun.ml/clover/) to prepare USB (not clover and EFI)
later I replaced the EFI folder that you attached updated it with clover pkg (as not updating it didn't show the mac os install USB at all)
and it worked. I got into the language selection menu on the installation but no keyboard and trackpad. I thought it may be an issue with clover ( new version of clover not injecting ethernet kext in the installation) so I used my USB mouse and keyboard and completed the installation it was successful everything works great except trackpad and keyboard.
I tried everything I was able to find online and I couldn't find anything that solved my problem.
do you have any thoughts as to why this happened and what can I do to solve this?

PS: I really appreciate for your work. because hackintishing that laptop was my dream for a very long time and as it got old I just stopped using that laptop and bought a pc. a week back I have successfully installed mac os on my pc and wanted to try it on my old laptop and thats how I landed here.
 

Attachments

  • EFI.rar
    4.8 MB · Views: 143
Joined
Mar 22, 2017
Messages
106
Motherboard
Lenovo G50-80 + Clover
CPU
i5-5200U
Graphics
HD 5500 & R5 M230
Mobile Phone
  1. Android
Hi JackLeeu,

my laptop :
Lenovo Z51-70
processor: i5 -5200U
graphics internal: HD 5500
GPU: AMD 375M(mine has broken and I have disabled it completely in the bios )


First of all, thanks for the guide. I was trying a Hackintosh my Lenovo Z51 from 2016 and never got this close achieving that.
I know you have suggested not to use your EFI file directly but I did(sorry for that). and you know what it worked flawlessly.

------what works------
Audio
Ethernet
USB ports

-------what does not work-------:crazy::|:thumbdown:cry:
Keyboard
trackpad

first, I followed this guide (https://kb.hackintoshisfun.ml/clover/) to prepare USB (not clover and EFI)
later I replaced the EFI folder that you attached updated it with clover pkg (as not updating it didn't show the mac os install USB at all)
and it worked. I got into the language selection menu on the installation but no keyboard and trackpad. I thought it may be an issue with clover ( new version of clover not injecting ethernet kext in the installation) so I used my USB mouse and keyboard and completed the installation it was successful everything works great except trackpad and keyboard.
I tried everything I was able to find online and I couldn't find anything that solved my problem.
do you have any thoughts as to why this happened and what can I do to solve this?

PS: I really appreciate for your work. because hackintishing that laptop was my dream for a very long time and as it got old I just stopped using that laptop and bought a pc. a week back I have successfully installed mac os on my pc and wanted to try it on my old laptop and thats how I landed here.
Glad to hear that it works on your laptop, nevertheless it is a different model. I have several suggestions about you keyboard & trackpad:

1. Did you read the FAQ? There are several guides about fixing the keyboard & trackpad.
2. For me, my keyboard & trackpad is Synaptics, so it is better to use VoodooPS2Controller.kext, if it is not the case of your laptop, please try other alternatives (other kexts & hotpatch, etc.), good luck! I will be appreciated if you can post your solution here.
 
Joined
Sep 3, 2020
Messages
4
Motherboard
Lenovo G50-80 80E501GQIX
CPU
i5-5200u
Graphics
intel HD5500 + Radeon R5 m330
same laptop but elan trackpad.....I am trying to manage to make it working.....
 
Last edited:
Top