Contribute
Register

[Guide] Lenovo G50-80 80L0 and Catalina 10.15.2

Joined
Sep 17, 2012
Messages
6
Motherboard
Lenovo G50-80
CPU
i5-5200U
Graphics
HD 5500
Mac
MacBook Pro
Mobile Phone
iOS
Hi @dandelionclock,

Everything is working fine but facing problem with display & night mode issue with Catalina 10.15.2 on Lenovo G50-80 5400U display. Please see the attached EFI folder and guide me where is doing mistake?

Thanks in advance
 

Attachments

Joined
May 29, 2018
Messages
90
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
Hi @dandelionclock,

Everything is working fine but facing problem with display & night mode issue with Catalina 10.15.2 on Lenovo G50-80 5400U display. Please see the attached EFI folder and guide me where is doing mistake?

Thanks in advance
What display and night mode issue???
 
Joined
May 29, 2018
Messages
90
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
No, I removed it.
Is your laptop using the same RTL8821AE chipset for wifi+bluetooth?
No mine is intel. Bluetooth 4.0 works out of the box for me but it does not connect to a lot of my LE peripherals so I don’t really use it.
 
Last edited:
Joined
May 29, 2018
Messages
90
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
You don't need applebacklightfixup now that Whatevergreen is handling it. It's probably confusing the system now coz you have both
update Lilu to 1.4.0 and Whatevergreen to 1.3.5
you also don't need appleps2 and voodoops2 .
also no need applealc and voodoohda
 
Joined
Sep 17, 2012
Messages
6
Motherboard
Lenovo G50-80
CPU
i5-5200U
Graphics
HD 5500
Mac
MacBook Pro
Mobile Phone
iOS
You don't need applebacklightfixup now that Whatevergreen is handling it. It's probably confusing the system now coz you have both
update Lilu to 1.4.0 and Whatevergreen to 1.3.5
you also don't need appleps2 and voodoops2 .
also no need applealc and voodoohda
I have updated Lilu and Whatevergreen both and removed Applebacklightfixup kext but it is not working please see the my EFI folder again and guide me where I am doing mistake. Thanks
 
Joined
May 29, 2018
Messages
90
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
I have updated Lilu and Whatevergreen both and removed Applebacklightfixup kext but it is not working please see the my EFI folder again and guide me where I am doing mistake. Thanks
Gotta read carefully. Use only one of the two following methods. You did both.

Step 9: backlight brightness
  1. Method 1: Put the attached SSDT-PNLF in /EFI/Clover/ACPI/patched
  2. Method 2: Check these boxes in clover configurator:
    1. ACPI -> Fixes -> Page 2 -> AddPNLF
    2. Devices -> SetIntelBacklight & SetIntelMaxBacklight
 
Joined
Sep 17, 2012
Messages
6
Motherboard
Lenovo G50-80
CPU
i5-5200U
Graphics
HD 5500
Mac
MacBook Pro
Mobile Phone
iOS
Gotta read carefully. Use only one of the two following methods. You did both.
apology, but I choose Method 2 but unfortunately not work. Attached EFI folder is latest please see.
 

Attachments

Joined
May 29, 2018
Messages
90
Motherboard
Dell XPS 8930
CPU
i7-8700
Graphics
RX 580
apology, but I choose Method 2 but unfortunately not work. Attached EFI folder is latest please see.
You've set a platform_id but not a device_id for your IGPU for Whatevergreen. My suspicion is WhateverGreen thus failed to detect what IGPU you really have, and therefore unable to inject the proper IntelMaxValue for you. Your quick sync probably won't work either.

You should find this post helpful:
 
Top