Contribute
Register

[Guide] Lenovo G50-70 Yosemite using Clover

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman !!

I remove the "GenericUSBXHCI.kext" and plug-in the mouse at USB3 port. Works ok, but always appears the Bluetooth keyboard detection at start-up the system. I tried to disable the option but was unable. It's a minor problem that I will try to solve later.
SysPrefs->Bluetooth->Advanced. Uncheck the boxes.
 
Joined
Apr 16, 2012
Messages
28
Motherboard
Laptop Lenovo G50-70
CPU
i7-4500U
Graphics
HD 4400
Mac
iMac, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
SysPrefs->Bluetooth->Advanced. Uncheck the boxes.
It seems that Yosemite has a problem with the bluetooth discovery process... As far as I know is impossible dissable. I unchecked the mentioned options; I tried to turn off the Bluetooth process via the Bluetooth preferences panel but the "turn off" button is in grey; I deleted the "com.apple.Bluetooth.plist" from /Library/Preferences but every system restart the plist is re created...

Interesting issue!!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
It seems that Yosemite has a problem with the bluetooth discovery process... As far as I know is impossible dissable. I unchecked the mentioned options; I tried to turn off the Bluetooth process via the Bluetooth preferences panel but the "turn off" button is in grey; I deleted the "com.apple.Bluetooth.plist" from /Library/Preferences but every system restart the plist is re created...

Interesting issue!!
The ability to turn off the bluetooth device is only available with certain hardware (possibly only Broadcom).

You'll get better results with Bluetooth if you have compatible bluetooth hardware.
 
Joined
Apr 16, 2012
Messages
28
Motherboard
Laptop Lenovo G50-70
CPU
i7-4500U
Graphics
HD 4400
Mac
iMac, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
Hi Rehabman !!

Finally I have my laptop working. I modified the guide with minor changes.

The only black hole is regarding the Bluetooth services. Due to I don't need the bluetooth I erase the IOBluetoothFamily.kext and IOBluetoothHIDDriver.kext from System/library/extensions, and all the USB ports works OK.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman !!

Finally I have my laptop working. I modified the guide with minor changes.

The only black hole is regarding the Bluetooth services. Due to I don't need the bluetooth I erase the IOBluetoothFamily.kext and IOBluetoothHIDDriver.kext from System/library/extensions, and all the USB ports works OK.
Which bluetooth hardware is installed in the laptop?

The idea of removing the bluetooth kexts is a good one, even if only done temporarily to isolate the problem with USB... :thumbup:
 
Joined
Apr 16, 2012
Messages
28
Motherboard
Laptop Lenovo G50-70
CPU
i7-4500U
Graphics
HD 4400
Mac
iMac, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
The bluetooth card installed in my Lenovo G50-70 is: Realtek RTL8723BE 802.11bgn + BT

And, As far as I know isn't supported !!! :thumbdown:
 
Joined
Jul 17, 2013
Messages
9
Motherboard
Lenovo G50-70
CPU
Core i3-4030U/Haswell-ULT
Graphics
HD4400, 1366x768
Mac
Classic Mac
Mobile Phone
Everything goes well with my g50-70 until I get to fixing the syntax errors after disassembly. After clicking compile in MacIASL it shows 17 errors then 15 after applying the two fixes given above. Can't seem to get around this part.

Also, After installing clover on HDD and restarting EFI isn't visible. Should I restart after the install or finish with the patches first?

Did you ever get the trackpad working?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Everything goes well with my g50-70 until I get to fixing the syntax errors after disassembly. After clicking compile in MacIASL it shows 17 errors then 15 after applying the two fixes given above. Can't seem to get around this part.
No one can see what you're seeing if you don't post your files.

Note: You're probably not following the instructions... You should double check.

Also, After installing clover on HDD and restarting EFI isn't visible.
You must mount EFI manually -- it is not mounted automatically.
 
Joined
Jul 17, 2013
Messages
9
Motherboard
Lenovo G50-70
CPU
Core i3-4030U/Haswell-ULT
Graphics
HD4400, 1366x768
Mac
Classic Mac
Mobile Phone
I'll double check and start from scratch. I'm fairly new to disassembling DSDTs and using MacIASL so the the guides can be all little advanced as I'm not familiar with all the terms.

I've tried using EFI mounter v2 and terminal but I get "doesn't exist" errors. So I end up reinstalling Clover to access the DSDTs. Hopefully that's not the issue.
 
Top