Contribute
Register

[Guide] Lenovo Flex 15 - 99% Compatibility Guide | macOS Catalina

Joined
Jan 1, 2018
Messages
3
Motherboard
st6
CPU
i5 haswell
Graphics
hd4400
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
ok.But keep in mind, sort of built this about a month ago, never got chance to clean it, debug it etc.Just got it onto disk.I can't see me comming back to it, corona, key work, just too busy.
Do this:
Before you start,open config.plist and fill your Platform infos.You can use MackBookPre11,1 or macBookAir6,2.Both works, think 6,2 should work better, got here 11,1 works fine, but didn't really checked and compared,Maybe you have more time to see.
Put this EFI on USB,Not SSD,till you happy enough with it.This EFI won't boot Catalina,so don't touch you clover till final, or fix it.
1.create new partition(about 20-30gb,APFS)beside your CATALINA.
2.Update your Catalina,run update BUT:select installation target to your new partition.recommend that.your Catalina will be working untouched and you can fix big sur just rebooting into her.
When I tried to install it clean from usb media, install failed as not possible to install on this Mac(so said the installer).update worked no problems, keep drinking coffee, no need to do anything.Just the reboot hanging, when your verbose disapears and screen turns black for longer, you shut her down and turn on again.The verbose is pretty busy all the times you won't miss it.
3.when asked for reboot, make sure,now you booting with open core from your USB,and picking installer.follow installer and make coffee.
4.All works, play with it.
5.If you happy with it do the whole thing again with your Catalina partition and remove your created one.

I ran into:
When putting OC from USB on SSD,Boot did not activate my wifi card when I booted from SSD,OSX did recognise it correctly and all looked ok, but she just did not turn on.Booting into windows created the same result.
When I booted from USB,No problems(OSX or WIN10)
If this happen to you you have to fysically unplug the mini card(Bcm94352hmb - my case),turn pc on/of,then plug in back and solved.
don't know why,I did it 3-times and the problem is gone for good now, i don't know why again.

This might not look like that but it is simple as there is not much needed to be done to get it in.I got this pc from eBay for £70,and it runs the latest osx...?
Like a said, you got straight away your Full Graphic,brightnes,audio,keyboard,HDMI with audio,osx audio, wifi(62mb/s-which my networks real speed)/bt,LAN,track pad(1 finger),CPU temp and power,USBs,You probably need to install alcPlugFix for your jack(I didn't do that,airpods works perfect so why?)
You are not getting touch screen(can't do,mine is broke),reboot issue, shutdown no prob, card reader, the rest I never tested.
whenever you ll be finished, clean up EFI,I left it in mess, not needed kexts, or not wrong ones,DSDT.aml have nothing got to do in ACPI folder(my improper shortcut get this going) etc, etc,.
THIS IS JUST A ROUGH BUILD,and I blame Corona for not having time to finish it.
If someone can, upload this EFI cleaned,Thanks.
BTW let me know how it worked for you.
 

Attachments

  • EFI-Flex15-haswell.zip
    10.2 MB · Views: 8
Last edited:
Top