Contribute
Register

[GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

Status
Not open for further replies.
Joined
Oct 11, 2017
Messages
74
Motherboard
Lenovo 510s-14isk (OpenCore UEFI)
CPU
i5-6257u
Graphics
Iris 550, 1920x1080
I've created a custom voodoops2controller with modifying resolution and scrollresolution so it feels better to use, still need to set tracking speed to max though in system preferences.
In case for anyone who uses custom precision touchpad when using windows like me, and it feels weird with default setting of the kext.

Edit: Also forgot that the best layout-id for applealc is so far 15. But the only working internal mic is the right one.
Thanks for sharing. I have just updated my bootloader to OpenCore. I will share my configuration in a new post.
 
Joined
Oct 15, 2016
Messages
72
Motherboard
Lenovo IdeaPad 510s-14isk
CPU
i7-6500U
Graphics
HD 520
Mobile Phone
  1. Android
Thanks for sharing. I have just updated my bootloader to OpenCore. I will share my configuration in a new post.

Is it stable or nah?
 
Joined
Aug 7, 2017
Messages
4
Motherboard
Intel Lenovo
CPU
Intel i5 6200u
Graphics
Intel HD Graphics 520
Mac
  1. MacBook Pro
Can anyone help me with de hdmi black screen and de audio, i made a copy and paste of the EFI folder published because i hace same laptop but the mine is with i5 6200u, Intel HD 520, thanks, please
 
Joined
Oct 11, 2017
Messages
74
Motherboard
Lenovo 510s-14isk (OpenCore UEFI)
CPU
i5-6257u
Graphics
Iris 550, 1920x1080
Is it stable or nah?
It is stable for me. I can use it normally for tasks such as compiling software, browsing, doing graphics. It is a little slower if you need video editing but I think it is globally stable.
 
Joined
Oct 11, 2017
Messages
74
Motherboard
Lenovo 510s-14isk (OpenCore UEFI)
CPU
i5-6257u
Graphics
Iris 550, 1920x1080
Can anyone help me with de hdmi black screen and de audio, i made a copy and paste of the EFI folder published because i hace same laptop but the mine is with i5 6200u, Intel HD 520, thanks, please
Read the guide posted in post #1 for audio: https://dortania.github.io/OpenCore...al/audio.html#making-layout-id-more-permanent.

The HDMI black screen a problem that is not totally fixed for me. I have to disconnect and re-connect the cable to get the laptop screen back to work.
 
Joined
Dec 20, 2018
Messages
741
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Read the guide posted in post #1 for audio: https://dortania.github.io/OpenCore...al/audio.html#making-layout-id-more-permanent.

The HDMI black screen a problem that is not totally fixed for me. I have to disconnect and re-connect the cable to get the laptop screen back to work.
try locking the screen with the HDMI cable connected. then unlock. once you do this after you boot then you can hot plug and unplug the hdmi. screen will flash black for 2 seconds then reappear
 
Joined
Aug 7, 2017
Messages
4
Motherboard
Intel Lenovo
CPU
Intel i5 6200u
Graphics
Intel HD Graphics 520
Mac
  1. MacBook Pro
Last edited:
Joined
Aug 7, 2017
Messages
4
Motherboard
Intel Lenovo
CPU
Intel i5 6200u
Graphics
Intel HD Graphics 520
Mac
  1. MacBook Pro
Hey Uchika

I have got the trackpad to work properly using the ApplePS2SmartTouchPad.kext - It now appears as proper touchpad in system prefs :)

I am still having issues with my Geekbench score, the laptop feels stable but it's appearing very low in comparison to your score you posted - if you have a chance could I grab a copy of your .EFI just to see if I have messed something up :)

-

For anyone reading remove the VoodooPS2Controller Kext using

sudo rm -rf /Library/Extensions/VoodooPS2Controller.kext

And install the ApplePS2SmartTouchPad.kext using Hackintool
thanks i tried but i couldn't reconfigure f11 and f12 keys for brightness
 
Joined
Oct 17, 2020
Messages
2
Motherboard
Lenovo 510s 14-ISK
CPU
i5-6267u
Graphics
Iris 550, 1920x1080
Hey Uchika,

Thanks for this guide :) - I have been following your guide and have got my Lenovo 510s-14isk up and running and it feels quite stable.

There are a few issues I am working through like the sleep wake up time, currently about 10 seconds and also a HDMI port issue, where the screen won’t turn on if the system boots with a monitor attached.

I think I can solve these 2 issues, but the big problem I am having is that my geek bench score appears really low.

My single core is 750 and my multi core is 1450!

I noticed yours were about 4x higher - Would it be possible to have a copy of your EFI to see if I have messed something up!

Thanks, David
I have the same problems. Have you resolved the low score in geekbench? If so, how?
 
Joined
Oct 17, 2020
Messages
2
Motherboard
Lenovo 510s 14-ISK
CPU
i5-6267u
Graphics
Iris 550, 1920x1080
Ahh... it was on geekbench 4
Now it's all clear
 
Status
Not open for further replies.
Top