Contribute
Register

Solved > GUIDE: Legion y530 MOJAVE 10.14 installation

Joined
Apr 7, 2019
Messages
3
Motherboard
5B20R40161 (not sure) :)
CPU
i5-8300H
Graphics
UHD 630, GTX 1050 , 1920x1080
Mac
Mac Pro
Mobile Phone
iOS
Hey rcc622,


I'm trying to use the Lenovo_Y7000-Y530 by XiaoM4095 but I'm kind of new to the entire hackintosh environment.
So far I have install the Mojave 10.14.4 on my Y530.

I'm having issues with my keyboard/audio drivers and I was thinking to use the entire repo.
Can you guide me bit on how to place the kexts correctly?


I got the kexts from the EFI/kexts/Other and placed them on my desktop. Used Kextbeast to install them and KextUtility to fix permission issues but it seems they are not working as expected.


Should I place all of them in my EFI volume under Clover? Should I take the entire EFI folder from Xiao?
Sorry for the noob question.

Best regards

Never mind..... I have rebuilt the EFI using Xiao's repository and it worked :D
 
Joined
Apr 7, 2019
Messages
3
Motherboard
5B20R40161 (not sure) :)
CPU
i5-8300H
Graphics
UHD 630, GTX 1050 , 1920x1080
Mac
Mac Pro
Mobile Phone
iOS
For the people having issues mounting EFI

Issue commands as follows:
diskutil list (this will show you on what disk you have the EFI)
sudo -s (Move to root account)
diskutil mountDisk /dev/disk<nr>



Code:
Florins-iMac:~ legion$ diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         512.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         256.0 GB   disk0s2
   3:         Microsoft Reserved                         16.8 MB    disk0s3
   4:       Microsoft Basic Data                         255.9 GB   disk0s4

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +256.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume macOS                   101.3 GB   disk1s1
   2:                APFS Volume Preboot                 45.0 MB    disk1s2
   3:                APFS Volume Recovery                522.9 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:       Microsoft Basic Data                         999.2 GB   disk2s1

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *2.0 TB     disk3
   1:               Windows_NTFS TOSHIBA EXT             2.0 TB     disk3s1

Florins-iMac:~ legion$ df -h
Filesystem      Size   Used  Avail Capacity iused               ifree %iused  Mounted on
/dev/disk1s1   238Gi   94Gi  142Gi    40% 1105618 9223372036853670189    0%   /
devfs          226Ki  226Ki    0Bi   100%     780                   0  100%   /dev
/dev/disk1s4   238Gi  1.0Gi  142Gi     1%       2 9223372036854775805    0%   /private/var/vm
/dev/disk0s4   238Gi   32Gi  206Gi    14%  170385           216355507    0%   /Volumes/Untitled
map -hosts       0Bi    0Bi    0Bi   100%       0                   0  100%   /net
map auto_home    0Bi    0Bi    0Bi   100%       0                   0  100%   /home
/dev/disk0s1   197Mi   56Mi  141Mi    29%       0                   0  100%   /Volumes/EFI
/dev/disk3s1   1.8Ti  1.5Ti  364Gi    81%  209472           381456748    0%   /Volumes/NTFS1
/dev/disk2s1   931Gi  644Gi  286Gi    70%  472067           300167881    0%   /Volumes/NTFS2
Florins-iMac:~ legion$ sudo -s
Password:
bash-3.2# diskutil mountDisk /dev/disk0
Volume(s) mounted successfully


bash-3.2# df -h
Filesystem      Size   Used  Avail Capacity iused               ifree %iused  Mounted on
/dev/disk1s1   238Gi   94Gi  142Gi    40% 1105674 9223372036853670133    0%   /
devfs          226Ki  226Ki    0Bi   100%     780                   0  100%   /dev
/dev/disk1s4   238Gi  1.0Gi  142Gi     1%       2 9223372036854775805    0%   /private/var/vm
/dev/disk0s4   238Gi   32Gi  206Gi    14%  170385           216355507    0%   /Volumes/Untitled
map -hosts       0Bi    0Bi    0Bi   100%       0                   0  100%   /net
map auto_home    0Bi    0Bi    0Bi   100%       0                   0  100%   /home
/dev/disk0s1   197Mi   56Mi  141Mi    29%       0                   0  100%   /Volumes/EFI
/dev/disk3s1   1.8Ti  1.5Ti  364Gi    81%  209472           381456748    0%   /Volumes/NTFS1
/dev/disk2s1   931Gi  644Gi  286Gi    70%  472067           300167881    0%   /Volumes/NTFS2
 
Joined
Apr 10, 2019
Messages
26
Motherboard
Lenovo Y530
CPU
i7-8750H
Graphics
GTX 1050 , 1920x1080
Mobile Phone
iOS
It’s going after this
399777
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,245
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
MacBook Air
Mobile Phone
iOS
I can't get into the system with your EFI, maybe you can refer to my EFI.
Boot with verbose mode and attach a photo of where it hangs.
 
Joined
Apr 10, 2019
Messages
26
Motherboard
Lenovo Y530
CPU
i7-8750H
Graphics
GTX 1050 , 1920x1080
Mobile Phone
iOS
.
 
Last edited:
Joined
Apr 10, 2019
Messages
26
Motherboard
Lenovo Y530
CPU
i7-8750H
Graphics
GTX 1050 , 1920x1080
Mobile Phone
iOS
I’m installed clover efi with this settings, and now freezing on apple logo. Which settings need to select?
 
Top