Contribute
Register

[Guide] Laptop backlight control using AppleBacklightFixup.kext

Joined
Jan 7, 2014
Messages
53
Motherboard
Lenovo Legion y7000p-1060 - OC
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android

Attachments

  • debug_17611.zip
    2.9 MB · Views: 52
Joined
Mar 17, 2018
Messages
7
Motherboard
Acer Aspire V3 771G Laptop
CPU
i3-3210M
Graphics
Intel HD4000 (Optimus Nvidia 650M)
Mobile Phone
  1. iOS

Attachments

  • debug_16932.zip
    3.4 MB · Views: 40

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi All ;
I decided to finally upgrade to 10.13.4, from Sierra.
in Sierra the brightness did not work but I never tried to fix .
now that I followed this thread and did every step. I tried to solve the issue but I couldn't.
the brightness slider and the brightness key work but the screen brightness does not change, always max .
the IGPU for me is defined in DSDT .
I'm attaching my clover patched folder and config.plist .
can anyone please tell me what went wrong ?
thanks.
Sorry, here is the generated file.

Your computer likely does not use the IGPU PWM, therefore not compatible with AppleBacklight.kext.
Your profile lacks important hardware details.
Please fix as per FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After making your changes I still don't get a brightness slider. I attached new logs.

Still same problems as mentioned before.
 
Joined
Nov 8, 2015
Messages
33
Motherboard
MSi B150M BAZOOKA
CPU
i5-6500
Graphics
Sapphire Tri-X R9 290X
Mac
  1. MacBook
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
I got the brightness slider to show up, but my screen doesn't dim when I adjust it.

Any help is appreciated.

edit...this is for the MSi GE60 0ND
 

Attachments

  • debug_28333.zip
    4.8 MB · Views: 65

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I got the brightness slider to show up, but my screen doesn't dim when I adjust it.

Any help is appreciated.

edit...this is for the MSi GE60 0ND

Your laptop probably does not use the IGPU PWM registers for backlight control, therefore not compatible with Apple's AppleBacklight.kext.

There are quite a number of laptops (mostly oddball Ivy Bridge by Samsung and Fujitsu).

You will need to use ACPIBacklight.kext + appropriate ACPI patches + "Brightness by bergdesign".
 
Joined
Mar 17, 2018
Messages
7
Motherboard
Acer Aspire V3 771G Laptop
CPU
i3-3210M
Graphics
Intel HD4000 (Optimus Nvidia 650M)
Mobile Phone
  1. iOS
After trying to follow each of your steps again, I still have no slider nor brightness buttons.Could you please tell me where to find the errors in the logs?
Thanks
 

Attachments

  • debug_12182.zip
    3.5 MB · Views: 73

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After trying to follow each of your steps again, I still have no slider nor brightness buttons.Could you please tell me where to find the errors in the logs?
Thanks

Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

It also shows AppleIntelFramebufferCapri.kext is patched. Restore to vanilla (run the macOS installer).
 
Joined
Mar 17, 2018
Messages
7
Motherboard
Acer Aspire V3 771G Laptop
CPU
i3-3210M
Graphics
Intel HD4000 (Optimus Nvidia 650M)
Mobile Phone
  1. iOS
Thanks for the hints. I think I have done everything you said (again), but I must have overlooked something. It still doesn't work.
 

Attachments

  • debug_8500.zip
    3.2 MB · Views: 77

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for the hints. I think I have done everything you said (again), but I must have overlooked something. It still doesn't work.

Your kextcache output proves kexts are not installed correctly (kextcache clearly shows FakeSMC.kext not installed).
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Your Clover bootlog shows no KextsToPatch entries... and if you look at your config.plist you have no config.plist/KernelAndKextPatches/KextsToPatch section (Clover ignores the entires you have in #KextsToPatch).

I didn't check anything else.
 
Top