Contribute
Register

[GUIDE] Jerivalu’s Build: Fresh 10.11.5, Z170X-UD5 TH, 6700k, Intel HD 530, Thunderbolt, Dual Boot

Joined
Mar 28, 2010
Messages
55
Motherboard
Z170x UD5 TH
CPU
6700k @4.5
Graphics
EVGA 1080Ti SC2
Mac
MacBook Pro
Mobile Phone
iOS
Jerivalu’s Editing Build: Fresh 10.11.5+, Z170X-UD5 TH, 6700k, Intel HD 530, Thunderbolt, Dual Boot OSX/WIN10



Components
  • Gigabyte Z170X-UD5 TH motherboard (bios F5)
  • Intel 6700k chip (overclocked)
  • Corsair H100i v2 water cooling
  • G.SKILL 32GB (4 x 8GB) TridentZ Series DDR4 PC4 - 25600 3200MHz Model F4-3200C16Q-32GTZ
  • 2x SanDisk SADSSDHII480 480GB Ultra II Internal Solid State Drive (one for osx, one for win 10)
  • HGST 4TB Deskstar 3.5" SATA III Internal Desktop Hard Drive
  • EVGA SuperNOVA 650 P2 80+ PLATINUM, 650W
  • Fractal Design Define R5 FD-CA-DEF-R5-BK Black Computer Case
  • StarTech.com 3 Port 2b 1a 1394 PCI Express FireWire Card Adapter PEX1394B3
  • LG Black 12X BD-R 2X BD-RE 16X DVD+R 12X DVD-RAM 10X BD-ROM 4MB Cache SATA Super Multi WH12LS30
  • Logitech HD Portable 1080p Webcam C615 with Autofocus (960-000733)
  • StarTech.com STTBT3TBTADP Thunderbolt 3 to Thunderbolt Adapter
  • StarTech.com USB 3.0 Internal Multi-Card Reader with UHS-II Support - SecureDigital/Micro SD/Memory Stick/Compact Flash Memory Card Reader
  • evga 1080ti sc2

Comments
*10.12.5 update= this build still works!


Installation
UEFI BIOS Settings (version f5)

  1. Enter BIOS with DEL key
  2. Update your bios to version F5
  3. Load Optimized Defaults in the Save&Exit tab
  4. Here are my settings
  5. Save and Exit

10.11.5 Fresh Install
  1. Use a black USB port in on the back of your motherboard to install OS X using your unibeast USB device
  2. Boot to the device by hitting the F12 key
  3. Follow the install guide on how to format/start the osx install
  4. After installing 10.11.5, the install WILL crash if you do not choose that the computer does not connect to the internet when it asks you for your internet settings (it will work later just do this for now)
  5. After OSX installs make sure to boot from your usb device again and then proceed to boot from your hard drive on the clover select screen
  6. Launch System Preferences then choose Security & Privacy > General > Allow apps downloaded from: Anywhere
  7. Open Multibeast and use the following MultiBeast 8.2 settings
    • Quick Start > UEFI Boot mode
    • Drivers > Audio > Realtek > 100 series audio
    • Drivers > Audio > Realtek > ALC1150
    • Drivers > Network > Intel > IntelMausiEthernet v2.1.0d0
    • Drivers > USB > Increase Max Port Limit
    • Customize > Graphics Config > Intel HD 530
    • Customize > System Definition > Imac > Imac 17,1
  8. Click Build > Install and let it complete
  9. Shut down your computer and unplug the USB drive
  10. Start your computer back up and you should be able to boot into OSX
  11. Install SSDT file to match your chip (in my case 6700k) for power savings options/correct clock speeds to your EFI folder The bottom of this post shows how and links the file in the "Final Power Saving Setup" section
  12. To get iMessage working correctly please consult the imessages guide on this site and set your UUID in clover config etc

Installing Windows 10
  1. In OSX format the Windows drive to GUID boot type in a single FAT partition using disk utility (This is IMPORTANT to make sure windows installs properly as UEFI and not legacy)
  2. Shut down your computer
  3. Unplug your OSX drive (and all other storage drives)
  4. To install Windows 10, boot to your install USB/DVD
  5. You'll have to have windows installer delete the current FAT formatted drive to continue
  6. After installing, when in windows, make sure to NOT install the Realtek audio drivers for the motherboard! This will make it so your rear audio port will not output sound in OSX! (DON'T WORRY: sound will still work 100% as intended through the preinstalled windows drivers (front, rear, etc), just don't install the realtek drivers from gigabyte)
  7. Shut down windows and plug in your OS X drive/storage drives and boot into OS X
  8. In OSX, open Clover Configurator and mount your OSX EFI drive
  9. On the sidebar, Go to TOOLS> Install Drivers > click NTFS UEFI (bottom rightish corner)
  10. Reboot and you should be able to choose your windows 10 or OSX drive to boot in clover
  11. To fix windows 10 time/clock
    • open regedit.exe
    • navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
    • Right click anywhere in the right pane and hit New > DWORD (32-bit) Value
    • Name it RealTimeIsUniversal, then double click on it and give it a value of 1
    • Close regedit
    • Restart into OSX and then restart back to windows and it should be fixed from now on
Notes
What works

  • 10.11.5 update via App Store
  • USB3- front, rear, adapters, etc
  • overclocking/power management with SSDT
  • ram full speed OOB
  • Firewire card OOB
  • Bluray burner
  • integrated graphics acceleration, shows full 1536mb memory
  • networking
  • sound- front, rear
  • 74-In-1 USB3 media reader
  • Appstore
  • Itunes
  • facetime
  • Messages
  • dual boot to win 10
  • Sapphire 280x Toxic OOB
  • Shutdown (supposedly) works with 10.11.5 (use clover config + fix shutdown option, if you use Corsair watercooling you must also unplug its' USB). Some have success, some don't. Also try to Enable ERP in BIOS.
  • Thunderbolt Guide
What doesn't work
  • Sleep (some reported success using nvidia cards, but basically still not working overall)
Notable Posts:

Benchmarks:
Geekbench
3 64bit @4.6ghz: 5350/21147

Geekbench 3 64bit @4.5ghz: 5288/20630

Cinebench (with 280x)

Luxmark 3.1 (with 280x)

BruceX (with 280x): 12secs

Updates
6/11/16: Added Thunderbolt info
5/18/16: Added notable posts section
5/18/16: Updated Bios to remind people to upgrade to F5, random guide updates
5/17/16: Updated to 10.11.5
5/11/16: Added possible sleep fix from matey post #43
5/7/16: Added shutdown issues, still no fix
5/3/16: Cleaned up guide and fixed pictures, added how to fix windows time
 
Last edited:
Joined
May 12, 2011
Messages
2,720
Motherboard
GA-X99M-Gaming 5
CPU
Intel Core i7-5930K
Graphics
MSI GTX 970 Gaming 4G
Mac
MacBook Pro
Mobile Phone
Android
Killer single-core speed. Did you try:
PHP:
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleRTC</key>
        <true/>
To fix the bios reset on shutdown?
 
Joined
Apr 19, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
This was exactly what I was looking for! Thank you for sharing!

I'm also an editor and getting thunderbolt working would be heavenly. Please let us know if you make any progress with sleep or thunderbolt functions. You rock! :headbang:
 
Joined
Mar 28, 2010
Messages
55
Motherboard
Z170x UD5 TH
CPU
6700k @4.5
Graphics
EVGA 1080Ti SC2
Mac
MacBook Pro
Mobile Phone
iOS
Killer single-core speed. Did you try:
PHP:
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleRTC</key>
        <true/>
To fix the bios reset on shutdown?
Thank you for the suggestion but it did not work. I'll keep on trying other things hah. I think it might be gpu related because when I pulled the 280x out of my old rig which suffered the same problem, it would shut down fine after.
 
Joined
Mar 28, 2010
Messages
55
Motherboard
Z170x UD5 TH
CPU
6700k @4.5
Graphics
EVGA 1080Ti SC2
Mac
MacBook Pro
Mobile Phone
iOS
This was exactly what I was looking for! Thank you for sharing!

I'm also an editor and getting thunderbolt working would be heavenly. Please let us know if you make any progress with sleep or thunderbolt functions. You rock! :headbang:
Of course! We will have to wait for a mac to come out with thunderbolt 3 first though for that :p
 
Joined
Feb 10, 2011
Messages
79
Motherboard
ASUS Prime X299-Deluxe
CPU
i9-7980XE
Graphics
GTX 1070
Mac
iMac, Mac Pro
Mobile Phone
iOS
hi jerivalu,

Thank you so much for your guide, it got me as far as to the multibeast 8.2.1 (latest version) were i try to install the things from your guide. Multibeast fails at Increase Max Port Limit.. Does someone have any solutions for this ?

I need to have my USB for el capitan inserted in order to boot, is that what you mean when you say: Can't get shutdown to not reset after shutting down ?

Btw jerivalu.. if i would use my nvidia gtx 980 card along side with this HD 530 what is the process for doing so ?

Thank you!
 
Joined
Mar 28, 2010
Messages
55
Motherboard
Z170x UD5 TH
CPU
6700k @4.5
Graphics
EVGA 1080Ti SC2
Mac
MacBook Pro
Mobile Phone
iOS
hi jerivalu,

Thank you so much for your guide, it got me as far as to the multibeast 8.2.1 (latest version) were i try to install the things from your guide. Multibeast fails at Increase Max Port Limit.. Does someone have any solutions for this ?

I need to have my USB for el capitan inserted in order to boot, is that what you mean when you say: Can't get shutdown to not reset after shutting down ?

Btw jerivalu.. if i would use my nvidia gtx 980 card along side with this HD 530 what is the process for doing so ?

Thank you!
Congrats on getting this far-

Max port limit- Hmm strange, what I would do is install everything except the max port limit and then boot into your computer without the USB, then try to install the max port limit. Also please make sure all your bios settings match mine.

shutdown- No, my shutdown problem is the computer reboots up 5 seconds after shutting down.

980 card- I don't have experience on nvidia cards but I believe you have to use clover config, mount your EFI and load your clover config file, and then check the nv_disable=1 boot flag in the boot sections (close and save). You also need to install the nvidia web drivers. (I might be wrong on this but that's what i've read in a simple way)
 
Joined
Jul 8, 2012
Messages
20
Motherboard
HP Pavilion Gaming 15 (2018)-Clover UEFI
CPU
i5-8300H/HM370
Graphics
HD 630, 1920x1080
Mobile Phone
Android
Congrats on getting this far-

Max port limit- Hmm strange, what I would do is install everything except the max port limit and then boot into your computer without the USB, then try to install the max port limit. Also please make sure all your bios settings match mine.

shutdown- No, my shutdown problem is the computer reboots up 5 seconds after shutting down.

980 card- I don't have experience on nvidia cards but I believe you have to use clover config, mount your EFI and load your clover config file, and then check the nv_disable=1 boot flag in the boot sections (close and save). You also need to install the nvidia web drivers. (I might be wrong on this but that's what i've read in a simple way)
About shutdown, disable ''wake on LAN'' in bios and use the shutdown fix in Clover too

Edit: the sleep problem may be the Graphics Card. In Amd Graphics sleep doesn't works since El Capitan. You only have to select Integrated Graphics as principal Graphics in your bios to make work the sleep. When you power on the computer logically the screen will be off until osx lockscreen.
 
Last edited:
Joined
Feb 10, 2011
Messages
79
Motherboard
ASUS Prime X299-Deluxe
CPU
i9-7980XE
Graphics
GTX 1070
Mac
iMac, Mac Pro
Mobile Phone
iOS
Thank you :)

But i cant get intel hd 530 and nvidia gtx 980 working together! I swear i had it the first time i installed el capitan 10.11.4 but i just cant re-create what i did... I have been re-installing for 7-8 times now and sick of doing it all over again :) Especially when the site was down for posting and reply :)

Anyone else has a successful build with this motherboard ga-z170x-ud5-th were they use one screen for the intel hd 530 and another screen for their graphics card ?

Thank you !
 
Joined
Feb 10, 2011
Messages
79
Motherboard
ASUS Prime X299-Deluxe
CPU
i9-7980XE
Graphics
GTX 1070
Mac
iMac, Mac Pro
Mobile Phone
iOS
The build is stuck in a boot loop.. Have to monitors connected to the gtx 980. But if i remove the DVI cable from the gtx 980 and only boot with 1 screen. It boots into the system, than i can connect the DVI into the gtx 980 and it works that way. But c'mon :):) cant live like that :)

Tried to boot with the motherboard Intel 530 HD but black screen (changed from PCI to motherboard graphics in BIOS). Strange.... Any one got any good advice why this is happening ? Tried for a week now.. lol
 
Top