Contribute
Register

[Guide] Intel Skylake NUC6 (and Skull Canyon) using Clover UEFI (NUC6i5SYK, NUC6i7KYK, etc)

Joined
Jul 6, 2011
Messages
36
Motherboard
Intel Nuc6i5SYH
CPU
I5-6260U
Graphics
Intel Iris 540
Mobile Phone
Android
Followed the process and installed High Sierra. Noticed HDMI audio is not working (currently connect through the HDMI port). Headphone port works fine.

Problem reporting files attached.

Correction: After a few operations (add users and install software) and reboots, HDMI audio is available now...
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Correction: After a few operations (add users and install software) and reboots, HDMI audio is available now...
Great.
 
Joined
Apr 16, 2016
Messages
26
Motherboard
Asrock Z370M
CPU
i7-7700
Graphics
Vega 56
Mobile Phone
iOS
Hi i have a problem. I have a Skull canyon I7, I follow step by step put the config install nuc 6 sc plist. Got this on my kexts folder and efi files. I am on the front left usb port.
Capture d’écran 2018-12-24 à 19.54.35.png Capture d’écran 2018-12-24 à 19.55.01.png


So key is created , but when i try to start it block on apple logo. With restart verbose mode i get that
unnamed.jpg

I look my keyboard light during process. Light disappear at the moment.


Sorry for my english ..
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
9,124
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi i have a problem. I have a Skull canyon I7, I follow step by step put the config install nuc 6 sc plist. Got this on my kexts folder and efi files. I am on the front left usb port.
View attachment 374850 View attachment 374851


So key is created , but when i try to start it block on apple logo. With restart verbose mode i get that
View attachment 374852

I look my keyboard light during process. Light disappear at the moment.


Sorry for my english ..
try searching for End RandomSeed
 
Joined
Apr 16, 2016
Messages
26
Motherboard
Asrock Z370M
CPU
i7-7700
Graphics
Vega 56
Mobile Phone
iOS
oh yea thx, i have found

I have set the "Execute Disable Bit" to ENABLED i can continue.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Direct upgrade to Mojave. HDMI audio is not working

Problem report files attached.
Try injecting fake device-id for HDEF.
In config.plist (Xcode), it would look like:
Screen Shot 2018-12-24 at 4.18.31 PM.png
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi i have a problem. I have a Skull canyon I7, I follow step by step put the config install nuc 6 sc plist. Got this on my kexts folder and efi files. I am on the front left usb port.
View attachment 374850 View attachment 374851


So key is created , but when i try to start it block on apple logo. With restart verbose mode i get that
View attachment 374852

I look my keyboard light during process. Light disappear at the moment.


Sorry for my english ..
I have set the "Execute Disable Bit" to ENABLED i can continue.
Not surprising.
It is clearly mentioned as a required BIOS setting in post #1 (also is default after BIOS setting reset).
 
Joined
Apr 16, 2016
Messages
26
Motherboard
Asrock Z370M
CPU
i7-7700
Graphics
Vega 56
Mobile Phone
iOS
Hi.
Yea I am sorry its my mistake. Well I have Mojave now, its work, but I get some problem, my graphic card have 7 mo... Also I want to use an external usb sound card. But when I plug it actually I get sound problem. Like sound artifact . And i dont have any sound outpout just my sound card.

I follow all the build I use Xcode to change the serial in the plist; but I am pretty sure my build are not good.

Do you think it work better with sierra or high sierra, I just need a stable Os, i dont care about the last update.
Well i try to reinstall majova for video kext missing, it doesnt work. I will try with high sierra now.

edit: i do a new install with high sierra. remake new key, format the efi disk and disk from my nuc, and make new install i have the same problem 7 mo and no card sound...
i forget in my first install that part " Unlike installing kexts to /System/Library/Extensions, where a kext installer (such as Kext Wizard) " but it didnt change anything on my problem.
There isnt load video kext that what system info tell me.

hope u could help and anyway thx for your job man ..
 

Attachments

Last edited:
Joined
Dec 22, 2018
Messages
1
Hi, this is my first hackintosh, I have a NUC6i5SYH with 16GB Ram and SSD M.2 SATA Sandisk 128GB

I follow step by step this guide but I'm stuck at End Randomseed

I use clover 4658 version from rehabman's fork and i use this drivers:
  • ApfsDriverLoader-64.efi
  • AppleImageLoader-64.efi
  • AppleUISupport-64.efi
  • AptioInputFix-64.efi
  • AptioMemoryFix-64.efi
  • DataHubDxe-64.efi
  • FSInject-64.efi
  • HFSPlus.efi
  • SMCHelper-64.efi
And this are my Kext's files:
  • FakeSMC.kext
  • IntelMausiEthernet.kext
  • Lilu.kext
  • USBInjectAll.kext
  • WhateverGreen.kext
For clover i use the config_install_nuc6.plist renamed at config.plist

I configure the BIOS like describe this guide, I don't know what I do wrong

EDIT: At Security->Security Features, "Execute Disable Bit" was disabled, I'm a little bit dumb...
 
Last edited:
Top