Contribute
Register

[Guide] Intel Skylake NUC6 (and Skull Canyon) using Clover UEFI (NUC6i5SYK, NUC6i7KYK, etc)

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Trying to boot a Nuc6cayh using an USB with config_install_nuc6.plist, fakesmc.kext and IntelMausiEthernet.kext but gets stuck as seen in the picture.

I've tried with Clover v4049, v4069 and v4077. Same result. I also tried to add FakecpuID in teh config.plist with my Cpu ID (0x0605C9 for Intel J3455) but nothing happens.

Any idea please? It would be great to, at least , reach the installer.

No EFI/Clover attached.
Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Oct 3, 2011
Messages
16
Motherboard
GA-Z77-DS3H
CPU
i5-3750 3,2 Ghz
Graphics
Nvidia GTX 560ti
Mac
Classic Mac
Mobile Phone
It is not per guide.
Read post #1.

I'm sorry mate but I don't understand. Since i can't boot the only thing I can upload is Efi/clover having pressed F4 and F2 together with a picture. That's all, the rest of the problem reporting commands in the 1st post can't be executed in clover shell.

I don't know what else to do.
 

Attachments

  • files.zip
    4 MB · Views: 59

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm sorry mate but I don't understand. Since i can't boot the only thing I can upload is Efi/clover having pressed F4 and F2 together with a picture. That's all, the rest of the problem reporting commands in the 1st post can't be executed in clover shell.

I don't know what else to do.

Your EFI/Clover is not per guide:
- config.plist is not config_install_nuc7.plist as per guide
- drivers64UEFI is not per guide (wrong set of files there)
- wrong kexts in Clover/kexts/Other

It is like you didn't read the guide at all...
 
Joined
Dec 9, 2016
Messages
8
Motherboard
NUC6i7KYB
CPU
i7
Graphics
Intel® Iris® Pro Graphics 580
I'm confused. Are there any changes I need to make when updating from 10.12.4 to 10.12.5? I thought I had to add Lilu/IntelGraphicsFixup kexts. BTW, I updated to 10.12.5 but now it hangs on reboot.

I'm running a Intel NUC6i7KYK.

Thanks in advance.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm confused. Are there any changes I need to make when updating from 10.12.4 to 10.12.5? I thought I had to add Lilu/IntelGraphicsFixup kexts. BTW, I updated to 10.12.5 but now it hangs on reboot.

I'm running a Intel NUC6i7KYK.

Thanks in advance.

No need for Lilu/IntelGraphicsFixup with HD580. That is for HD520/HD530/HD620/HD630 (and some HD515).
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,933
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Note: Updated the github project to install Lilu.kext + IntelGraphicsFixup.kext.

I found that IntelGraphicsFixup.kext eliminates a "pause" that happens periodically while watching certain video content in Safari while moving the mouse.

Note also that I added support for the Skylake Intel Compute Stick.
Not sure if I will write a separate guide for that, or just integrate it into this guide, but other than the fact you need to use an external USB drive for the system drive, the procedures are similar/predictable.
I have an STCK2mv64CC with an external USB3 SSD. It actually works surprisingly well.
 
Last edited:
Joined
May 31, 2011
Messages
2
Motherboard
P8H67 3.0
CPU
Intel i5 3.3GHz
Graphics
nVidia GTX750
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I use NUC6i5SYH with 960 evo(nvme) 250GB.

For osx 10.12.3~4, this guide was worked well for my nuc.

But, for present 10.12.5, my nuc can not boot, stuck at apple logo on boot.
All result are same using two method for 10.12.5.
1) After install 10.12.4 by this guide, the system was perfectly worked and installed combo update 10.12.5
2) Clean install 10.12.5 by this guide with clover 4077.

Could you have a idea for my problem??

*attached files: used config.plist for 10.12.4 and 10.12.5
 

Attachments

  • config_10.12.4_for_install.plist
    11.5 KB · Views: 180
  • config_10.12.4_for_post_install.plist
    14 KB · Views: 164
  • config_10.12.5_for_install.plist
    11.3 KB · Views: 180
Last edited:
Joined
Oct 6, 2015
Messages
5
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
Intel 630
Mac
  1. MacBook Pro
This is such an awesome guide and thread.
The one thing I had looked for was thunderbolt support, and it's simple to get.

First - go into the bios. Advanced/Security and under security features you'll see the Thunderbolt Security Level - change it to Legacy Mode.
Install Windows (ideally on a spare drive), install the thunderbolt drivers and run the latest thunderbolt firmware update (V25 certainly works). Boot back into the Apple OS and you should have Thunderbolt 3 working.
Hope that's useful, and I've put this in the right spot....
 
Status
Not open for further replies.
Top