Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
For the NUC8i7BEH, should I format my USB to MBR or GPT?

Your choice.
It will work with either.
MBR is a bit easier to manage as "CLOVER EFI" will mount automatically.
 
Joined
Dec 9, 2018
Messages
32
Motherboard
Intel NUC8I3BEH1
CPU
i3-8109U
Graphics
Intel Iris Plus Graphics 655
I followed Rehabman's guide all the way through, inclusive of disabling (I think?) hibernation mode for my NUC8 i3.

When I sleep my computer for a long period (overnight), or just leave it (and it put displays and hard disks to sleep on its own eventually), I typically come back to this garbled screen that comes in/out. When it goes out, the NUC loses connectivity to the display. I have to turn off the NUC and turn it back on to resolve.

Anyone else experiencing this and potentially solved it?



@RehabMan - can you help with this? Myself and another poster in this long thread have been affected by this garbled screen issue waking from a long (4+ hours) sleep.
 
Joined
Dec 29, 2018
Messages
9
Motherboard
NUC8i7BEH
CPU
i7
Graphics
Intel
Try without unneeded USB devices plugged (such as USB WiFi).
I don't have this problem with my monitor, which doesn't have a speaker, but with my TV, which with audio over hdmi.
and my onboard bluetooth works sometimes and not other time, could you help debug this? and does M.2 slot support wifi+bluetooth card with a B+M key adapter? Thank you very much

Edit: with new m.2 adapter and wifi card it works. but bluetooth stop working ....
 
Last edited:
Joined
Apr 29, 2011
Messages
25
Motherboard
Optiplex 9020 Sff
CPU
i7-4790
Graphics
HD 4600
Mac
  1. MacBook Pro
NM. Went vanilla and it's working now.
 
Last edited:
Joined
Mar 2, 2016
Messages
2
Motherboard
b85n
CPU
i5-4690
Graphics
RX 480
@RehabMan hello rm, I have a nuc8i5beh. Things works fine, but only one issue is my usb-c function not working at all. Dp, usb-c hub and usb-c flash drive, no response at all, tb3 not tested. And I've also tried windows, not working the same. So is there some special settings in bios or maybe I have a bad hardware?
 
Joined
Feb 25, 2013
Messages
64
Motherboard
NUC 8i5BEH-0087
CPU
i5-8259U
Graphics
UHD 655
Mobile Phone
  1. Android
@RehabMan hello rm, I have a nuc8i5beh. Things works fine, but only one issue is my usb-c function not working at all. Dp, usb-c hub and usb-c flash drive, no response at all, tb3 not tested. And I've also tried windows, not working the same. So is there some special settings in bios or maybe I have a bad hardware?
hi,
usb c is working fine. look at the capture .Sorry it's in french, my external drive ( silverdrive U3C) is working great
at 10 GB/s
 

Attachments

  • Capture d'écran 2019-01-06 à 19.56.07 PM.png
    Capture d'écran 2019-01-06 à 19.56.07 PM.png
    27 KB · Views: 152
Last edited:
Joined
Apr 29, 2011
Messages
25
Motherboard
Optiplex 9020 Sff
CPU
i7-4790
Graphics
HD 4600
Mac
  1. MacBook Pro
@RehabMan And I've also tried windows, not working the same.

Makes me believe it is a hardware issue or something is not set correctly in BIOS. You might try loading defaults in the BIOS and making the changes in post #1. If it still doesn't work in Windows (after installing all drivers) then you probably have faulty hardware.
 
Joined
Mar 21, 2013
Messages
4
Motherboard
Gigabyte GA-170X-UD3
CPU
I7-6700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. Android
If using NUC8i7BEH or similar, then don't upgrade BIOS to version 56 (leave at version 51). I have had a couple of these and several hours of support with Intel (who did not know this, nor that it was an issue). I wish I had have found this ****** post https://www.reddit.com/r/intelnuc/comments/a3rykv before spending a few hours mucking around. Intel knew about it more than a month ago but haven't taken it down...
 
Joined
Jul 18, 2017
Messages
2
@RehabMan - can you help with this? Myself and another poster in this long thread have been affected by this garbled screen issue waking from a long (4+ hours) sleep.
I solve this problem - disable hibernate, stay only sleep

sudo pmset -a hibernatemode 0
 
Top