Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Sep 23, 2019
Messages
86
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
Intel Iris Plus 655
Classic Mac
  1. Portable
Mobile Phone
  1. Android
For my nuc8i7 the oc7.3 config also doesn’t work

oc7.0 works, but after oc7.3 it gave me an error.

again I'm back to my oc7.0 EFI
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,939
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
oc7.0 works, but after oc7.3 it gave me an error.

again I'm back to my oc7.0 EFI
What error? It's mostly worked for those who have tried it, like to see if I can fix your issue.
 
Joined
Sep 23, 2019
Messages
86
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
Intel Iris Plus 655
Classic Mac
  1. Portable
Mobile Phone
  1. Android

Attachments

  • IMG_20210928_200512.jpg
    IMG_20210928_200512.jpg
    4.8 MB · Views: 44

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,939
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Okay, thanks for that. It appears you have three different errors and they are probably all in your config.plist. The first error should be impossible in O.C. 7.3 as there is no "AdviseWindows" feature anymore. They changed that entry in the config.plist under PlatformInfo/Generic section to "AdviseFeatures".

I suspect you tried to copy over your serial numbers etc. that are recorded within the PlatformInfo/Generic from an older version of your existing config.plist. I've done that too...to fix it change the name in the config.plist to "Advise Features"

The second error I do not recognize but again I believe you made a change to the config.plist that is causing it. You can compare your config.plist to mine and see if you can find the difference causing the error.

Either that or log out of your iCloud account and then load my EFI folder onto a USB Boot drive and start your NUC from it and see if you still get the error messages. I recognize the third error, had it myself when I was updating to 7.3, but I am not quite sure what I did to make it go away. I never get that error message now though and I uploaded the exact version I am using less serial numbers.
 
Joined
Apr 30, 2021
Messages
4
Motherboard
NUC8I7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. 512K
Updated three Nuc's from OC 6.8 to OC 7.3 under macOS 11.6 without problem.

Also fixed the problem in OC 6.8 of Time Machine including all external disk(s) in it's backup unless they were manually excluded. With OC 7.3 the exclusion is done automatically again. Also in DiskUtil whole Disks can be unmounted again, instead of only Volumes. Happy camper.

Thank you very much @Leesurone!
 
Joined
Sep 23, 2019
Messages
86
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
Intel Iris Plus 655
Classic Mac
  1. Portable
Mobile Phone
  1. Android
Hello Leesureone ,
I changed the disk of my nuc8i7beh.
The Nvme model I just bought looks like this "1TB Pc611 Nvme Sk Hynix"

I am getting the attached error while installing BigSur. What do you recommend.
The "EFI" I use is "Nuc8OC7.0" on page 89.
 

Attachments

  • WhatsApp Image 2021-10-02 at 12.46.38.jpeg
    WhatsApp Image 2021-10-02 at 12.46.38.jpeg
    372.3 KB · Views: 20
Joined
Dec 26, 2019
Messages
27
Motherboard
Intel NUC8i5
CPU
i5-8259U
Graphics
Iris 655
strange - my Nuc want's so to stay on 11.5.1, no update to 11.6 found.
Any idea on any hidden setting preventing the update?

Apple stopped providing the previous "combo" updates which allowed a manual process
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,939
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello Leesureone ,
I changed the disk of my nuc8i7beh.
The Nvme model I just bought looks like this "1TB Pc611 Nvme Sk Hynix"

I am getting the attached error while installing BigSur. What do you recommend.
The "EFI" I use is "Nuc8OC7.0" on page 89.
It could be helpful if you post the drive model numbers but if I recall the NVME drive SK Hynix makes are not compatible with Mac OS. See this post here: #2,761
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,939
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Top