Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,252
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
PC nuc8I5BEH
Macos 10.14.6
bluetooth dongle : TP-Link UB400 Bluetooth USB

hello everybody,
Since May 2020, everything was working perfectly, but since a few days I have had the following problem:
after a stop or a standby my Magic keyboard 1 bluetooth is no longer recognised automatically whereas the Magic Keypad works perfectly and is recognised directly.
I have to press and hold down the button on the keypad each time, then when macos asks for it, enter a new code.
I tried to remove the keyboard and reinstall it with no result,
Do you have an idea ?
Thank you for your help.
Mac OS occasionally has problems with Bluetooth. Search for how to enter Debug mode in Bluetooth. You hold down shift and the option keys and then click the bluetooth icon in the top right corner. More options are available and that's worked for me before.

Did you know with the latest EFI folders on page 90 the internal intel bluetooth is enabled?
 
Joined
May 9, 2020
Messages
26
Motherboard
NUC8
CPU
I5
Graphics
intel I5
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Mac OS occasionally has problems with Bluetooth. Search for how to enter Debug mode in Bluetooth. You hold down shift and the option keys and then click the bluetooth icon in the top right corner. More options are available and that's worked for me before.

Did you know with the latest EFI folders on page 90 the internal intel bluetooth is enabled?
Thank you very much for this quick answer, I will test the latest EFI as indicated.
 
Joined
Mar 4, 2019
Messages
11
Motherboard
Intel NUC 8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. Mac mini
Mobile Phone
  1. Android
Thanks so much for all the super helpful advice @Leesureone ! What a boon you've been!

I've got a question for you (or anyone else) -- I got a warranty replacement because of a defective fan on my NUC 8. I get an error when it tries to boot clover (was working on OC migration when fan issue stopped me) that says something like "Security error: cannot boot on this device". That's not verbatim, but the gist of the message.

It will then boot to the Windows drive and work just fine.

So my question is this: Is there a way to get around this, or do I need to start over with a fresh install disk?'

Thanks!
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,252
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks so much for all the super helpful advice @Leesureone ! What a boon you've been!

I've got a question for you (or anyone else) -- I got a warranty replacement because of a defective fan on my NUC 8. I get an error when it tries to boot clover (was working on OC migration when fan issue stopped me) that says something like "Security error: cannot boot on this device". That's not verbatim, but the gist of the message.

It will then boot to the Windows drive and work just fine.

So my question is this: Is there a way to get around this, or do I need to start over with a fresh install disk?'

Thanks!
Appreciate the good words, I am not familiar with that error message. Did you turn off secure boot in the bios? Wondering if that is the cause.
 
Joined
Mar 4, 2019
Messages
11
Motherboard
Intel NUC 8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
  1. Mac mini
Mobile Phone
  1. Android
Appreciate the good words, I am not familiar with that error message. Did you turn off secure boot in the bios? Wondering if that is the cause.
That was it! Thanks again -- Now to migrate to OC and upgrade to Big Sur!
 
Joined
May 28, 2018
Messages
48
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Updated my nuci15beh to the OC63 folder that was shared back in November and installted Big Sur and it's been working great. I even did the Big Sur 11.2 update today with no issues. One thing I have noticed is my fan seems to be working a harder since the change to big sur....I have become a cautious critter when it comes to updating/changing. I was thinking of 1) disassembling and blowing out nuc to make sure there has not been a build up of dust anywhere (I know that wont hurt anything) and then 2) upgrading to newest kexts 3) upgrading to the new 87 bios. I think I am running 71. Of course I would first try out the kexts on a USB boot, but I wanted to see if any of these are ill advised?

Thanks
 
Last edited:

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,252
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Updated my nuci15beh to the OC63 folder that was shared back in November and installted Big Sur and it's been working great. I even did the Big Sur 11.2 update today with no issues. One thing I have noticed is my fan seems to be working a harder since the change to big sur....I have become a cautious critter when it comes to updating/changing. I was thinking of 1) disassembling and blowing out nuc to make sure there has not been a build up of dust anywhere (I know that wont hurt anything) and then 2) upgrading to newest kexts 3) upgrading to the new 87 bios. I think I am running 71. Of course I would first try out the kexts on a USB boot, but I wanted to see if any of these are ill advised?

Thanks
No reason not to do any of those things, I think Big Sur requires a little more overhead and that may be all it is. You can also try adjusting the fan speed in the bios
 
Joined
Mar 4, 2012
Messages
26
Motherboard
Intel NUC8i7BEH
CPU
Core i7-8559U
Graphics
Iris Plus 655
Mac
  1. MacBook Pro
  2. Mac mini
Just chiming in to report a smooth upgrade from 11.1 to 11.2 using the built in update utility and the latest EFI bundle with OC 0.6.5. Seems 11.2 doesn't need OC 0.6.6.
 
Joined
Feb 25, 2013
Messages
65
Motherboard
NUC 8i5BEH-0087
CPU
i5-8259U
Graphics
UHD 655
Mobile Phone
  1. Android
Hi,
Thanks Leesureone I've just update OC from 0.6.5 to 0.6.6.
Everything works fine but my second HD with windows 10 is now
invisible in the boot menu.
Do I need a new driver ?
Because driver folder is very reduced now only : HFSPlus.efi, Opencanopy.efi, OpenRuntime.efi.
 
Joined
Feb 25, 2013
Messages
65
Motherboard
NUC 8i5BEH-0087
CPU
i5-8259U
Graphics
UHD 655
Mobile Phone
  1. Android
Hi,
Thanks Leesureone I've just update OC from 0.6.5 to 0.6.6.
Everything works fine but my second HD with windows 10 is now
invisible in the boot menu.
Do I need a new driver ?
Because driver folder is very reduced now only : HFSPlus.efi, Opencanopy.efi, OpenRuntime.efi.
I reply to myself
i 've just changed : Misc -> Security -> ScanPolicy set to 0 to show all drives
and my windows 10 HD is now visible in boot menu.
 
Top