Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
igration was a success, zero issues. But I did have to redo the entire SMBIOS, incase apple records my MAC address.
Everything works fine now, hope yours
The migration was a success, zero issues. But I did have to redo the entire SMBIOS, incase apple records my MAC address.
Everything works fine now, hope yours will soon.
Sweet!
Mine is literally in the UPS truck awaiting delivery as we speak, I'll keep you posted.
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
The migration was a success, zero issues. But I did have to redo the entire SMBIOS, incase apple records my MAC address.
Everything works fine now, hope yours will soon.
Just got mine, installed everything, no more monitor issues after several boots, fingers crossed! :headbang:

Out of curiosity, what color is your hard drive blinker? my previous one was orange, this one is white, so weird. Also noticed production year on this replacement unit is 12/2018, the one that had monitor problem was 2/2019.
 
Joined
Aug 1, 2018
Messages
13
Motherboard
Z370 Aorus Gaming 7
CPU
i7-7800K
Graphics
GTX 1080 Ti Extreme
Mac
iMac, Mac mini
On page 90 here #894 I've got some EFI folders you can test drive, the clover version isn't updated though. Meanwhile it wouldn't surprise me if it was the cable or adapter. That's been reported here enough.
Yup, turned out that the issue was the usbc adapter, or rather - do not use apple thunderbolt 3 (usb-c) to thunderbolt (mini display port) adapters - got a regular usb-c -> HDMI and usb-c -> display port and both worked fine. Dual monitor works perfectly fine :) Thanks!
 
Joined
Mar 5, 2019
Messages
56
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
MacBook Pro
Mobile Phone
iOS
Just got mine, installed everything, no more monitor issues after several boots, fingers crossed! :headbang:

Out of curiosity, what color is your hard drive blinker? my previous one was orange, this one is white, so weird. Also noticed production year on this replacement unit is 12/2018, the one that had monitor problem was 2/2019.
My OG was 12/2018
My first replacement is 4/2019
AND the current one is SURPRISINGLY 6/2020. I cant believe they would make more of this :) I was wrong huh, looks like selling numbers were good.
Had a small issue where HDMI would blink on my 2K screen, so I switched the cable with my 1080P USBC-HDMI. And everything works fine now.
 
Joined
Feb 21, 2010
Messages
1,986
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
Just got mine, installed everything, no more monitor issues after several boots, fingers crossed! :headbang:

Out of curiosity, what color is your hard drive blinker? my previous one was orange, this one is white, so weird. Also noticed production year on this replacement unit is 12/2018, the one that had monitor problem was 2/2019.
You can change the color in the bios
 
Joined
Feb 21, 2010
Messages
1,986
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
ok thank you. Then I have a problem because my pc don't detect Bluetooth :(
Is bluetooth turned on in the bios and are you sure you are loading the kext properly? Does it work in Windows or Linux by comparison?
 
Joined
Oct 11, 2017
Messages
74
Motherboard
Intel NUC Kit 8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
Mac mini
Is bluetooth turned on in the bios and are you sure you are loading the kext properly? Does it work in Windows or Linux by comparison?
In bios is enabled but system it don't see. I use the command log show --last boot | grep IntelFirmware but no log so it doesn't work and I dunno where is problem. Maybe USB ports
 
Joined
Feb 21, 2010
Messages
1,986
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
In bios is enabled but system it don't see. I use the command log show --last boot | grep IntelFirmware but no log so it doesn't work and I dunno where is problem. Maybe USB ports
Yes, that could be what you need to resolve for it to work. Bluetooth requires it.
 
Last edited:
Joined
Oct 11, 2017
Messages
74
Motherboard
Intel NUC Kit 8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
Mac mini
Yes, that could be what you need to resolve for it to work. Bluetooth requires it.
Ok so now system detects Bluetooth, but when I click on icon and he looks for devices so then application freeze. Ofc when I use command into the terminal so no log. I did delete all bluetooth.plist and still the same problem.
 
Top