Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Jan 16, 2015
Messages
10
Motherboard
GA-Z97MX-GAMING 5
CPU
i7-4790K
Graphics
GTX 970
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Run ./install_downloads.sh to fix.

But also, your copy of the github project is not up-to-date (there have been recent changes that you don't have).
Make sure you follow post #1 instructions for updating.

Your drivers64UEFI is wrong. apfs.efi is not used anymore. Instead, as per guide, we use ApfsDriverLoader-64.efi and ApfsImageLoader-64.efi.
Also, you're not running the recommended RehabMan Clover build.
Hi RehabMan,

My apologies, I thought I had kept my git repo up-to-date, but I must have done something wrong. Anyway, I've carried out those steps, still no change on the audio out options.

I attach a further set of PR files. Any guidance is greatly appreciated.

Best wishes.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi RehabMan,

My apologies, I thought I had kept my git repo up-to-date, but I must have done something wrong. Anyway, I've carried out those steps, still no change on the audio out options.

I attach a further set of PR files. Any guidance is greatly appreciated.

Best wishes.
You have kexts in EFI/Clover/kexts/Other that imply you have NOT run ./download.sh and ./install_downloads.sh with current github code recently.

Note: Your ioreg shows AppleALC is not initializing at HDEF, which probably indicates the latest AppleALC.kext is not installed.

Also, apfs.efi should not be in drivers64UEFI (ApfsDriverLoader-64.efi replaces it).
 
Last edited:
Joined
Jan 16, 2015
Messages
10
Motherboard
GA-Z97MX-GAMING 5
CPU
i7-4790K
Graphics
GTX 970
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
You have kexts in EFI/Clover/kexts/Other that imply you have NOT run ./download.sh and ./install_downloads.sh with current github code recently.

Note: Your ioreg shows AppleALC is not initializing at HDEF, which probably indicates the latest AppleALC.kext is not installed.

Also, apfs.efi should not be in drivers64UEFI (ApfsDriverLoader-64.efi replaces it).
I'm not quite sure what to say. I've only ever followed the guide for this build and apart from having 32GB of RAM, there isn't really anything different from your initial guide.

I'm unclear as to what steps I need to take to restore audio over HDMI, and I don't know why the latest version of AppleALC would not be installed having followed your previous guidance precisely.

Best wishes.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm not quite sure what to say. I've only ever followed the guide for this build and apart from having 32GB of RAM, there isn't really anything different from your initial guide.

I'm unclear as to what steps I need to take to restore audio over HDMI, and I don't know why the latest version of AppleALC would not be installed having followed your previous guidance precisely.

Best wishes.
Make sure you copy of the github project is up-to-date.
Then run through all post-install instructions as per post #1.
That will insure everything is up-to-date.
It is all covered in post #1.
If you still have an issue, reply with details and full PR files.
 
Joined
Jul 4, 2013
Messages
64
Motherboard
NUC8i7BNH
CPU
i7 8559U
Graphics
UHD 655
Mac
MacBook Pro
Hi RehabMan, I have just realized that when I try to shutdown, the NUC reboots again, it doesn’t keep off. Do you know why?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jul 4, 2013
Messages
64
Motherboard
NUC8i7BNH
CPU
i7 8559U
Graphics
UHD 655
Mac
MacBook Pro

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Comments:
- FakeSMC sensor kexts should not be in Clover/kexts/Other
- check your BIOS settings
- TRIM enable with APFS not recommended
- as a test, try without BT/WiFi card (disable in BIOS), or just without BT keyboard paired
- current guide/repo suggests iMac16,1
- your ACPI/patched/SSDT-NUC7-DC.aml is not up-to-date with respect to current github
 
Joined
Jul 4, 2013
Messages
64
Motherboard
NUC8i7BNH
CPU
i7 8559U
Graphics
UHD 655
Mac
MacBook Pro
Comments:
- FakeSMC sensor kexts should not be in Clover/kexts/Other
- check your BIOS settings
- TRIM enable with APFS not recommended
- as a test, try without BT/WiFi card (disable in BIOS), or just without BT keyboard paired
- current guide/repo suggests iMac16,1
- your ACPI/patched/SSDT-NUC7-DC.aml is not up-to-date with respect to current github
Done what you said (but keep trim enabled, as I didn't have problems so far), but it continues rebooting. After changing all my config.plist with the current repo config.plist, second HDMI port (non UHD protected labelled) stopped working and have to change HDMI cable to the other port...
The model I use is iMac16,2 as stated in the config.plist, not iMac16,1 as you say in the post.
I upload again the diag zip.

Thank you for help!!
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,714
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Done what you said (but keep trim enabled, as I didn't have problems so far), but it continues rebooting. After changing all my config.plist with the current repo config.plist, second HDMI port (non UHD protected labelled) stopped working and have to change HDMI cable to the other port...
The model I use is iMac16,2 as stated in the config.plist, not iMac16,1 as you say in the post.
I upload again the diag zip.

Thank you for help!!
iMac16,1 and iMac16,2 should be mostly equivalent (both are Intel IGPU).

Only fundamental difference between your old plist (last PR files) and this one (these PR files) is SMBIOS.
You can always test again with iMac14,2 to see if you notice a diff (or even iMac14,1).

Did you test without the BT/WiFi, without BT keyboard as I suggested? What was the result?
 
Top