Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Oct 19, 2013
Messages
100
Motherboard
NUC Kit NUC8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Anyone experiencing mouse lag using intelBluetoothFirmware.kext? was working fine until updated to OC 5.8
 
Joined
Nov 17, 2014
Messages
77
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-9700K
Graphics
RX 5700XT
Mac
  1. iMac
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
So is anybody using an Asus BT400 bluetooth dongle? I can't get mine to work reliably and my Logitech G603 mouse seems to refuse to connect most of the time.

I've tried using the BrcmPatchRAM 3 & associated kexts but it still refuses to load the right firmware so either I'm doing something wrong or I don't know what's happening. This is with OC0.5.8 NUCB8i5BEH

Cheers

Jim
 
Last edited:
Joined
Nov 17, 2014
Messages
77
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i7-9700K
Graphics
RX 5700XT
Mac
  1. iMac
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
So is anybody using an Asus BT400 bluetooth dongle? I can't get mine to work reliably and my Logitech G603 mouse seems to refuse to connect most of the time.

I've tried using the BrcmPatchRAM 3 & associated kexts but it still refuses to load the right firmware so either I'm doing something wrong or I don't know what's happening. This is with OC0.5.8 NUCB8i5BEH

Cheers

Jim

Turns out I had my Brcm kexts in the wrong order, which is important, apparently. Also for my Asus BT400 it seems work better with the specific firmware injector kexts & associated BrcmFirmwareRepo.kext.
 
Joined
Sep 15, 2019
Messages
19
Motherboard
Intel Nuc8i3BEH1
CPU
Intel Core i3
Graphics
Irs Plus 655
Mobile Phone
  1. iOS
Check that sip is disabled with:
csrutil status

If not, reboot to recovery, open a terminal, and write:
csrutil disable

it is. however, I've move not from it. its not critical right now.
 
Joined
May 9, 2020
Messages
26
Motherboard
NUC8
CPU
I5
Graphics
intel I5
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Good Morning, everyone,
I've been trying for a long time to start my NUC with Mojave without success after trying a lot of tutorials on this site, I just manage to get the apple with the scrollbar that stays at most indefinitely during the installation after booting on the usb key and after running CLOVER.

Does anyone have a link that works with my hardware?
Here is my configuration:
NUC8I5BEH2
Bios: BECFL357.86A.0078

Thank you very much
 
Joined
Sep 15, 2019
Messages
19
Motherboard
Intel Nuc8i3BEH1
CPU
Intel Core i3
Graphics
Irs Plus 655
Mobile Phone
  1. iOS
Good Morning, everyone,
I've been trying for a long time to start my NUC with Mojave without success after trying a lot of tutorials on this site, I just manage to get the apple with the scrollbar that stays at most indefinitely during the installation after booting on the usb key and after running CLOVER.

Does anyone have a link that works with my hardware?
Here is my configuration:
NUC8I5BEH2
Bios: BECFL357.86A.0078

Thank you very much


Hey ,

try the efi on page 90. I’m using oc8 and I’ve similar hardware to yours. My bios is a bit higher though, 71 I believe
 
Joined
Sep 15, 2019
Messages
19
Motherboard
Intel Nuc8i3BEH1
CPU
Intel Core i3
Graphics
Irs Plus 655
Mobile Phone
  1. iOS
@Leesureone did some amazing work and compile a bunch here.
So check it out.
 
Joined
Apr 17, 2020
Messages
20
Motherboard
intel nuc8i7beh
CPU
intel i7
Graphics
intel iris plus 655 + eGPU Radeon RX 570
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Good Morning, everyone,
I've been trying for a long time to start my NUC with Mojave without success after trying a lot of tutorials on this site, I just manage to get the apple with the scrollbar that stays at most indefinitely during the installation after booting on the usb key and after running CLOVER.

Does anyone have a link that works with my hardware?
Here is my configuration:
NUC8I5BEH2
Bios: BECFL357.86A.0078

Thank you very much

Hello, try with OpenCore. @Leesureone OpenCore EFI works fine for me.

bye
 
Joined
Feb 23, 2011
Messages
26
Motherboard
Gigabyte Z77X-UD3H
CPU
i5-2500K
Graphics
GTX 960
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello, first of all thanks Leesureone for your hard work keeping this thread alive.
I used your Clover EFI and everything works fine except for the graphic part. I can't have a resolution higher than 1080p. On my 30" monitor I'm stuck at 1920x1080. I tried to go over the many pages but there are so many posts to read. If someone has an idea. Thank you very much.
 
Top