Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,383
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I tried your config.plist just now. Unfortunately still no sound—not a single audio output device listed. :(

Thanks anyway, was worth a try.
I need to look harder at your debug later when I’m back home
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,383
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I tried your config.plist just now. Unfortunately still no sound—not a single audio output device listed. :(

Thanks anyway, was worth a try.
Okay, I found that the Rehabman script double loaded kexts on your machine which happened the first time around to me as well. Duplicate Kexts have been installed both in Library\Extensions as well as EFI\Clover\Kexts\Other and that could be the issue. You will have to decide first where you'd like the permanent home for your kexts to live, my suggestion is in the EFI folder because it is easier to maintain and update but arguments have been made for either location.

If you decide to remove them from L\E you will need to provide permissions to delete each one, entering your password after each move to the trash, and then once finally done you will need to rebuild the kextcache by running this command in terminal. "sudo kextcache -I /"

You can reference the kexts that are installed in Clover/ Kexts/ Other to know which to delete and which to leave. You can also decide to just delete the kexts in Clover\Kexts\Other, move them to the trash and then empty it, which is quite a bit easier and no need to rebuild the kextcache but the choice is yours.

Once done reboot, cross your fingers and check output devices in system preferences again.
 
Joined
Apr 26, 2014
Messages
19
Motherboard
Gigabyte GA-Z87N-WIFI
CPU
i7-4770K
Graphics
HD 4600
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Okay, I found that the Rehabman script double loaded kexts on your machine which happened the first time around to me as well. Duplicate Kexts have been installed both in Library\Extensions as well as EFI\Clover\Kexts\Other and that could be the issue. You will have to decide first where you'd like the permanent home for your kexts to live, my suggestion is in the EFI folder because it is easier to maintain and update but arguments have been made for either location.

If you decide to remove them from L\E you will need to provide permissions to delete each one, entering your password after each move to the trash, and then once finally done you will need to rebuild the kextcache by running this command in terminal. "sudo kextcache -I /"

You can reference the kexts that are installed in Clover/ Kexts/ Other to know which to delete and which to leave. You can also decide to just delete the kexts in Clover\Kexts\Other, move them to the trash and then empty it, which is quite a bit easier and no need to rebuild the kextcache but the choice is yours.

Once done reboot, cross your fingers and check output devices in system preferences again.

Thanks for looking further into it.

Well, I mounted my EFI, moved all the Kexts from "EFI/EFI/CLOVER/kexts/Other" to a backup folder on my desktop, rebooted and… … … still no change, still nothing in my sound output devices. *sigh*

In other news, I ordered a "Creative X-Fi Surround 5.1 Pro V3" USB sound card, which arrived yesterday and that thing does it's job pretty well. With it attached, I actually have digital 5.1. output on the NUC. I certainly would like to get the sound working natively without any extra hardware and save the money, but if all else fails, I can live with having the Creative card attached permanently.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,383
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks for looking further into it.

Well, I mounted my EFI, moved all the Kexts from "EFI/EFI/CLOVER/kexts/Other" to a backup folder on my desktop, rebooted and… … … still no change, still nothing in my sound output devices. *sigh*

In other news, I ordered a "Creative X-Fi Surround 5.1 Pro V3" USB sound card, which arrived yesterday and that thing does it's job pretty well. With it attached, I actually have digital 5.1. output on the NUC. I certainly would like to get the sound working natively without any extra hardware and save the money, but if all else fails, I can live with having the Creative card attached permanently.

You can try this #1,594
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,383
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Ok thanks, I'll try that as well. Will report back.

And what about #11? Is that still relevant in late 2019?
Installing kexts to L/E requires a kext installer or the appropriate terminal commands. Fyi
 
Joined
Jan 26, 2019
Messages
30
Motherboard
NUC7I7DNKE
CPU
i7-8650U
Graphics
UHD620
I should point out that I actually don't know if audio of HDMI works because I use a bluetooth speaker.
I can confirm that HDMI audio absolutely works on nuc7 on both Mojave and Catalina. The only thing that doesn't work is volume adjustment via the menu bar as that is apparently how Apple designed it.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,383
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Last edited:
Joined
Nov 24, 2011
Messages
7
Motherboard
Asus Maximus iX Apex
CPU
17 7700k
Graphics
Zotac 1070 AMP
Hey All,

Looking to get an intel NUC8i7HVK and follow the guide on the hac-mini GitHub. I was wondering 2 things before I grab one.

1. is eGPU possible in Mojave with this? (not planning to upgrade as I have hardware that doesn't like Catalina yet) its not critical to me just curious.
2. I read somewhere in this thread (and I can't seem to find it anymore) that you can install the official Apple Broadcom Wifi into a USB adapter and use it that way; then you can use both SSD slots?

Sorry for the hijack very interested in the build and found a NUC for a good price!
 
Top