Contribute
Register

[Guide] Intel NUC DC3217IYE macOS Sierra 10.12 (TV BOX)

Joined
May 2, 2012
Messages
47
Motherboard
DC3217IYE
CPU
i3-3217U
Graphics
Intel HD4000

Project Info

This Guide describes my work to get my tv pc to a new operating system after using mountain lion for a (to) long time with stopped software support. So i decided to use Sierra 10.12.6 instead of the new High Sierra to avoid instability from new minor/major updates.

The experience was nearly OOB and all problems could be solved with a quick search in the forum.

The nuc is now working very reliable together with my LG Full HD 55“ and is used for KODI, Spotify, Youtube etc. Kodi is controlled with Flirc and a XBOX remote control. Everything else with apple mouse and bluetooth keyboard

Used Hardware
Intel® NUC-Kit DC3217IYE
  • Release-Date Q4'12
  • Mainboard-Chip Intel® QS77 Express-Notebookchip
  • Prozessor i3-3217U
  • Ram 4 GB Corsair DDR3-1333 (SO-DIMM)
  • Frequenz 1,80 GHz
  • Video Dual HDMI
  • Graphic HD4000
  • Audio HDMI
  • Lan Intel E1000
  • Wlan Atheros 9280
  • USB 2.0 3 Ports
  • Installed Bios 42 (GKPPT10H.86A.0042)
Other Hardware
  • Bluetooth Belkin / Broadcom (USB)
  • Flirc Remote Stick (USB)
  • Apple Mouse (Wireless) Magic Mouse (2009)
  • Keyboard Perixx Periboard 804
  • XBOX one remote control
  • 8GB USB Stick
Used Software
  • macOS 10.12.6
  • UniBeast
  • MultiBeast 9.2
  • EFI-Mounter v3
Installation
  1. Create a USB macOS 10.12.6 stick with UniBeast and select the UEFI option
  2. For successful boot of the sierra setup we have to set a Clover Option
    Code:
    Options > Graphics Injector > ID and enter 0x12345678
  3. Install Sierra to your internal drive.
MultiBeast

Using MultiBeast 9.2 after Installation and install the following settings



Also don‘t forget the Intel Graphics Fixup!



DSDT
  1. Mount your EFI partition using EFI-Mounter v3
  2. Copy the DSDT.aml to folder
    Code:
    /Volumes/EFI/EFI/CLOVER/ACPI/patched
Note: It‘s only tested for bios version 42

That‘s it! Now everything should work (after reboot)

Issues
  • HDMI Audio output is only working for the port near the network
  • Bluetooth after sleep is not working with my Bluetooth USB
Bios-Warning

I installed the bios version 62 (GKPPT10H.86A.0062) from the intel website but i ended with no display output from the box. So i used the yellow jumper on the mainboard and a USB stick to flash version 42 to the box again.

Be careful with version 62/newer versions!

Comment

Hope you like the guide! Comment if you have questions.

Source
https://ark.intel.com/de/products/71275/Intel-NUC-Kit-DC3217IYE
https://www.tonymacx86.com/threads/solved-sierra-wont-boot-after-multibeast-installation.231620/
https://www.tonymacx86.com/threads/solved-intel-nuc-hdmi-audio.81396/

Regards Withoutaface
 

Attachments

Last edited by a moderator:
Joined
Dec 10, 2017
Messages
5
Motherboard
NUC 3217BY
CPU
I3-3217U
Graphics
HD4000
Mac
MacBook Pro
Hi,

Thanks for you guide! However, I can't get it working on my DC3217BY (so thunderbolt version): I can't get the graphic acceleration to work.

What is you plist? In particular, what is you ig-plateform-id?

Thanks in advance!
 
Joined
May 2, 2012
Messages
47
Motherboard
DC3217IYE
CPU
i3-3217U
Graphics
Intel HD4000
Hello, in my config.plist only Inject Intel is set to true. There is no other setting or ig-platform-id override.
The ig-platform-id was automatically set to 0x01660009 which matches to this guide (1920x1080)
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
"0x01660008, 0x01660009: HD4000 1600x900, 1920x1080"

For me the "Intel Graphics Fixup" solved eveything but maybe you can force the id in your config.plist.

Hope you can figure it out!
 
Joined
Jan 3, 2018
Messages
3
Motherboard
Intel NUC6i5SYK
CPU
Skylake i5 6260U
Graphics
Intel Iris 540
Mac
Mac mini
Hi everyone, thanks to tonymac86 I got my system running.
Just a follow up as I couldn't find anyone mentioning this already:
I got OSX 10.13 running on my DC3217IYE and the latest bios (0062)
Simply used the latest unibeast+multibeast for OSX 10.13 patched the DSDT.aml as mentioned above and that was it.
cheers :D
 
Joined
May 2, 2012
Messages
47
Motherboard
DC3217IYE
CPU
i3-3217U
Graphics
Intel HD4000
... I got OSX 10.13 running on my DC3217IYE and the latest bios (0062) ...
It's great to hear that you got 10.13 working and even with the bios version 0062 :)
(so maybe one of my component is not compatible with the 62 bios version)
 
Joined
Aug 1, 2016
Messages
65
Motherboard
HP Probook 430 G2 Broadwell
CPU
i5
Graphics
HD 5500 1366x768
Mac
MacBook Air
Mobile Phone
iOS
AWESOME GUIDE!!! 1000 kisses/hugs/high fives - whatever you might choose! Working like a charm!!!
 
Joined
Aug 1, 2016
Messages
65
Motherboard
HP Probook 430 G2 Broadwell
CPU
i5
Graphics
HD 5500 1366x768
Mac
MacBook Air
Mobile Phone
iOS
btw - does anyone know a wlan/bt card for the above nuc which get's bt and wlan working properly? TIA!
 
Joined
Feb 6, 2013
Messages
38
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4590
Graphics
RX-580
Mobile Phone
Android, iOS,
Hi everyone, thanks to tonymac86 I got my system running.
Just a follow up as I couldn't find anyone mentioning this already:
I got OSX 10.13 running on my DC3217IYE and the latest bios (0062)
Simply used the latest unibeast+multibeast for OSX 10.13 patched the DSDT.aml as mentioned above and that was it.
cheers :D
What video resolution are you getting? intel website does not point out the sepc of this NUC. Thanks.
 
Joined
Jan 20, 2017
Messages
2
Motherboard
Intel QS77
CPU
i3-3217
Graphics
HD4000
Mac
Mac mini
Mobile Phone
Android, iOS
thanks for this sharing.
I successfully installed OSX 10.13 (High Sierra) on my DC3217IYE and the latest bios (0063), yes, 0063.
 
Joined
Feb 9, 2011
Messages
26
Motherboard
Gigabyte Z370N WIFI
CPU
i7 8700
Graphics
HD 630
Mac
MacBook
Mobile Phone
iOS
I can't get graphics to work properly.
I have graphics but really sluggish and laggy.

DC3217IYE, MacOS High Sierra.

About this Mac says it's a HD 4000 7mb.
I have tried BIOS 42, 62 and 63.
I have 128mb selected in BIOS.
Tried both: Graphics/ig-platform-id=0x0x01660009 and 0x01660008.

System report says there is no kext loaded for graphics/displays.

What am I missing or doing wrong?!

@Astin.King would you mind to share your config.plist, Library/Extensions and EFI folder?
 
Last edited:
Top