Contribute
Register

[Guide] Intel IGPU HDMI/DP audio (all Sandy Bridge -> Kaby Lake [and likely later])

Joined
Jan 7, 2018
Messages
5
Motherboard
MSI Z370A Krait Gaming
CPU
i7-8700k
Graphics
GTX 1080Ti
Mobile Phone
Android
On HD4000 via HDMI max resolution 1920x1080@60? My monitor support 2K@144Hz
Laptop: Asus N56VB(i7-3610QM, HD4000+GT740M, HM76 Chipset)
 
Joined
Nov 19, 2017
Messages
39
Motherboard
Dell 3567
CPU
i3-7020U
Graphics
HD 620
Mac
MacBook Pro
Mobile Phone
Android
Hi,
Why the system always trying to connect to DP port? I don't have one. My Dell laptop has only 1 video port - HDMI (no VGA, DP, DVI).

I see a lot of [IGFB][INFO] [Connection_probe] msgs in the log and during these connections my laptop hangs.

If eliminate DP port the system reboots every 5m ([IGFB][INFO] [Connection_probe] failed??) and after waking from sleep.


Any ideas?
 
Joined
Oct 15, 2012
Messages
8
Motherboard
Acer Aspire F15
CPU
i7-7500U
Graphics
HD 620
Mac
MacBook Pro
Mobile Phone
Android
I installed Catalina (10.15.2) on Acer Aspire. Few issues were quite easy to fix. Got stuck with HDMI and Audio. I use Lilu and AppleALC for Audio, WEG for video. Laptop has two SSD drives (one hold windows, another Hackintosh). HDMI was rebooting laptop on plugin. Opened pipes on fb 1,2 and now HDMI is dead. I do not see a display on neither of FBs
Audio is even greater enigma. I had it working and lost it when I started tinkering with HDMI.
Any help would be greatly appreciated. Let me know what else is of interest, please
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
18,663
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I installed Catalina (10.15.2) on Acer Aspire. Few issues were quite easy to fix. Got stuck with HDMI and Audio. I use Lilu and AppleALC for Audio, WEG for video. Laptop has two SSD drives (one hold windows, another Hackintosh). HDMI was rebooting laptop on plugin. Opened pipes on fb 1,2 and now HDMI is dead. I do not see a display on neither of FBs
Audio is even greater enigma. I had it working and lost it when I started tinkering with HDMI.
Any help would be greatly appreciated. Let me know what else is of interest, please
inject intel should be set to false

this should be removed:
Code:
<key>ig-platform-id</key>
        <string>0x0</string>
this:
Code:
<key>Inject</key>
            <string>Detect</string>
should be:
Code:
<key>Inject</key>
            <string>No</string>
this:
Code:
<key>CsrActiveConfig</key>
        <string>0x0</string>
should be:
Code:
<key>CsrActiveConfig</key>
        <string>0x67</string>
MacBookPro14,1 would be a better choice of smbios

also there is a fix in hackintool to stop reboot on hdmi connect
 
Joined
Oct 15, 2012
Messages
8
Motherboard
Acer Aspire F15
CPU
i7-7500U
Graphics
HD 620
Mac
MacBook Pro
Mobile Phone
Android
inject intel should be set to false

this should be removed:
Code:
<key>ig-platform-id</key>
        <string>0x0</string>
this:
Code:
<key>Inject</key>
            <string>Detect</string>
should be:
Code:
<key>Inject</key>
            <string>No</string>
this:
Code:
<key>CsrActiveConfig</key>
        <string>0x0</string>
should be:
Code:
<key>CsrActiveConfig</key>
        <string>0x67</string>
MacBookPro14,1 would be a better choice of smbios

also there is a fix in hackintool to stop reboot on hdmi connect
Thank you. Done all this. Does not make a difference. Will try and investigate further
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
18,663
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Thank you. Done all this. Does not make a difference. Will try and investigate further

and also check the guides at the top of that post
 
Joined
Mar 20, 2020
Messages
11
Motherboard
ASUSTeK N56VB
CPU
i7-3630QM
Graphics
HD4000
@Feartech
Hello. Maybe you can help me?
Notebook config:
Intel® Core™ i7 3630QM Processor
Intel Graphics HD4000
Intel® HM76 Express Chipset
15.6" 16:9 Full HD

Clover 5104 | MacOS 10.15.3

Problem. HDMI is working ( ), but internal display (with ig-platform-id 0x01660004 ) - no.

HDMI is working without entering ig-platform-id or with 0x01660003. But in mac os preferences I see 2 monitors. But internal - is black.
Only display with ig-platform-id 0x01660004

My EFI and config.plist is attached

Please, help me to solve it!
Thank you in advance.
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
18,663
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
@Feartech
Hello. Maybe you can help me?
Notebook config:
Intel® Core™ i7 3630QM Processor
Intel Graphics HD4000
Intel® HM76 Express Chipset
15.6" 16:9 Full HD

Clover 5104 | MacOS 10.15.3

Problem. HDMI is working ( ), but internal display (with ig-platform-id 0x01660004 ) - no.

HDMI is working without entering ig-platform-id or with 0x01660003. But in mac os preferences I see 2 monitors. But internal - is black.
Only display with ig-platform-id 0x01660004

My EFI and config.plist is attached

Please, help me to solve it!
Thank you in advance.
config.plist looks a little old, grab a newer one from the laptop guide:

also read up on:
 
Joined
Jul 17, 2019
Messages
14
Motherboard
Asus TUF B360M-Plus Gaming/BR
CPU
i5 9400F
Graphics
RTX 2070
Maybe your HDMI is directly connected to the Nvidia device.
Check in Windows.
RehabMan,
I have the same problem, I realized with Hackintool that when you put the HDMI cable in the notebook it recognizes as HDMI right? However, the rare times that he recognizes as "DP" he works the hdmi audio. Is there any way to always recognize the cable in the notebook's HDMI port as "DP"?
 
Top