Contribute
Register

[Guide] Intel IGPU HDMI/DP audio (all Sandy Bridge -> Kaby Lake [and likely later])

Joined
Dec 14, 2013
Messages
101
Motherboard
HP Pavilion x360 13-u002ur, W7R60EA
CPU
Intel Core i5-6200U (2.3 ГГц)
Graphics
Разрешение:1920x1080 HD520
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Good afternoon. I have a problem. When I turn on the laptop with the HDMI connector connected, the download goes up to 60 percent, and then the screen turns black. Can I fix this?
 

Attachments

  • RehabMan.zip
    2.9 MB · Views: 64

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Good afternoon. I have a problem. When I turn on the laptop with the HDMI connector connected, the download goes up to 60 percent, and then the screen turns black. Can I fix this?

You can always boot with the monitor turned on, then turn the monitor on after booting.
FYI: It does not appear you patched the connector-type for HDMI...
 
Joined
Dec 14, 2013
Messages
101
Motherboard
HP Pavilion x360 13-u002ur, W7R60EA
CPU
Intel Core i5-6200U (2.3 ГГц)
Graphics
Разрешение:1920x1080 HD520
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
You can always boot with the monitor turned on, then turn the monitor on after booting.
FYI: It does not appear you patched the connector-type for HDMI...

In normal boot, the connector is displayed as 008, when it connects to HDMI it turns to 004 and remains until the reboot
 
Joined
Jan 10, 2018
Messages
34
Motherboard
Samsung NP900X3C (Clover)
CPU
i5 3317u/HM75
Graphics
HD4000 (1600x900)
Mobile Phone
  1. Android
Hi! I would like get some help. I have a working appleHDA audio but I can't enable the HDMI audio. Could you help me please?
 

Attachments

  • Vilmos’s MacBook Pro.ioreg
    12.5 MB · Views: 90
  • debug_8655.zip
    992.4 KB · Views: 69
  • CLOVER.zip
    3.9 MB · Views: 74

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
In normal boot, the connector is displayed as 008, when it connects to HDMI it turns to 004 and remains until the reboot

It is relatively common, but no idea why it happens.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi! I would like get some help. I have a working appleHDA audio but I can't enable the HDMI audio. Could you help me please?

Your ioreg shows no HDMI device plugged in. No expectation of HDMI audio without an HDMI device...
And you didn't patch the any of the external connectors in the framebuffer for HDMI.
Read post #1.
 
Top