Contribute
Register

[GUIDE] Intel HD Graphics 5500 on OS X Yosemite 10.10.3

Joined
Dec 29, 2014
Messages
147
Motherboard
Lenovo X1 Carbon (Gen 3 20BS) - Clover
CPU
i7-5600U
Graphics
HD 5500, 1920x1080
Beat you to it :D

Sadly that led to no change, I still got the kernel panic. Any other tips?

Extra Info:
mygfx.png

Just in case, that is my graphics page, in theory that should be okay? It is possible that I need a different framebuffer patch?

I will update this post with a screenshot of the panic - I think it is the same though, happens at the same time.

Edit: Looks like the same exact error to me - again, sorry about quality.
View attachment 134445
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Beat you to it :D

Sadly that led to no change, I still got the kernel panic. Any other tips?

Extra Info:
View attachment 134444

Just in case, that is my graphics page, in theory that should be okay? It is possible that I need a different framebuffer patch?

I will update this post with a screenshot of the panic - I think it is the same though, happens at the same time.

Edit: Looks like the same exact error to me - again, sorry about quality.
View attachment 134445
Try different settings in BIOS (eg. Legacy boot enabled/disabled). Also, see what other options you have for the IGPU.

Also try different settings for ScreenResolution in config.plist.
 
Joined
Jul 27, 2011
Messages
19
Motherboard
Dell XPS 13 Touch 2015
CPU
i7-5500U
Graphics
HD 5500
i followed this guide on my dell xps13 i7-5500u with intel hd5500. after injecting ig-platform-id 0x16160002 in config.plist i got kernel panic, so i patched AppleIntelBDWGraphicsFramebuffer in config.plist. patch seems to work, but i end with console output. os is running, i can hear sound when typing on keyboard, but i guess screen output is not setup correctly. what can i do with it?
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i followed this guide on my dell xps13 i7-5500u with intel hd5500. after injecting ig-platform-id 0x16160002 in config.plist i got kernel panic, so i patched AppleIntelBDWGraphicsFramebuffer in config.plist. patch seems to work, but i end with console output. os is running, i can hear sound when typing on keyboard, but i guess screen output is not setup correctly. what can i do with it?
I think patching to mask the panic is a bad idea. Fix the root of the problem instead...
 
Joined
Dec 29, 2014
Messages
147
Motherboard
Lenovo X1 Carbon (Gen 3 20BS) - Clover
CPU
i7-5600U
Graphics
HD 5500, 1920x1080
it's mentioned in STEP 2.1: Apply the patch to pass the Stolen Memory assertion. I tried.
Any chance I can get a copy of your config.plist for comparison to make sure I mine isn't working versus having a typo? (I tried to ask via PM but the 75 post rule is brutal.)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
it's mentioned in STEP 2.1: Apply the patch to pass the Stolen Memory assertion. I tried.
Yes, I know. I don't think masking that assertion is a good idea. The assertion was put in there for a reason.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I tried also the other way, but there's no DVTM settings in bios. And I didn't find a way how to dump my bios.
Did you patch the framebuffer so that the configuration matches what you believe your DMVT setting to be?
 
Top