Contribute
Register

[Guide] Intel Framebuffer patching using WhateverGreen

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
2,616
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
ok, i've decided to disassemble case and remove GTX and that was it. Now IGPU HD 4600 works fine with HackinTool patch for 0x0DD20003.

@gulios,

It does not look like Nvidia are going to release updated WebDrivers for Mojave anytime soon, best thing you can do is sell it and buy a second hand Vega 64 ... which is which is what i did ... managed to pick up a Sapphire Vega 64 Liquid Cooled (AIO) on ebay for a very good price ... one of the best moves i ever made on my main hackingtosh system.

Works flawlessly, MacOS UI is much smoother (no stutters when scrolling .. etc) and super fast renders in FCPX.

Cheers
Jay
 
Joined
Apr 21, 2012
Messages
280
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
@gulios,

It does not look like Nvidia are going to release updated WebDrivers for Mojave anytime soon, best thing you can do is sell it and buy a second hand Vega 64 ... which is which is what i did ... managed to pick up a Sapphire Vega 64 Liquid Cooled (AIO) on ebay for a very good price ... one of the best moves i ever made on my main hackingtosh system.

Works flawlessly, MacOS UI is much smoother (no stutters when scrolling .. etc) and super fast renders in FCPX.

Cheers
Jay
yeah i know but... it's 1080TI ;( killer in games. For now i think i'll work on IGPU only (I've changed fans position so no GTX is disconnected) or i sell GTX and case and put all into smaller case ;) without GPU...

or... maybe it's time to change Nvidia to AMD.

Does Sapphire Vega 64 works OOB?
Does "Asus Radeon RX Vega 64 ROG STRIX O8G Gaming, 8192 MB HBM2" will work OOB ?
 
Joined
Jan 21, 2012
Messages
482
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GTX 710
Mobile Phone
Android
Im following trs96's guide for a Dell 7020 and troubleshooting one of the issues - the on board Intel 4600 graphics. The image is fine when it works but in my dual monitor setup one of the monitors has to be turned off before starting the machine or neither monitor will display anything. I have looked at the Hackintool but dont really understand how to convert the info it shows into actions that I should do and wonder if someone can point me to an overview for noobs. 7020 Guide here.
Edit: seems this a known issue with iMac sys Def's which use a variation of the dispalyport standard for in built screens. Any ideas about how or if this is worth pursuing appreciated. There is a simplerfix to use an dedicated graphics card.
Edit 2: Used 14,3 sys defs and it worked.
 
Last edited:

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
2,616
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Does Sapphire Vega 64 works OOB?
Does "Asus Radeon RX Vega 64 ROG STRIX O8G Gaming, 8192 MB HBM2" will work OOB ?

@gulios,

When using a Vega GPU it's advisable to install Lilu + WhatEverGreen which applies a few patches and ensures that the correct frame buffer is configured (usually "Kamarang")

Most Sapphire cards are based on the AMD reference designs as such they tend to be more compatible with MacOS which is why i favour them .... I have no experience of the Asus so cant really comment, however the 10.14.5 update resolved a lot of thermal issues (mainly fan control) with OEM Vega cards so it will most likely be ok but i would recommend you search the forums and find someone with a success story of using the "Asus Radeon RX Vega 64 ROG STRIX O8G Gaming" card before committing to one.

For more info on AMD GPU's on MacOS see the Compatibility Guide :-


However it might be worth holding fire for a month or so, AMD have recently released details of the new Navi cards (Radeon RX 5700 series) which go on sale July 7th ... and early support for them has already been seen in Apples AMD drivers for MacOS.

I don't think they are going to be as powerful as Radeon VII but they use a new architecture (RDNA) that may be better optimised on MacOS.

I would wait and see how they benchmark against Vega 64 before making a decision, also when they hit the market its likely that Vega Gen 1 cards will probably get cheeper.

Cheers
Jay
 
Joined
Apr 21, 2012
Messages
280
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
@gulios,

When using a Vega GPU it's advisable to install Lilu + WhatEverGreen which applies a few patches and ensures that the correct frame buffer is configured (usually "Kamarang")

Most Sapphire cards are based on the AMD reference designs as such they tend to be more compatible with MacOS which is why i favour them .... I have no experience of the Asus so cant really comment, however the 10.14.5 update resolved a lot of thermal issues (mainly fan control) with OEM Vega cards so it will most likely be ok but i would recommend you search the forums and find someone with a success story of using the "Asus Radeon RX Vega 64 ROG STRIX O8G Gaming" card before committing to one.

For more info on AMD GPU's on MacOS see the Compatibility Guide :-


However it might be worth holding fire for a month or so, AMD have recently released details of the new Navi cards (Radeon RX 5700 series) which go on sale July 7th ... and early support for them has already been seen in Apples AMD drivers for MacOS.

I don't think they are going to be as powerful as Radeon VII but they use a new architecture (RDNA) that may be better optimised on MacOS.

I would wait and see how they benchmark against Vega 64 before making a decision, also when they hit the market its likely that Vega Gen 1 cards will probably get cheeper.

Cheers
Jay
Thank you @jaymonkey

I've decided to finish that battle with GPUs ;) and back to "games only on console" work on PC so i'm trying to sell all parts i needed before because of WIN and stick just to motherboard+CPU and now i'm on Streacom ST-FC8B Alpha case + motherboard + cpu and problem disappeared. HD 4600 on i7 4790K works great and stable on latest macOs.

Thank you!
 
Joined
Apr 1, 2018
Messages
33
Motherboard
Dell OptiPlex 3050-Clover
CPU
i5-7500/B250
Graphics
HD630
Mac
iMac
There's two data of framebuffer, so what's the different and which one should I select. I have a kabylake HD630 desktop with a HDMI and a DP connectors. Now I use the HDMI connector. When I use whatevergreen without any Arbitrary and select smbios 18.2/18.3, I get some skialith when minimizing a window. However, after I change smbios to 18.1, it was solved. The only different is that whatevergreen set 9MB framebuffer to 18.2/18.3 and 0 to 18.1. Confused.
Now I use smbios 18.1, but there are three DP connectors in Hackintool though I have a DP and a HDMI which is used. So should I ban two DP and change DP used to HDMI? Thank you!
412208
 
Joined
Jul 24, 2012
Messages
1
Hello All,
i'm using a tiny lenovo m900 with an intel HD530 as graphic card with 3 DP connectors. I'm using an smbios imac 16.1 as 17.1 never worked with more than one screen. Since the upgrade to 10.4.5 i've got a weird issue.
Only 2 screens are working. The last one is visible on Hackintool (or using ioreg) but it doesn't appear on display prefpanes.
Here come a screenshot a an extract of the config.plist for display :
Any idea about this kind of behavior?
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
<dict>
<key>AAPL,ig-platform-id</key>
<data>
AAASGQ==
</data>
<key>AAPL,slot-name</key>
<string>Internal</string>
<key>device-id</key>
<data>
EhkAAA==
</data>
<key>device_type</key>
<string>VGA compatible controller</string>
<key>framebuffer-patch-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-pipecount</key>
<data>
BAAAAA==
</data>
<key>framebuffer-portcount</key>
<data>
BAAAAA==
</data>
<key>model</key>
<string>HD Graphics 530</string>
</dict>
 

Attachments

Top