Contribute
Register

[Guide] Intel Framebuffer patching using WhateverGreen

Joined
Aug 14, 2010
Messages
1,013
Motherboard
GA-Z97X-UD5H-BK Rev 1.0 Bios F8
CPU
i7-4790k OC 4.9ghz
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@RehabMan and @headkaze I am going to install another SSD in my machine and test the install process again anyway so this time I will incorporate using the Spoof Audio Device ID method - will report back when I get time to do it - a bit busy in the next few days
@headkaze @RehabMan I tested this morning and the Audio spoofing did not work for me. I ended up with Built-in, Internal Speakers but no HDMI Audio see screenshot and PR files in debug_12808.zip
 

Attachments

  • debug_12808.zip
    2.4 MB · Views: 44
  • Screenshot 2018-11-09 at 11.18.36.png
    Screenshot 2018-11-09 at 11.18.36.png
    29.1 KB · Views: 83

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@headkaze @RehabMan I tested this morning and the Audio spoofing did not work for me. I ended up with Built-in, Internal Speakers but no HDMI Audio see screenshot and PR files in debug_12808.zip

That's what I expected.

But it also appears you have a kext installation problem. Look at your kextcache output:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb58a606a00 [0x7fff886b18f0]> { URL = "AppleALC.kext/ -- file:///Library/Extensions/", ID = "as.vit9696.AppleALC" }
AppleALC.kext - dependency 'as.vit9696.Lilu' not found.
AppleALC.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
 
Joined
Jun 20, 2014
Messages
1,015
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Audio spoofing did not work for me.
You're injecting audio layout 14. Not what you were injecting before. Check General->Audio section in FB-Patcher. Also check Installed section to make sure AppleALC is installed.
 
Joined
Jun 20, 2014
Messages
1,015
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
That's what I expected.

But it also appears you have a kext installation problem.

Of course it won't work if AppleALC is not installed correctly.
 
Joined
Jul 14, 2013
Messages
49
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900k
Graphics
iMac1,1 SMBIOS(only RX 570)
Mobile Phone
  1. Android
  2. iOS
Hi, I fighting with frame buffer patching, because I do not have signal on hdmi when I reach desktop, only vga, I use whatevergreen patching method, any advice ?
 

Attachments

  • debug_4441.zip
    2.5 MB · Views: 47

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Of course it won't work if AppleALC is not installed correctly.

Yes, of course.
People really need to pay close attention to their kextcache output!
 
Joined
Jun 20, 2014
Messages
1,015
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Yes, of course.
People really need to pay close attention to their kextcache output!
Well there's certainly a lot to learn. If it wasn't for experts like yourself there would be no tools like FB-Patcher either.
 
Joined
Jun 20, 2014
Messages
1,015
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
No way... You deserve all the credit for FB-Patcher :)
Well it's just a companion app to the real hard work that goes into drivers such as WEG, Lilu, AppleALC, USBInjectAll etc.
 
Joined
Aug 14, 2010
Messages
1,013
Motherboard
GA-Z97X-UD5H-BK Rev 1.0 Bios F8
CPU
i7-4790k OC 4.9ghz
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
That's what I expected.

But it also appears you have a kext installation problem. Look at your kextcache output:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7fb58a606a00 [0x7fff886b18f0]> { URL = "AppleALC.kext/ -- file:///Library/Extensions/", ID = "as.vit9696.AppleALC" }
AppleALC.kext - dependency 'as.vit9696.Lilu' not found.
AppleALC.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
mmm - that is odd, it was installed to /Library/Extensions with KextBeast I will test again.
 
Top