Contribute
Register

[Guide] Intel Framebuffer patching using WhateverGreen

Joined
Oct 1, 2010
Messages
67
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Try changing your SMBios to 18,1 or 18,2 (I had mine set to 18,2 originally and got lots of screen flickering, which went once I changed to 18,1).

Thanks. 18,1 results in black screen, and both 18,2 and ,3 flicker. I tried 17,1 now, however, and it works well (what the ****?).

So I guess I'll use 17,1 for now!

One thing I don't understand, though.. Why does it name HD 615 in framebuffer info and HD 630 in GPU info? I am reasonably sure my platform id is correct. Shouldn't it load/use a different framebuffer?
 

Attachments

  • Screenshot 2018-10-21 at 12.23.12.png
    Screenshot 2018-10-21 at 12.23.12.png
    129.2 KB · Views: 177
Joined
Aug 24, 2012
Messages
15
Motherboard
Asus ROG Strix Z370-F Gaming
CPU
i7-8700K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi pastrychef,

Thanks for the awesome guide. I'm having almost the same build as you have, i7-8700K, 32GB RAM, Asus Z370-F and Asus Strix RX Vega 64. Actually I just upgraded my GPU to Vega 64, and I haven't been able to get full hardware acceleration whatsoever. I have IGPU enabled with the BIOS settings that you've recommended in your first post, and almost identical config.plist. I've tried iMac18,3 and iMacPro1,1, both failed to get hw acceleration.

I've attached my Clover folder, could you help to see what I can do?

Thanks!
 

Attachments

  • EFI.zip
    3.4 MB · Views: 46

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,536
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi pastrychef,

Thanks for the awesome guide. I'm having almost the same build as you have, i7-8700K, 32GB RAM, Asus Z370-F and Asus Strix RX Vega 64. Actually I just upgraded my GPU to Vega 64, and I haven't been able to get full hardware acceleration whatsoever. I have IGPU enabled with the BIOS settings that you've recommended in your first post, and almost identical config.plist. I've tried iMac18,3 and iMacPro1,1, both failed to get hw acceleration.

I've attached my Clover folder, could you help to see what I can do?

Thanks!

Try the EFI from my z370 build thread. Make sure you DO NOT copy your config.plist to it. Just copy your Serial, Board Serial, and UUID to the config.plist included in my EFI.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,536
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I haven't tried to replace my whole config.plist except the serial/uuid yet, I'll try later and report back. Thanks!

When using my EFI, make sure you don't have any hackintosh kexts in /Library/Extensions/.
 
Joined
Aug 24, 2012
Messages
15
Motherboard
Asus ROG Strix Z370-F Gaming
CPU
i7-8700K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
When using my EFI, make sure you don't have any hackintosh kexts in /Library/Extensions/.

My PC won't boot with your config, not until I disable the PPMC->PMCR and EC0->EC ACPI patches. And still, no acceleration with my Vega 64. Any ideas?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,536
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
My PC won't boot with your config, not until I disable the PPMC->PMCR and EC0->EC ACPI patches. And still, no acceleration with my Vega 64. Any ideas?

What do you have in your /Library/Extensions/?
 
Joined
Aug 24, 2012
Messages
15
Motherboard
Asus ROG Strix Z370-F Gaming
CPU
i7-8700K
Graphics
RX Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
What do you have in your /Library/Extensions/?

Nothing related to Hackintosh really. All my Hackintosh kexts are in CLOVER/kexts/Other

Here's the list of /Library/Extensions:

ACS6x.kext
ArcMSR.kext
ATTOCelerityFC8.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID2.kext
CalDigitHDProDrv.kext
HandsOff.kext
HighPointIOP.kext
HighPointRR.kext
PromiseSTEX.kext
SoftRAID.kext
tap.kext
tun.kext
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,536
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Nothing related to Hackintosh really. All my Hackintosh kexts are in CLOVER/kexts/Other

Here's the list of /Library/Extensions:

ACS6x.kext
ArcMSR.kext
ATTOCelerityFC8.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID2.kext
CalDigitHDProDrv.kext
HandsOff.kext
HighPointIOP.kext
HighPointRR.kext
PromiseSTEX.kext
SoftRAID.kext
tap.kext
tun.kext

Doesn't make sense... So right now, with the Vega 64 installed, Finder is like a slideshow? No acceleration at all? When you minimize a window to the dock, you don't get the genie effect?
 
Top