Contribute
Register

[Guide] Intel Broadwell NUC5 using Clover UEFI (NUC5i5MHYE, NUC5i3MYHE, etc)

Joined
Feb 17, 2011
Messages
381
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Hi Rehabman and thank you (again) for the guide.
I just updated my NUC5i7RYH from Sierra to Mojave and everything seems to work fine, except sleep.
When I "tell" the NUC to sleep, the screen goes black, but everything else keeps running (fan, power LED, etc.).
If I try to wake it up, it crashes and reboots.
"Problem Reporting files" attached...
Thanks!
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman and thank you (again) for the guide.
I just updated my NUC5i7RYH from Sierra to Mojave and everything seems to work fine, except sleep.
When I "tell" the NUC to sleep, the screen goes black, but everything else keeps running (fan, power LED, etc.).
If I try to wake it up, it crashes and reboots.
"Problem Reporting files" attached...
Thanks!
Your Clover/kexts/Other proves you didn't follow the guide (install_downloads.sh updates/copies the required kexts there).
I think you didn't run download.sh and install_downloads.sh.
Read post #1 and follow it exactly.

Also, if your NUC has any HDMI ports (instead of DP), you must adjust the framebuffer patches.

I would not suggest you enable TRIM (your config.plist has it enabled, which is different than the provided guide plist).

Also, I'm using my own build of Clover. You seem to be using a different build.

Remove things like SoundFlower.
 
Joined
Feb 17, 2011
Messages
381
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Your Clover/kexts/Other proves you didn't follow the guide (install_downloads.sh updates/copies the required kexts there).
I think you didn't run download.sh and install_downloads.sh.
Read post #1 and follow it exactly.
Also, if your NUC has any HDMI ports (instead of DP), you must adjust the framebuffer patches.
I would not suggest you enable TRIM (your config.plist has it enabled, which is different than the provided guide plist).
Also, I'm using my own build of Clover. You seem to be using a different build.
Remove things like SoundFlower.
I did follow the guide and I did run download.sh + install_downloads.sh, but at some point and for troubleshooting purposes, I tried to remove all kexts (except FakeSMC.kext) from Clover/kexts/Other. Anyway, same crash with or without.

The NUC5i7RYH has 2 display connectors, con1 is HDMI and con2 is DP. So I enabled framebuffer-con1 only.
Code:
        <key>Properties</key>
        <dict>
            <key>PciRoot(0)/Pci(0x02,0)</key>
            <dict>
                <key>framebuffer-con1-enable</key>
                <integer>1</integer>
                <key>framebuffer-con1-type</key>
                <data>
                AAgAAA==
                </data>
                <key>framebuffer-con2-enable</key>
                <integer>0</integer>
                <key>framebuffer-con2-type</key>
                <data>
                AAgAAA==
                </data>
                <key>framebuffer-patch-enable</key>
                <integer>1</integer>
            </dict>
        </dict>
Is that correct?

I will disable trim.
I will remove SoundFlower (maybe it's not compatible with Mojave).
If it does not solve the problem, I'll try your build of Clover.

Thank you, I'll report back...
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I did follow the guide and I did run download.sh + install_downloads.sh, but at some point and for troubleshooting purposes, I tried to remove all kexts (except FakeSMC.kext) from Clover/kexts/Other. Anyway, same crash with or without.

The NUC5i7RYH has 2 display connectors, con1 is HDMI and con2 is DP. So I enabled framebuffer-con1 only.
Code:
        <key>Properties</key>
        <dict>
            <key>PciRoot(0)/Pci(0x02,0)</key>
            <dict>
                <key>framebuffer-con1-enable</key>
                <integer>1</integer>
                <key>framebuffer-con1-type</key>
                <data>
                AAgAAA==
                </data>
                <key>framebuffer-con2-enable</key>
                <integer>0</integer>
                <key>framebuffer-con2-type</key>
                <data>
                AAgAAA==
                </data>
                <key>framebuffer-patch-enable</key>
                <integer>1</integer>
            </dict>
        </dict>
Is that correct?
Yes.

I will disable trim.
I will remove SoundFlower (maybe it's not compatible with Mojave).
If it does not solve the problem, I'll try your build of Clover.

Thank you, I'll report back...
Sounds like a plan.
Keep in mind I have not tested the NUC5 with 10.14.1 yet.
 
Joined
Feb 17, 2011
Messages
381
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Keep in mind I have not tested the NUC5 with 10.14.1 yet.
I had the same crash/reboot at wake with 10.14, which is why I tried the 10.14.1 update ...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I had the same crash/reboot at wake with 10.14, which is why I tried the 10.14.1 update ...
I had no such issue with my NUC5 and 10.14. I will test 10.14.1 later next week.

Maybe BIOS setting issue? BIOS version issue?
 
Joined
Feb 17, 2011
Messages
381
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
Maybe BIOS setting issue? BIOS version issue?
I don't remember my BIOS version, but everything was fine (following your guide) under Sierra.
Anyway, I'm going to check my Bios as well ...
Thanks RehabMan.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I don't remember my BIOS version, but everything was fine (following your guide) under Sierra.
Anyway, I'm going to check my Bios as well ...
Thanks RehabMan.
Note that you have some sleep preventers:
Code:
Listed by owning process:
   pid 323(Google Chrome): [0x0000008200018181] 00:41:56 NoIdleSleepAssertion named: "WebRTC has active PeerConnections"
   pid 628(screensharingd): [0x000007ef0007825d] 00:10:16 PreventSystemSleep named: "Remote user is connected"
   pid 628(screensharingd): [0x000007ef0009825e] 00:00:00 UserIsActive named: "Remote user active"
   Timeout will fire in 600 secs Action=TimeoutActionRelease
   pid 151(coreaudiod): [0x0000002500018093] 00:43:30 PreventUserIdleSystemSleep named: "com.apple.audio.AppleHDAEngineOutputDP:3,0,1,1:0:{2D4C-0F13-01000E00}.context.preventuseridlesleep"
   Created for PID: 401.
   pid 151(coreaudiod): [0x0000002500018083] 00:43:30 PreventUserIdleSystemSleep named: "com.apple.audio.SoundflowerEngine:0.context.preventuseridlesleep"
   Created for PID: 401.
   pid 151(coreaudiod): [0x0000002500058094] 00:43:30 PreventUserIdleDisplaySleep named: "com.apple.audio.AppleHDAEngineOutputDP:3,0,1,1:0:{2D4C-0F13-01000E00}.context.preventuseridledisplaysleep"
   Created for PID: 401.
Kernel Assertions: 0x4=USB
You might want to do a fresh install to be certain 3rd party software you installed is not having an impact.
 
Joined
Nov 27, 2018
Messages
6
Motherboard
Intel NUC 5i3 RYH
CPU
i3-5010U
Graphics
HD 5500
Mac
MacBook Pro
Mobile Phone
iOS
Hello ReHabMan

many thanks for your guide, which helps me to change my nuc5 from Linux to work perfect with 10.14.1.
Great work.

I have one little open point with my new 4k monitor LG 27UK850-W. This Monitor works perfect when I use the following connection:

(nuc)miniHDMI ------- HDMI(LG) Resolution 3840x2160 / 30 Hz
I can see the complete boot process from BIOS, Clover, OS-boot, Login Screen, and working OS

(nuc)miniDP ---------- DP(LG) Resolution 3840x2160 / 60 Hz
I can see the BIOS, Clover, OS-Boot, after the switch to the Login Screen the Monitor gets dark
Switching the Monitor off / on the Login Screen is visible and I can continue to Login with this resolution.

My workaround for now is: Start the nuc without the monitor, wait, switch on the Monitor and login.

Maybe I miss some settings in my nuc config or at the monitor.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,989
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello ReHabMan

many thanks for your guide, which helps me to change my nuc5 from Linux to work perfect with 10.14.1.
Great work.

I have one little open point with my new 4k monitor LG 27UK850-W. This Monitor works perfect when I use the following connection:

(nuc)miniHDMI ------- HDMI(LG) Resolution 3840x2160 / 30 Hz
I can see the complete boot process from BIOS, Clover, OS-boot, Login Screen, and working OS

(nuc)miniDP ---------- DP(LG) Resolution 3840x2160 / 60 Hz
I can see the BIOS, Clover, OS-Boot, after the switch to the Login Screen the Monitor gets dark
Switching the Monitor off / on the Login Screen is visible and I can continue to Login with this resolution.

My workaround for now is: Start the nuc without the monitor, wait, switch on the Monitor and login.

Maybe I miss some settings in my nuc config or at the monitor.
Your config.plist is not up-to-date with respect to current github content.
 
Top