Contribute
Register

[Guide] Intel Broadwell NUC5 using Clover UEFI (NUC5i5MHYE, NUC5i3MYHE, etc)

Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
It’s anyone tested BCM943602BAED DW1830 can work or not?
I have, it works but only WiFi, have been trying to play with different Kexts and USB port confirmations but it won’t work. It shows up as active but is not able to see or connect to other devices. You’ll need to buy a M.2 adapter so you won’t be able to use it for a NVME drive.

I have NUC5i7RYH
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
@bassel.gustav Did you also try to upgrade to Catalina with this EFI?
My NUC5i7RYH works perfectly in Catalina and clover.

I have not had any issues updating Clover either, just make sure to use a USB and load EFI from there to test.

Been trying to play around with Open Core but have not been able to get to work properly.
 
Joined
Jan 20, 2019
Messages
4
Motherboard
Asus
CPU
Intel
Graphics
Amd
My NUC5i7RYH works perfectly in Catalina and clover.

I have not had any issues updating Clover either, just make sure to use a USB and load EFI from there to test.

Been trying to play around with Open Core but have not been able to get to work properly.
Hi mitoda,

would you mind to upload your EFI folder? I have catalina running for days on my i5iryk but it has problems to recognize the iGPU as an hd 6000 (it shows an 5500 with 2gb of ram which should be hd6000 on the i5250u) and the grafik looks like unsharp in some cases as if it is not rendered correcly, espacily the fonts and logos. I think it would realy help me to compare it with your settings and files.

Thank you in advance

Regards
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Hi mitoda,

would you mind to upload your EFI folder? I have catalina running for days on my i5iryk but it has problems to recognize the iGPU as an hd 6000 (it shows an 5500 with 2gb of ram which should be hd6000 on the i5250u) and the grafik looks like unsharp in some cases as if it is not rendered correcly, espacily the fonts and logos. I think it would realy help me to compare it with your settings and files.

Thank you in advance

Regards
Here you go, mind you, this works for NUC5i7RYH. Audio actually works as well (headphone and through HDMI)
Serial and SmUUID have been erased, you can fill them up with yours if you want imessage working.

Make sure you clear NVRAM as well. usually F11 on Clover menu on start up, but I think Open Core is more reliable to clear NVRAM, you can download the EFI folder here https://github.com/acidanthera/OpenCorePkg/releases/ put in a USB and just use it to clear NVRAM.

I have been working on using Open Core instead of Clover on the Nuc5, have made it to start properly, but the video is not properly configured when using 2 displays. If I get it to work, i'll post here.

let me know how it goes.
 

Attachments

Last edited:
Joined
Jan 20, 2019
Messages
4
Motherboard
Asus
CPU
Intel
Graphics
Amd

Here you go, mind you, this works for NUC5i7RYH. Audio actually works as well (headphone and through HDMI)
Serial and SmUUID have been erased, you can fill them up with yours if you want imessage working.

Make sure you clear NVRAM as well. usually F11 on Clover menu on start up, but I think Open Core is more reliable to clear NVRAM, you can download the EFI folder here https://github.com/acidanthera/OpenCorePkg/releases/ put in a USB and just use it to clear NVRAM.

I have been working on using Open Core instead of Clover on the Nuc5, have made it to start properly, but the video is not properly configured when using 2 displays. If I get it to work, i'll post here.

let me know how it goes.
Thanks a lot for your EFI. System now recognizes my hd6000 and the vram correctly. I set the ig platform id to 0x16260004 which seems to run better (but could be my eyes are beeing tired now working for hours on the hack :)).
In cinebench I get normal score for the processor, so I think it accelerates correctly, but still the grafik is not in the full resolution. Espacialy where the picture is high contrasted you see artefacts and the picture isn`t realy sharp. I would discribe it as "granular". But it says, that the picture is in full resolution on my tv (1920x1080). But it looks more like 720p or something like that. I'm going to buy a display port to hdmi cable tomorrow, maybe the mini hdmi port is the problem. Very frustrating, because all-in-all the system runs good.
 
Joined
Jan 20, 2019
Messages
4
Motherboard
Asus
CPU
Intel
Graphics
Amd

Thanks a lot for your EFI. System now recognizes my hd6000 and the vram correctly. I set the ig platform id to 0x16260004 which seems to run better (but could be my eyes are beeing tired now working for hours on the hack :)).
In cinebench I get normal score for the processor, so I think it accelerates correctly, but still the grafik is not in the full resolution. Espacialy where the picture is high contrasted you see artefacts and the picture isn`t realy sharp. I would discribe it as "granular". But it says, that the picture is in full resolution on my tv (1920x1080). But it looks more like 720p or something like that. I'm going to buy a display port to hdmi cable tomorrow, maybe the mini hdmi port is the problem. Very frustrating, because all-in-all the system runs good.
Maybe the antialiasing is not functioning propably with the iGPU, but I dont't know how to fix that in any way. Font smoothing didn't fix the problem. Something is not rendering correctly. When I slide through the dock icons I see pixels at every rounded icon when they are zoomed in. Is there any setting that activates a rendering in the iGPU?
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Maybe the antialiasing is not functioning propably with the iGPU, but I dont't know how to fix that in any way. Font smoothing didn't fix the problem. Something is not rendering correctly. When I slide through the dock icons I see pixels at every rounded icon when they are zoomed in. Is there any setting that activates a rendering in the iGPU?
Sorry, no idea. what is interesting about this EFI, I see no Ig platform id whatsoever! I'm surpirsed it even works, thats the strange part. I just carried it over from a very old tonymac thread https://www.tonymacx86.com/threads/guide-el-capitan-on-the-intel-broadwell-nuc.171942/ and kept updating clover, messing up with some kexts here and there.

I'm glad you identified the ig platform, have been searching for this a long time. I need it as I am trying the NUC5 on Open Core, haven't seen anyone posting on this. I'll report back.
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Maybe the antialiasing is not functioning propably with the iGPU, but I dont't know how to fix that in any way. Font smoothing didn't fix the problem. Something is not rendering correctly. When I slide through the dock icons I see pixels at every rounded icon when they are zoomed in. Is there any setting that activates a rendering in the iGPU?
my res does get to 4k on youtube, but it does get interrupted constantly, you may wanna check that. it's not my internet speed as I get 500 mbps on my google fiber provider. My NUC8 has no problem with 4k.
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Maybe the antialiasing is not functioning propably with the iGPU, but I dont't know how to fix that in any way. Font smoothing didn't fix the problem. Something is not rendering correctly. When I slide through the dock icons I see pixels at every rounded icon when they are zoomed in. Is there any setting that activates a rendering in the iGPU?
Hey would you share your config.plist? I'd like to try your ig-platform configuration

thanks
 
Joined
Oct 19, 2013
Messages
81
Motherboard
Intel NUC8i7BEH NUC8i5BEH NUC5i7RYH
CPU
i7-8559U i5-8259 i7-5557
Graphics
Intel® Iris® Plus Graphics 655
Success! I built an Open Core based EFI for my NUC5i7RYH. for more info, google open core hackintosh, very detailed guide.

Audio + sleep works (at least in Catalina, but not on Mojave, for an unclear reason)

Config.plist is missing MLB, ROM, Serial, SmUUID you have to use propertree to edit it, DO NOT USE CLOVER CONFIGURATOR, the file is different from Clover.
 

Attachments

Top