Contribute
Register

[Guide] Installing macOS Mojave (10.14.2) on Intel NUCi5BEH using Clover UEFI

Joined
Jan 27, 2019
Messages
11
Motherboard
NUC8i7BEH
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
I had the same issue with my 1Gbit ethernet connection. The ping would start out ok, then after a while I would get packet loss and a high ping. One workaround was to force the connection to 100Mbit.

To get a stable 1Gbit connection, I had to disable the PCIe ASPM Support setting in the BIOS. You can find the setting under Power->Secondary Power Settings.

Hope this helps.
OMG. it helps. !!! Saved my life :D
 
Joined
Jan 16, 2019
Messages
5
Motherboard
NUC7i5BNK
CPU
I5-7260U
Graphics
Iris Plus 640
Mac
iMac, MacBook
Mobile Phone
iOS
Hi, i... Not tested BT, WIFI, i am still wating to Macbook Air card + adaptet to SATA port.
.
There is a possibility to have this inside of the NUC? With the SATA Port and an Adapter?
 
Joined
Jan 27, 2019
Messages
11
Motherboard
NUC8i7BEH
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
Or i will buy wifi and BT USB dongles compatible with MacOS
 
Joined
Jan 16, 2019
Messages
5
Motherboard
NUC7i5BNK
CPU
I5-7260U
Graphics
Iris Plus 640
Mac
iMac, MacBook
Mobile Phone
iOS
in This moment im using a dongle.

Would the MacBook WiFi Card support Airdrop and so on? Also Hands-on doesn't work for me and unlocking with my Apple Watch.
 
Joined
Dec 4, 2018
Messages
5
Motherboard
NUC8i5BEH
Hello, thanks so much for the awesome guide, worked perfectly for me but I'm running into issues now that I've added 8 more gigs of ram.

I've got the nuc8i5BEK and started with 8 gigs when I installed, things were going smoothly once I got my audio working with voodoo.

I decided now that it appeared I had a stable system I would add 8 more GBs. Since I've done that I can't go more than 5-10 minutes without the whole machine crashing. Would this have anything to with adding more RAM? I'm new to Hackintosh and this is the only thing I've changed since the crashes started happening so I figured it was the cause of my issues. Any ideas?

Thanks

Edited to add bootlog, not sure if that'll help.

Edit 2: Took the new RAM out and booted with the original 8, still experiencing crashes after 5-10 minutes that don't seem to be associated with any actions (I can leave it running without touching anything, still crashes) anyone else running into this?
I have exactly the same problem. Only I started right away with 16GB and it was like that from the beginning. Since I have to work with the computer too, I have again installed Windows 10 and it is all stable. So it should not be on the hardware.
 
Joined
Jan 31, 2019
Messages
2
Motherboard
NUC8i5
CPU
i5
Graphics
Iris Plus 655
I have exactly the same problem. Only I started right away with 16GB and it was like that from the beginning. Since I have to work with the computer too, I have again installed Windows 10 and it is all stable. So it should not be on the hardware.
That's really weird... I actually just finished reinstalling and so far no crashes. I tried every fix I could find online and had no luck. I'm going to document every change I make and program I install from here to try to find the cause.
 
Joined
Feb 4, 2019
Messages
3
Motherboard
NUC8i5BEH1 (NUC8i5BEK)
CPU
Intel Core i5-8259U
Graphics
Intel Iris Plus Graphics 655
Hi.

I did this installation (and I'm willing to do it again), but I got as far is getting into the Mac OS, but when i open Safari, I get weird Display issues for example, in Safari, tabs have black in it, the mouse drags, and when Mac Icons bounce

I installed Mojave (fresh off App Store) to the install_osx.

I tried rebooting/etc. on two different displays and I get the same behavior.

I'm connected via HDMI to a 1440x900 LG Monitor. Tried a second monitor, same behavior.

Here is all hardware I'm using:
NUC8i5BEH1
G.SKILL Ripjaws Series 16GB (2 x 8G) 260-Pin DDR4 SO-DIMM DDR4 2400
WD Blue 3D NAND 500GB PC SSD


After this (see attached Safari screenshots), during boot I set the fakeID of the GPU to:
0x3EA58086

Now I'm get a bit of idle flicker but not the black issue or mouse drag issue.

Any thoughts would help :)


 

Attachments

Last edited:
Joined
Aug 1, 2011
Messages
28
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
MacBook Air
Now I'm get a bit of idle flicker but not the black issue or mouse drag issue.

Any thoughts would help :)
Looks like you have not copied across the post install config.plist (config_nuc8_bc.plist). See final step of the guide in post #1.
 
Joined
Feb 4, 2019
Messages
3
Motherboard
NUC8i5BEH1 (NUC8i5BEK)
CPU
Intel Core i5-8259U
Graphics
Intel Iris Plus Graphics 655
Looks like you have not copied across the post install config.plist (config_nuc8_bc.plist). See final step of the guide in post #1.

Mispelled the command. I did config.xml instead of plist. Mac is performing well now. good call!

Does power/restart/sleep work well for you? It seem to shut down the OS but the Nuc is still running.
 
Last edited:
Top