Contribute
Register

[Guide] Installing macOS Mojave (10.14.2) on Intel NUCi5BEH using Clover UEFI

Joined
Mar 9, 2018
Messages
13
Motherboard
GA Z170X-Gaming-7
CPU
i7-6700 3.4 GHz
Graphics
Sapphire Pulse Radeon RX 580
Finally I found out, that the NUC8i5BEH2 is to be reseted by removing the jumpers from the 3 Pins completely. I restored BIOS v.56 with that. After that you put the jumper either to pins 1 + 2 for „normal boot“ or to 2 + 3 for „lockdown“. Neither of those allowed me to access the BIOS. I even changed keyboards in case the „F2“-key is broken. No success...
With no Jumpers I would be able to erase the Trusted Hardware data. Do you think, this helps?
 
Joined
Jan 19, 2019
Messages
9
Motherboard
NUCi5BeK
CPU
i5
Thank you @Cric and @RehabMan for these incredible tutorials! For a newbie, these were easy to follow! I successfully installed Mojave onto my SSD. Post installation using terminal went fine until I tried to compile the patched files using the make command.

Here is the output I got:
Chriss-iMac:nuc.git cmac$ ./install_downloads.shmake


-bash: ./install_downloads.shmake: No such file or directory


Chriss-iMac:nuc.git cmac$ make install_nuc8bcmake


make: *** No rule to make target `install_nuc8bcmake'. Stop.


Chriss-iMac:nuc.git cmac$ make install_nuc8bc



Any help appreciated!
 
Joined
Jan 19, 2019
Messages
9
Motherboard
NUCi5BeK
CPU
i5
One other issue--has anyone had issues with chrome? It is currently unusable. I have disabled hardware acceleration but does not help.
 
Joined
Jan 27, 2019
Messages
6
Motherboard
NUC8i7BEH1 BIOS 0056
CPU
i7-8559U
Graphics
Iris 655
Mac
MacBook Pro
I believed that happened to me when I didn't copy the config file correctly. Did you download the config_install_nuc8_bc.plist file correctly? I just ended up downloading the entire rehabman repo as a zip.

"Note: Clover cannot read HTML (config.plist is a plist/xml), so make sure to download from the "Raw" link: hit the « Raw » link + « File->Save as » and save config_install_nuc8_bc.plist on your Drive. "
Hello chuckw / Cric

I have the same issue. I have downloaded the whole Rehabman NUC zip and extracted the file. I still have the corrupted graphics (in verbose mode) and system freeze. I am using the config_install_nuc8_bc.plist file and I am renaming it to config.plist It is an XML file on my drive and not HTML.

I have downloaded the OS from the apple store.

I have followed Cric's guide three times from the start and used all of his files that were attached to post #1. I have assumed it was a config.plist file issue, but I really don't know at this point. I have reset my BIOS to default three times and made the appropriate changes. I upgraded the BIOS to 0056. I am not sure what else to check at this point other than a setting in the BIOS.

Any suggestions as to what simple thing I may be missing? Did you do something different than the guide for the Nuc8i7BEH?

Edit. I found my problem after rebooting F to the N times. One time the graphics were clear enough to see "waiting for storage" or something similar. I turned off the SATA port in the BIOS and it made it through boot up on the USB drive.
 
Last edited:
Joined
Jan 27, 2019
Messages
11
Motherboard
NUC8i7BEH
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
Hi, i followed the guide, excelent job. Everything work, also TB3 with audio, 4k@60hz on HDMI with sound. Siri, iMessage, Time Machine, etc.
Not tested BT, WIFI, i am still wating to Macbook Air card + adaptet to SATA port.

I used:
Samsung Evo 970 1TB, 32GB DDR4 2400 HyperX Kingston.

BUT:
1] after adding the "Sinetek-rtsx.kext" for Card reader, the video output stated flashing by blackscreen, to i remove it and disable in BIOS, maybe this file is not needed. I really dont use microSD card reader.

2] After install, i encrypted my SSD, but after reboot i cant see it in Clover Boot Master, so i decrypted the disk by Disk Utility and Terminal, and everything works again .. is there any chance to make FileVault works in Mojave 10.14.3 ?

3] I have one issue, with the network speed. Some times is very slow, and ping is too much high. I found that is could be broken by SMB (samba) connection to the NAS, i dont know. ... Does anybody has the same issue ? or i need to wait for updated driver ? https://bitbucket.org/RehabMan/os-x-intel-network/downloads/

Thanks for help.
 

Attachments

Joined
Jan 19, 2019
Messages
9
Motherboard
NUCi5BeK
CPU
i5
Hi all, So I am getting black screen and system freezes. Things will be stable until I download an app and install it. anyway, I am still not able to use the make command to compile patched files. apparently, I need to move aisl into user/bin or /tools, but cannot find any file.

any help appreciated.
 
Joined
Jan 16, 2019
Messages
5
https://github.com/chris1111/VoodooHDA-2.9.0-Clover-V12

Also, not to be rude or anything, and I'm also a noob hackintosher, but 100% working guides are rare and a little Googling/reading documentation is required from time to time. And if the documentation is Greek to you, then you might rethink this route.
NUC8 uses ALC235 instead ALC233. Layout-ID 28 works nice, but audio level is little bit low. DisplayPork audio is enabled by different kext.
 

Attachments

Joined
Jan 19, 2019
Messages
9
Motherboard
NUCi5BeK
CPU
i5
I still can't figure out a way to get the make command to work. How can I find the IASL directory?

current terminal output

Last login: Thu Jan 31 06:19:32 on ttys000


Chriss-iMac:~ cmac$ cd ~/Projects/nuc.git


Chriss-iMac:nuc.git cmac$ make


iasl -vw 2095 -vw 2008 -p build/SSDT-NUC5.aml SSDT-NUC5.dsl


make: iasl: No such file or directory


make: *** [build/SSDT-NUC5.aml] Error 1


Chriss-iMac:nuc.git cmac$ make install_nuc8bc


Thanks--I've been scouring the site, but this is my first build so not too sharp!

Chris
 
Joined
Jan 31, 2019
Messages
2
Motherboard
NUC8i5
CPU
i5
Graphics
Iris Plus 655
Hello, thanks so much for the awesome guide, worked perfectly for me but I'm running into issues now that I've added 8 more gigs of ram.

I've got the nuc8i5BEK and started with 8 gigs when I installed, things were going smoothly once I got my audio working with voodoo.

I decided now that it appeared I had a stable system I would add 8 more GBs. Since I've done that I can't go more than 5-10 minutes without the whole machine crashing. Would this have anything to with adding more RAM? I'm new to Hackintosh and this is the only thing I've changed since the crashes started happening so I figured it was the cause of my issues. Any ideas?

Thanks

Edited to add bootlog, not sure if that'll help.

Edit 2: Took the new RAM out and booted with the original 8, still experiencing crashes after 5-10 minutes that don't seem to be associated with any actions (I can leave it running without touching anything, still crashes) anyone else running into this?
 

Attachments

Last edited:
Joined
Jan 31, 2019
Messages
3
Motherboard
Intel NUC8i5BEH-0056
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
iMac, MacBook Air, MacBook Pro
Hi, i followed the guide, excelent job. Everything work, also TB3 with audio, 4k@60hz on HDMI with sound. Siri, iMessage, Time Machine, etc.
Not tested BT, WIFI, i am still wating to Macbook Air card + adaptet to SATA port.

I used:
Samsung Evo 970 1TB, 32GB DDR4 2400 HyperX Kingston.

BUT:

3] I have one issue, with the network speed. Some times is very slow, and ping is too much high. I found that is could be broken by SMB (samba) connection to the NAS, i dont know. ... Does anybody has the same issue ? or i need to wait for updated driver ? https://bitbucket.org/RehabMan/os-x-intel-network/downloads/

Thanks for help.
I had the same issue with my 1Gbit ethernet connection. The ping would start out ok, then after a while I would get packet loss and a high ping. One workaround was to force the connection to 100Mbit.

To get a stable 1Gbit connection, I had to disable the PCIe ASPM Support setting in the BIOS. You can find the setting under Power->Secondary Power Settings.

Hope this helps.
 
Top