Contribute
Register

[Guide] Installing macOS Mojave (10.14.2) on Intel NUCi5BEH using Clover UEFI

Joined
Feb 7, 2019
Messages
4
Motherboard
NUC8BEB
CPU
i7-8559U
Graphics
iris 655
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Did anyone ever get Thunderbolt to work on the NUC8I7BEH ? I know about hot plugins not working but I can<t get any thunder bot devices to work on mine.
 
Joined
Feb 21, 2010
Messages
49
Motherboard
Asus Zenbook UX410UA
CPU
i7-8550U
Graphics
UHD 620
Mac
iMac, MacBook, MacBook Air
Mobile Phone
Android
Did anyone ever get Thunderbolt to work on the NUC8I7BEH ? I know about hot plugins not working but I can<t get any thunder bot devices to work on mine.
Sure...try the Thunderbolt "Legacy" setting in the bios. Quite a few folks are using it.
 
Joined
Nov 17, 2014
Messages
5
Motherboard
ASUS P8H77-I
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
Android
So I'm up running now, although I haven't used the EFI file that Leesureone kindly supplied (will do so in near future) and mostly everything is good. One thing though that is nagging me is in the toolbar at the top with the time & Finder there is an icon that say something like unknown card and gives me the option to Power Down. Anyone any idea what this is?
 
Joined
Jan 10, 2011
Messages
5
Motherboard
Lion
CPU
i7 2.9ghz
Graphics
nVidia 9500gt
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Mobile Phone
iOS
Hey guys. Just got my NUC8i5 and thought I had everything good but it seems I am stuck really early on in the boot. The boot stops at
Code:
Start ReadKernelCache
I might just be missing something easy. Any thoughts?
 

Attachments

Joined
Feb 7, 2019
Messages
4
Motherboard
NUC8BEB
CPU
i7-8559U
Graphics
iris 655
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Sure...try the Thunderbolt "Legacy" setting in the bios. Quite a few folks are using it.

I tried this but still no Thunderbolt. I'm using a Cable Matters TB3 to TB2 adapter to connect an audio interface.
 
Joined
Dec 16, 2012
Messages
29
Motherboard
GA-Z270X-UD5
CPU
i7-7700K
Mac
iMac, MacBook Air, MacBook Pro
Classic Mac
128K, 512K, Classic, Color Classic, eMac, iMac, LC, Performa, Plus, Power Mac, PowerBook, Quadra, SE
Mobile Phone
Android, iOS
So I'm up running now, although I haven't used the EFI file that Leesureone kindly supplied (will do so in near future) and mostly everything is good. One thing though that is nagging me is in the toolbar at the top with the time & Finder there is an icon that say something like unknown card and gives me the option to Power Down. Anyone any idea what this is?
That's for the unsupported, SD Card reader. I spoke about that on Rehabman's thread :) You can dissable it in the BIOS and it will dissapear. There's another icon up there though that I can't seem to make go away (not near the NUC at the moment to see which one it is though).
 
Joined
Feb 21, 2010
Messages
49
Motherboard
Asus Zenbook UX410UA
CPU
i7-8550U
Graphics
UHD 620
Mac
iMac, MacBook, MacBook Air
Mobile Phone
Android
I tried this but still no Thunderbolt. I'm using a Cable Matters TB3 to TB2 adapter to connect an audio interface.
I use a similar apple adapter that was one of a kind when I first got it for a couple of external hard drives, no issues. There are no specific drivers to load or kexts you need I am aware of, I think everything is is native to OSX as far as Thunderbolt goes . Does your setup work on windows?
 
Joined
Feb 21, 2010
Messages
49
Motherboard
Asus Zenbook UX410UA
CPU
i7-8550U
Graphics
UHD 620
Mac
iMac, MacBook, MacBook Air
Mobile Phone
Android
Hey guys. Just got my NUC8i5 and thought I had everything good but it seems I am stuck really early on in the boot. The boot stops at
Code:
Start ReadKernelCache
I might just be missing something easy. Any thoughts?
Hard to know exactly without more info. It could be as simple as having secure boot in the bios turned on or possibly another one of the needed settings might have been overlooked. It could also be you are missing a crucial kext or your config.plist isn’t right. If you post your EFI folder I’ll look at it for you....up to you.
 
Last edited:
Joined
Nov 17, 2014
Messages
5
Motherboard
ASUS P8H77-I
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
Android
That's for the unsupported, SD Card reader. I spoke about that on Rehabman's thread :) You can dissable it in the BIOS and it will dissapear. There's another icon up there though that I can't seem to make go away (not near the NUC at the moment to see which one it is though).
Thanks, that's good to know. I'll turn it off in the bios then.

Got to say really liking this NUC Hackintosh the more I use it. It's much quieter than the NUC6i7KYK Skull Canyon I was using previously although that one was easier to get up & running out of the box . Probably because the hackintosh support is a bit more mature I guess.

Just as matter of interest what keyboards and mice are folks using if wireless/bluetooth? ATM Im using a Logitech K810 & Xiaomi Mi bluetooth mouse, which most of the time connect & work great. However it's still a pain when rebooting as neither work before getting to the login screen. Would be nice to have support at the Clover screen rather than having to plug in a wired keyboard.
 
Last edited:
Top