Contribute
Register

[Guide] Installing macOS Mojave (10.14.2) on Intel NUCi5BEH using Clover UEFI

Joined
Mar 2, 2019
Messages
3
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
Iris Plus 655
Mac
MacBook Pro
Did anyone using an Intel NUC8i7BEH have problems with screen flashing ?
If I leave fakeid in Clover -> Graphics Injector to the value that's in there (0x00000000) I get a flickering display (almost as if the buffer doesn't get cleared and reverts to a previous state every few seconds). If I change it to 0x19160000, my display works correctly, but I can't change to its native resolution (which is 4k). Do any of you have an idea as to the value I should enter ? I also tried 0x3EA58086 without any success.
 
Joined
Jan 23, 2019
Messages
19
Motherboard
Asus UX331UA
CPU
i5-8250U
Graphics
UHD 620
Mac
MacBook
Has anyone had an issue where Safari/Chrome have audio issues from the headphone jack? The audio from iTunes and other macOS apps is fine. I could use Voodoo like mentioned in the thread, but I thought I wouldn't have to.
 
Joined
Dec 16, 2012
Messages
29
Motherboard
GA-Z270X-UD5
CPU
i7-7700K
Mac
iMac, MacBook Air, MacBook Pro
Classic Mac
128K, 512K, Classic, Color Classic, eMac, iMac, LC, Performa, Plus, Power Mac, PowerBook, Quadra, SE
Mobile Phone
Android, iOS
Has anyone had an issue where Safari/Chrome have audio issues from the headphone jack? The audio from iTunes and other macOS apps is fine. I could use Voodoo like mentioned in the thread, but I thought I wouldn't have to.
Yes, I've experienced what you're experiencing. I installed Voodoo, followed the admin guide for the crackling audio some people experience (NUCs), and now the audio is perfect. I'd highly recommend installing Voodoo.
 
Joined
Feb 16, 2019
Messages
5
Motherboard
nuc
CPU
8109u
Graphics
655
I've still been unable to make the system see any input or output devices on my NUC8i3 system. I was hoping to have sound out via HDMI to the monitor. Can anyone point me in the right direction?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've still been unable to make the system see any input or output devices on my NUC8i3 system. I was hoping to have sound out via HDMI to the monitor. Can anyone point me in the right direction?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Also, please fix your profile as requested in the guide/FAQ.
 
Joined
Feb 1, 2018
Messages
1
Motherboard
Nuc8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Dear both, thanks for your awesome work.

My nuc8i5 (fresh install 30min ago, trying to get it run with Mojave 14.3 since 3 weeks now) has 2x8 GB Corsair (Intel verified) RAM, a 500GB NVME WD (black) and crashes with Youtube, Radio-Streams and such (after 3-7 minutes).
I would like to mention that (on a separate Crucial mSata) Win10 also crashes with Youtube and such, but this can be avoided by setting the energy prefs in Win to max (not sure what that's called in English, sorry). Still I would like to run Mojave on it. Bios is version 56, settings as in first post by Cric.

I attach the debug docs and I'm appreciating you have a look and looking forward to your feedback. Thank you very much.
 

Attachments

Joined
Dec 31, 2018
Messages
13
Motherboard
Intel NUC8I5BEH
Hello.. i ran into a problem. So i was using my dell 4K monitor through usb c to display port and everything worked fine for weeks.. i went on vacation for a week and after i came back my display won’t work through usb c anymore. Tried multiple cables and even tried usbc to mini display port with no luck.. what could it be any ideas ?? It works through hdmi but everything it goes to sleep it doesn’t turn back on but worked perfect with usbc to DisplayPort till now.. Please help with advice
 
Joined
Sep 4, 2012
Messages
19
Motherboard
Intel NUC8i5BEH2
CPU
i5-8259U
Graphics
Iris Pro 655
Mac
iMac
Hello.. i ran into a problem. So i was using my dell 4K monitor through usb c to display port and everything worked fine for weeks.. i went on vacation for a week and after i came back my display won’t work through usb c anymore. Tried multiple cables and even tried usbc to mini display port with no luck.. what could it be any ideas ?? It works through hdmi but everything it goes to sleep it doesn’t turn back on but worked perfect with usbc to DisplayPort till now.. Please help with advice
I noticed when i boot, my DP acts strange. I have to unplug the cable, boot with HDMI only, and when i'm on the desktop i can plug it back in (hotswap). Maybe something isn't quite right with dp port. Can't help you with that.

btw, i'm running 10.14.3 for a couple of weeks now on 8I5BEH, runs super stable..no issues!
 
Joined
Dec 31, 2018
Messages
13
Motherboard
Intel NUC8I5BEH
I noticed when i boot, my DP acts strange. I have to unplug the cable, boot with HDMI only, and when i'm on the desktop i can plug it back in (hotswap). Maybe something isn't quite right with dp port. Can't help you with that.

btw, i'm running 10.14.3 for a couple of weeks now on 8I5BEH, runs super stable..no issues!
Everything worked without hotswap. It wont work at all now. I don't understand why tho
 
Top