Contribute
Register

[Guide] Installing macOS Mojave (10.14.2) on Intel NUCi5BEH using Clover UEFI + updating to Mojave (10.14.6) on post#2

Status
Not open for further replies.

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,258
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
HI!!!
thank to you all (expecialy @Leesureone ) now everything is almost perfect.
I HAVE ONLY ONE LAST LITTLE PROBLEM:
My mac is connected USB to my stereo.
The mac recognize the audio source bue disable MAC volume control so if I want to increase the output volume i have to use the volume dial i the stereo.
Is there any possibility to control the volume through the mac ?
thank you!!!!
Not if you are using HDMI for sound output, same on a real mac
 
Joined
May 1, 2020
Messages
6
Motherboard
Intel NUC7I5DNK2E
CPU
i5-7300U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
What I see is you are trying to load the IntelMausiEthernet.kext twice, once in Clover/Kexts/Other and also in L\E. Later versions of Catalina will not load nonApple kexts form L\E so delete that, it will ask for a password, then rebuild the kextcache in terminal with this command:

sudo kextcache -i /

Then reboot and cross your fingers...that should be it

Unfortunalty it did not work..!

But the console gave me some interesting output:
Code:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7f8317f17e80 [0x7fff8a1b48e0]> { URL = "file:///Library/Extensions/FakePCIID.kext/", ID = "org.rehabman.driver.FakePCIID" }
Kext with invalid signatured (-67050) allowed: <OSKext 0x7f83178a3bf0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Invalid signature -67050 for kext <OSKext 0x7f83178a3bf0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
kxld[com.insanelymac.IntelMausiEthernet]: The super class vtable 'vtable for IOEthernetController' for vtable 'vtable for IntelMausi' is out of date. Make sure your kext has been built against the correct headers.
Link failed (error code 5).
Prelink failed for com.insanelymac.IntelMausiEthernet; omitting from prelinked kernel.
KernelCache ID: 403750512387BCADAF9FC1520F2C0F27
Kext with invalid signatured (-67050) allowed: <OSKext 0x7ff063dc7fa0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Kext with invalid signatured (-67062) allowed: <OSKext 0x7ff065f55a90 [0x7fff8a1b48e0]> { URL = "file:///Library/Extensions/FakePCIID.kext/", ID = "org.rehabman.driver.FakePCIID" }

So I deleted both IntelMausiEthernet.kext and FakePCIID.kext in BOTH directory L/E and S/L/E
The cache rebuild is now giving some way better output (only the KernelCacheID)

Tried to reboot again, and...
But still not woking...
In Hackintools, the "Extensions" panel is still not showing IntelMausiEthernet in the installed extensions, is that normal for that kext?

(The Ethernet works well on my other laptop BTW)

UPDATE:
I finally managed to make it work: I replaced the last version of IntelMausiEthernet.kext by the old version by RehabMan. Rebooting makes my ethernet port appears.

Thank you so much for your help & time @Leesureone
 
Last edited:

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,258
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Unfortunalty it did not work..!

But the console gave me some interesting output:
Code:
Kext with invalid signatured (-67062) allowed: <OSKext 0x7f8317f17e80 [0x7fff8a1b48e0]> { URL = "file:///Library/Extensions/FakePCIID.kext/", ID = "org.rehabman.driver.FakePCIID" }
Kext with invalid signatured (-67050) allowed: <OSKext 0x7f83178a3bf0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Invalid signature -67050 for kext <OSKext 0x7f83178a3bf0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
kxld[com.insanelymac.IntelMausiEthernet]: The super class vtable 'vtable for IOEthernetController' for vtable 'vtable for IntelMausi' is out of date. Make sure your kext has been built against the correct headers.
Link failed (error code 5).
Prelink failed for com.insanelymac.IntelMausiEthernet; omitting from prelinked kernel.
KernelCache ID: 403750512387BCADAF9FC1520F2C0F27
Kext with invalid signatured (-67050) allowed: <OSKext 0x7ff063dc7fa0 [0x7fff8a1b48e0]> { URL = "file:///System/Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Kext with invalid signatured (-67062) allowed: <OSKext 0x7ff065f55a90 [0x7fff8a1b48e0]> { URL = "file:///Library/Extensions/FakePCIID.kext/", ID = "org.rehabman.driver.FakePCIID" }

So I deleted both IntelMausiEthernet.kext and FakePCIID.kext in BOTH directory L/E and S/L/E
The cache rebuild is now giving some way better output (only the KernelCacheID)

Tried to reboot again, and...
But still not woking...
In Hackintools, the "Extensions" panel is still not showing IntelMausiEthernet in the installed extensions, is that normal for that kext?

(The Ethernet works well on my other laptop BTW)

UPDATE:
I finally managed to make it work: I replaced the last version of IntelMausiEthernet.kext by the old version by RehabMan. Rebooting makes my ethernet port appears.

Thank you so much for your help & time @Leesureone
Glad you figured that out, bet its just older generation ethernet.
 
Joined
Oct 16, 2016
Messages
270
Motherboard
Dell 7560
CPU
i7 7500u
Graphics
HD 620 & 940MX (1920x1080)
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
HI!!!
thank to you all (expecialy @Leesureone ) now everything is almost perfect.
I HAVE ONLY ONE LAST LITTLE PROBLEM:
My mac is connected USB to my stereo.
The mac recognize the audio source bue disable MAC volume control so if I want to increase the output volume i have to use the volume dial i the stereo.
Is there any possibility to control the volume through the mac ?
thank you!!!!
I don´t think so. OS X will not allow volume control unless you use P2 output. The same behavior you will find on HDMI or Bluetooth connect devices.

Edit: Maybe SoundFlower can help you with the volume control over USB.
 
Last edited:
Joined
Oct 21, 2019
Messages
19
Motherboard
ASUS PRIME A320M-K
CPU
Intel Core i3-9100F
Graphics
MSI Radeon RX 580
Thank you so much!
I find an app called soundsource plus bettertouchtool and I almost resolve!
But now i have another problem
My nuc is in hdmi2 on my tv and it's set like this:
no screensaver and this energy saver option.
If I use hdmi all day and then I switch to hdmi 2 sometime the tv can't fine the nuc, a TV static noise screen appears ans i have to reboot the nuc to resolve.
Can someone help me?
 

Attachments

  • Schermata 2020-05-09 alle 14.48.48.png
    Schermata 2020-05-09 alle 14.48.48.png
    66.1 KB · Views: 56
Joined
May 28, 2018
Messages
48
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Until now I have never had any luck getting the SD card reader to work..but this week I added the newest version of the Sinetek-rtsx kext to my folder and once I rebooted it worked perfectly! wanted to share in case any one else still had this problem
 
Last edited:
Joined
Jan 28, 2020
Messages
18
Motherboard
NUC NUC8I5BEK
CPU
Intel i5
Graphics
Intel Iris Plus 655
Mac
  1. Mac mini
Mobile Phone
  1. Android
Has anyone lost audio on Windows after Hackintosh the machine even though Windows is on another SSD?
 
Joined
Oct 21, 2019
Messages
19
Motherboard
ASUS PRIME A320M-K
CPU
Intel Core i3-9100F
Graphics
MSI Radeon RX 580
Hello everybody.
Yesterday I tried to install another os in my nuc (it's called roon rock)
Now I'd like to reinstall mojave but i can't..
I have made an usb with unibeast, i have set bios but the system doesn't boot
this are the screen picture
 

Attachments

  • IMG_20200523_110033.jpg
    IMG_20200523_110033.jpg
    216.7 KB · Views: 29
  • IMG_20200523_110037.jpg
    IMG_20200523_110037.jpg
    248.4 KB · Views: 35
  • IMG_20200523_110052.jpg
    IMG_20200523_110052.jpg
    220.3 KB · Views: 29
  • IMG_20200523_110104.jpg
    IMG_20200523_110104.jpg
    224.2 KB · Views: 30
  • IMG_20200523_110130.jpg
    IMG_20200523_110130.jpg
    561 KB · Views: 28
  • IMG_20200523_110147.jpg
    IMG_20200523_110147.jpg
    161.4 KB · Views: 30
  • IMG_20200523_110158.jpg
    IMG_20200523_110158.jpg
    181.7 KB · Views: 30

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,258
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello everybody.
Yesterday I tried to install another os in my nuc (it's called roon rock)
Now I'd like to reinstall mojave but i can't..
I have made an usb with unibeast, i have set bios but the system doesn't boot
this are the screen picture
A couple of things, Unibeast will never get you going with this device as is. There are patches needed in the config.plist it won't cover. You also seem to be trying to boot in legacy mode which is correct, it requires UEFI booting. You should update your signature so we know what Molde NUC you are working on. Then see page 90 of this other thread for my post here: #894
 
Joined
Oct 21, 2019
Messages
19
Motherboard
ASUS PRIME A320M-K
CPU
Intel Core i3-9100F
Graphics
MSI Radeon RX 580
Hi,
so in the lst hours i erase the ssd in the nuc ( NUC8i3BEK )so I have nothing on it.
I have bought a new Usb, disk utility erase it, open unibeast 9.3 (for mojave) select UEFI boot mode, nothing in graphic configuration.
Unibeast finish, replace EFI folder with the one you post at page 90.
update BIOS and Change the setting on my nuc as said in the first page of this topic.

I attach the bios screen
save the bios, restart the pc, press F10 and this is what i have
All the options bring me to nothing

ps. This is the link to the os i have installe yesterday on the nuc:
 

Attachments

  • Screenshot 2020-05-23 at 14.43.42.png
    Screenshot 2020-05-23 at 14.43.42.png
    349.9 KB · Views: 40
  • 3fff8252-cb85-483b-a636-c3e140949193.jpg
    3fff8252-cb85-483b-a636-c3e140949193.jpg
    102.5 KB · Views: 32
  • 40e7486a-8807-45a2-bba5-fa0b8948962c.jpg
    40e7486a-8807-45a2-bba5-fa0b8948962c.jpg
    94.2 KB · Views: 32
  • 422f0572-25f0-409e-bf7c-2895d72b713f.jpg
    422f0572-25f0-409e-bf7c-2895d72b713f.jpg
    81.9 KB · Views: 36
  • 619515ed-9563-415e-b68b-c20363fad2b4.jpg
    619515ed-9563-415e-b68b-c20363fad2b4.jpg
    109.4 KB · Views: 33
  • ba7238fa-f0ae-4589-9798-20f5cd91cc6f.jpg
    ba7238fa-f0ae-4589-9798-20f5cd91cc6f.jpg
    126.9 KB · Views: 32
  • cebb1cf2-5126-4bc0-b196-f91eed6731b1.jpg
    cebb1cf2-5126-4bc0-b196-f91eed6731b1.jpg
    119.1 KB · Views: 33
  • f3d49459-ee43-4b4f-aa0e-d18b8f1eb56b.jpg
    f3d49459-ee43-4b4f-aa0e-d18b8f1eb56b.jpg
    109.3 KB · Views: 33
  • f0425d59-7ff6-4702-bb68-150b0090ff0e.jpg
    f0425d59-7ff6-4702-bb68-150b0090ff0e.jpg
    196.4 KB · Views: 30
  • 257fefc1-53f0-424b-a037-1541c4bfba7e.jpg
    257fefc1-53f0-424b-a037-1541c4bfba7e.jpg
    232.3 KB · Views: 29
Status
Not open for further replies.
Top