Contribute
Register

[Guide] Install macOS Sierra on Alienware Alpha (Drivers, Messages, FaceTime ...)

Joined
Aug 9, 2010
Messages
11
Mac
Classic Mac
Mobile Phone
I can't get this to work in 10.12.2.

Graphics driver isn't compatible. I have tried a newer one from Nvidia but it keeps reverting back to the OS X default driver.

2nd issue is no HDMI sound. I have installed Soundflower but HDMI audio isn't listed as an option.

Not sure what to try next. Everything else seems to be working except for the known issue with WiFi.
Hope you have solved already.
1) for the graphic card, Check config.plist - System Parameters - NvidiaWeb.
2) hdmi audio requires a hdmi kext
 
Joined
Jan 25, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
I didn't patch the kernel, you may try the clover plist file I uploaded.
I got most of the things to work in my alienware alpha, only thing missing is bluetooth.
It is detected and works but i am unable to pair my apple wireless keyboard and trackpad.

It detects both of them but doesn't pair.

any solution ?
 
Joined
Jul 11, 2016
Messages
1
Classic Mac
eMac, iBook, iMac
Mobile Phone
iOS
Stuck at apple logo. Progress bar hangs when its almost done. Anyone else having this issue?

EDIT: The FakeCPUID was the issue. Set it to the haswell code and it successfully boots onto the installer.
 
Last edited:
Joined
Mar 3, 2019
Messages
3
Motherboard
Alienware Alpha R1
CPU
i3
Graphics
GeForce 860m
Mobile Phone
Android
Ty this got my alpha r1 i3 going , I had to do it a little different. I have to get the new multi and uni beast. The one provided some of there files have expired. After I created the thumb drive I took your plist and put it in clover in the efi on thumb drive. I put on haswell in clover and gave it a haswell fakespuid. Made sure to save that configuration. After installing OS X I booted in with thumb drive. Used the new multibeast. Then I copied the thumb drives whole efi mount and pasted over the one on the internal hd.

I had to download the latest Nvidia web drivers. I have every thing working great. I have been playing diablo 3 and Minecraft full setting in D3 at 768 resolution. getting 90fps and in a window mode I got 132 fps.

Minecraft I have going with shaders and its going smooth and looks nice. I will be testing with metro last light. The performance is so fast. I am really thinking of getting the i7 upgrade for my alpha.

BTW my first hackingtosh.
 
Top