Contribute
Register

[Guide] Install High Sierra or Mojave on the Dell Optiplex 7010 / 9010 Desktop PC - Revision II

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I use the last Clover v2.4k r4895
Why not use the recommended RM version of Clover as per the guide ?
What is it exactly that is not working correctly ?
 
Joined
Mar 21, 2019
Messages
1
Motherboard
Intel
CPU
i5-3470
Graphics
HD4000
Noob Alert :) I have only recently bought a MacBook Pro(2015) after being a Windows user for 20 years. My first excursion into Mac world. It has Mojave on it and I just love how easy it is. I therefore wanted to give Hackintosh a go and I bought a 9010 - i5 3470, 16Gb RAM, BIOS A30. I have installed a blank 256Gb SSD. I have followed this guide to the letter, but on booting my Dell, I get to a Clover boot manager screen and don't know what to do next. I'd love some help please. At the bottom right of this screen it says 4862
394837
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Noob Alert :) I have only recently bought a MacBook Pro(2015) after being a Windows user for 20 years. My first excursion into Mac world. It has Mojave on it and I just love how easy it is. I therefore wanted to give Hackintosh a go and I bought a 9010 - i5 3470, 16Gb RAM, BIOS A30. I have installed a blank 256Gb SSD. I have followed this guide to the letter, but on booting my Dell, I get to a Clover boot manager screen and don't know what to do next. I'd love some help please. At the bottom right of this screen it says 4862
Sterling, you'll need to read the guide again and follow the directions to have success. Here's a paragraph from graphics:
Apple has dropped all support for analog VGA connections. They also dropped support for HD2500 about five years ago. Most 7010/9010s shipped with the i5-3470 or the i7-3770. The 3470 has only the unsupported HD2500 graphics.
At the bottom right of this screen it says 4862
The guide also does not use that version of Clover, use the one by RehabMan, linked from the guide.

If you want help you need to follow the directions. If you don't want to do that then post in Mojave desktop support. Thanks.
 
Last edited:
Joined
Aug 31, 2014
Messages
45
Motherboard
Gigabyte Z97X UD3H
CPU
i7 4790K
Graphics
GeForce GTX 760 2GB 256-Bit
Mac
iMac, Mac Pro
Classic Mac
Mobile Phone
Why not use the recommended RM version of Clover as per the guide ?
What is it exactly that is not working correctly ?
I see that all work correctly
I put 2 differents config.plist, one with the EFI folder, I want to know which one is the best
The 2 works fine but maybe one of then is best and other have bad configurations
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
This is the best to use. It enables onboard audio when AppleALC and Lilu are installed as per the guide.
It's also the only one that works with the SSDTs correctly. Not sure why you don't just follow the guide
exactly as it's written. Doing otherwise will cause problems.
 

Attachments

Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
A reminder for those just starting out with this guide

1. Read the guide carefully, don’t skip anything.
2. Apply each step in the order presented.
3. Use only the config.plist, kexts and SSDTs from this guide.
4. Enjoy your fully functional Dell CustoMac Mini !

I've recently gotten requests for help that don't really need to be posted at all. When using the kexts, SSDTS and version of Clover r4701.RM in the guide, everything works. There is no need to be on the latest, greatest version of Clover. It's not similar to security updates where you always want the latest version.

In summary:

1. The SSDTs and Clover Config.plist attached to the end of post #1 are designed to work together. If you use just one or the other individually it will create problems and you won't have a fully functional and stable system. Follow this guide exactly as presented here for the best results. Don't mix in other kexts or make modifications to the config.plist that are not needed.

2. Do not update Clover to a newer version. We are using the newest RehabMan version. If and when he updates Clover get that from his bitbucket.org repository. https://bitbucket.org/RehabMan/clover/downloads/
The official Clover versions that are newer will not work in the same manner without changing many of the drivers.
 
Joined
Dec 20, 2018
Messages
1
Motherboard
Dell Optiplex 7010 SFF
CPU
i5-3475S
Graphics
HD4000
Great guide. My Mojave install works well except... I'm unable to consistently have graphics acceleration (glitchy time line in garageBand, Hackintool shows QE/CI: No, Metal: No). I've tried multiple configs and sometimes I have full acceleration then after reboot GA is gone.
Hardware testing show no errors. I've attach the debug folder. Any help would be greatly appreciated
 

Attachments

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Great guide. My Mojave install works well except... I'm unable to consistently have graphics acceleration (glitchy time line in garageBand, Hackintool shows QE/CI: No, Metal: No). I've tried multiple configs and sometimes I have full acceleration then after reboot GA is gone.
Hardware testing show no errors. I've attach the debug folder. Any help would be greatly appreciated
You've got a few unneeded kexts installed that aren't part of this guide. Go back and determine what those are and then remove them. Reboot and see if it improves the graphics problem.

From post #936 above:
3. Use only the config.plist, kexts and SSDTs from this guide.
 
Joined
Mar 11, 2019
Messages
20
Motherboard
Dell Optiplex 7010 Desktop
CPU
i3
Graphics
NVS 510
Mac
MacBook Pro, Mac Pro
Has anyone tried updating to 10.14.4 yet? As an update: I grabbed a different 7010 and used the NVS 510 @trs96 posted a few pages ago instead of onboard video and I'm fully in business now.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,106
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Has anyone tried updating to 10.14.4 yet? As an update: I grabbed a different 7010 and used the NVS 510 @trs96 posted a few pages ago instead of onboard video and I'm fully in business now.
I don't have the free time till later this evening to try 10.14.4. What problems occured when using HD4000 ?

If anyone does have problems you could try putting the latest Lilu kext and Whatevergreen into Clover/kexts/other folder before the update. Also update Lilu and Whatever green in /L/E as well if you do this. The latest versions are attached to post #1 at the end. Always have matching versions of any kexts that are in both /L/E on your system drive and Clover/kexts/other on your EFI partition. Report back how it goes for you.
 
Last edited:
Top