Contribute
Register

[Guide] Install High Sierra or Mojave on the Dell Optiplex 7010 / 9010 Desktop PC - Revision II

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,839
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
When looking at the USB Header on the PCI card, it only has 8 total pins (but one is missing). Also the BLANK pin area on the board does not align to the cable. Also the little TRIANGLE (Index pin) does not align on the board to the one on the cable.
I wouldn't be too confident that will work even with the right cable. Can you still return that card and get one of these:
 
Last edited:
Joined
Jun 20, 2015
Messages
17
Motherboard
Dell Optiplex 7020
CPU
i5-4670
Graphics
HD 4600
Hi trs96 I just wanted to thank you for your excellent build and instructions! I have a few comments and maybe a couple of questions. Firstly, I also have an HP 8300 and have tried both your build (H-Sierra) and Sniki's build (Mojave) and both worked too and now that I have done both the Dell 7010 and the HP 8300 (Mojave) I have tried configuring on the HP 8300 and putting the drive into the Dell 7010 and it seems to work (limited testing) and also once configured on one, putting the EFI from the other on it and putting it into the other and that works too, which is great. So in coming to a question, what are the main differences between the 2 machines in terms of what they need to set up as a 'tosh. Secondly, I have played with both the NV710 and the iHD4000 (from a core-i3 3445) and the NV710 seems to load so much faster (on both Dell 7010 and HP 8300) and I am wondering why that is and if others have noted this too or whether its just me and I need to look deeper? Many thanks!
 
Joined
Jun 20, 2015
Messages
17
Motherboard
Dell Optiplex 7020
CPU
i5-4670
Graphics
HD 4600
Also, I have noticed that getting through the BIOS boot up on the 7010 is faster the earlier the BIOS. Its much quicker around version A17 and starts to slow right down around A20 and is still slow or slower at A29. It seems to work fine on this build on A20 and am tempted to go lower to get faster boot speeds unless there is a pressing reason why I shouldn't? Unlike the HP 8300 (which boots through the BIOS much faster), I haven't found a "Quickboot" setting, unless I'm missing something obvious? Thanks.
 
Joined
May 9, 2010
Messages
164
Motherboard
DELL Optiplex 7010
CPU
i5-3475S/Q77
Graphics
HD 4000
Mobile Phone
Android
I wouldn't be too confident that will work even with the right cable. Can you still return that card and get one of these:
I will see if I can return the card and the adapter.

Does this one appear to be the same one?? The listing you gave ships from China.


Grizz
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,839
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Does this one appear to be the same one?? The listing you gave ships from China.
Looks right except they don't show a low profile bracket which you'll need to have. Ask the seller if they include that. I don't like the statement "new other" in their listing. The seller I've listed has an excellent Ebay selller rating and ships anywhere in the world so it works better for our worldwide audience, viewers of this thread.

The seller I've linked to states they use ePacket mailing so delivery time shouldn't be excessively long.
i.e. the "slow boat from China" shipping service.
 
Last edited:
Joined
Mar 11, 2019
Messages
19
Motherboard
Dell Optiplex 7010 Desktop
CPU
i3
Graphics
NVS 510
Mac
MacBook Pro, Mac Pro
So, I started up my 7010 Mini-Tower this morning and graphics acceleration was disabled again. It seems like it's working every fourth or fifth reboot. Additionally, I'm having a problem where watching videos in the News app causes the system to freeze.

I have verified all my Kexts and configurations match the guide.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,839
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
So, I started up my 7010 Mini-Tower this morning and graphics acceleration was disabled again. It seems like it's working every fourth or fifth reboot. Additionally, I'm having a problem where watching videos in the News app causes the system to freeze.

I have verified all my Kexts and configurations match the guide.
Need to fill out your profile with CPU, graphics and "D.O. 7010 MT" where it asks for you motherboard. https://www.tonymacx86.com/account/account-details

Also you could upload your PR files. https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/
 
Joined
Mar 11, 2019
Messages
19
Motherboard
Dell Optiplex 7010 Desktop
CPU
i3
Graphics
NVS 510
Mac
MacBook Pro, Mac Pro

Attachments

trs96

Moderator
Joined
Jul 31, 2012
Messages
13,839
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Here's my PR files.
Try removing the Intel Graphics Fixup kext from /L/E you don't need it. Also remove all the FakeSMC Sensor kexts you have in /L/E and in kexts/other. Also remove the extra WhateverGreen kext.

393030


Those can be problematic. Reboot and test graphics.
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,595
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
@smashabback as @trs96 said those kexts are not efficient and may cause issues.
The second problem is:
Code:
Kext with invalid signatured (-67030) allowed: <OSKext 0x7ffd38499230 [0x7fff9f9728f0]> { URL = "AppleIntelHD4000Graphics.kext/ -- file:///System/Library/Extensions/", ID = "com.apple.driver.AppleIntelHD4000Graphics" }
Remove that kext

Third problem: no IMEI loaded, missing SSDT-IMEI or Intel Management Engine is disabled on BIOS.
Without IMEI you won't have QE/CI.
 
Last edited:
Top