Contribute
Register

[Guide] Install High Sierra or Mojave on the Dell Optiplex 7010 / 9010 Desktop PC - Revision II

Joined
May 9, 2010
Messages
156
Motherboard
DELL Optiplex 7010
CPU
i5-3475S/Q77
Graphics
HD 4000
Mobile Phone
  1. Android
Maxing it out to run VMs in Windows ? Good thing you got the DT and not a SFF version Dell. Can't use these in the SFF unless you completely remove the HDD tray in front.

trs96,

Actually the new OP7010 will replace my old Windows 10 workstation that I use for my personal stuff. Looking forward to the RAM arriving 19-Apr. The i7-3770 arrived yesterday, and I have the SilverStone M.2 card and Samsung 970 EVO Plus already. Gonna use the Broadcom WiFi Adapter I got for the MAC (which did not work)...the one made by DELL for the Optiplex (seen below) - as it works great in Windows. I have a USB BlueTooth 4.0 adapter in my existing deskptop - which I will just move.

400261


Not looking forward to re-installing all the softwares. :(

Grizz
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,704
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Samsung 970 EVO Plus already.
Do these work well in Windows ? No one seems to have success in Mojave as the firmware has major macOS problems.
 
Joined
May 9, 2010
Messages
156
Motherboard
DELL Optiplex 7010
CPU
i5-3475S/Q77
Graphics
HD 4000
Mobile Phone
  1. Android
Do these work well in Windows ? No one seems to have success in Mojave as the firmware has major macOS problems.

I will find out. I read several review of them (Huge Fan of SAMSUNG - just about all the electronics and SSDs and Monitors, TVs, etc in my home are SAMSUNG).

Their Customer service can be a little crappy at times (read from a script and all - but, who's isn't?), but they stand behind their products. I had a 27" monitor which died 4 months out of warranty - when they saw all my registered items, they sent me a replacement (of a newer model).

I will let you know how I fare.

Grizz
 
Joined
Jul 19, 2016
Messages
194
Motherboard
Asus X79 Deluxe
CPU
E5-1680 V2
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Do these work well in Windows ? No one seems to have success in Mojave as the firmware has major macOS problems.
Really now? i am expecting my Silverstone M.2 and a Samsung 970 evo plus the next days.... :banghead:
...I will let you know how I fare.
...
please do.
 
Joined
May 9, 2010
Messages
156
Motherboard
DELL Optiplex 7010
CPU
i5-3475S/Q77
Graphics
HD 4000
Mobile Phone
  1. Android
Really now? i am expecting my Silverstone M.2 and a Samsung 970 evo plus the next days.... :banghead:

please do.

caniggia,

Please be aware - my SilverStone and Samsung Evo are not going to be in a Hackintosh. It will be a Windows 10 PC.

I am happy with my current OP7010 Mojave machine with the 8GB RAM and Kingston SSD. I did add a BluRay player to that one - and it does play movies. Also has the Broadcom WiFi/BT recommended by trs96, and everything works.

Grizz
 
Joined
Jul 19, 2016
Messages
194
Motherboard
Asus X79 Deluxe
CPU
E5-1680 V2
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Please be aware - my SilverStone and Samsung Evo are not going to be in a Hackintosh. It will be a Windows 10 PC.
I am happy....
... i am not... :p
Well it is dirty job but someone has to do it.. i will report back with results. Hopefully succesfull ones.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,704
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
am expecting my Silverstone M.2 and a Samsung 970 evo plus the next days
I've not seen anyone get the Evo Plus to work with macOS. Exchange it for a standard 970 evo and it will work. So many people buy these for higher read speeds but they never get them to work. It will take a fix from Samsung for these to work. That hasn't happened yet.

nessung5 said:
same problem here Sierra 10.13.4 with my old Evo 970 is solid no problems , bought a Evo 970 plus 1 tb 2 days a go and can't get it to stable , it is recognised and loads to desktop but within a few minutes system shuts down :( , fresh install would fail , but I did manage to clone to it and boot off it but would fail again after a few minutes , do we know why they don't work is it a hardware limitation or driver support ?

Here's what we should put where everyone will see it.
400274
 
Last edited:
Joined
Feb 2, 2019
Messages
4
Motherboard
Dell 9010
CPU
i7-3770/Q77
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Alright here are the results with only NVMe in the PCIe x4 wired slot. The performance is better than having both NVMe and SATA together in the adapter but lower than PCIe x16 slot.
View attachment 398370
First of all, thanks to @trs96 for a great guide and @randompurplehippo for the NVME information!

Wanted to come to you all with a disk speed issue I'm having.

A little background: Running a clean install of Mojave 10.14.4 on an Optiplex 9010 MT i7 3770 (trs96 guide) and installed the SilverStone Dual M2 to PCI-E X4 and SATA 6G Adapter Card per RPH's post. The adapter is installed in the PCIe x4 wired slot. I opted for the 512gb version of the Sabrent Nvme PCIe M.2 2280 SSD. Everything installed great-EFI is installed on SSD drive to boot Nvme

My issue is, compared to randompurplehippo's speed test, my drive is not performing well. The read speeds are fine, but when I run the Blackmagic test, my write speed starts out at ~1200 and settles in the upper 500s/low 600s.

Drive is installed correctly and I've tested with Trim enabled as well as disabled. Running out of ideas and was hoping someone (smarter than me) could help. Thanks!!!

, Screen Shot 2019-04-18 at 1.25.45 PM.pngScreen Shot 2019-04-18 at 1.19.01 PM.png
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,704
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
My issue is, compared to randompurplehippo's speed test, my drive is not performing well. The read speeds are fine, but when I run the Blackmagic test, my write speed starts out at ~1200 and settles in the upper 500s/low 600s.
RPH may not have tested with Blackmagic DST as you did. The longer you run the test in that the slower the write speeds will be as the cache gets filled up. Also sequential writes are not the whole picture. That just indicates how fast it is copying a file. Instead of looking at the numbers, what is your direct experience of using macOS with it like ? You are still getting much better performance than any Sata based SSD. Also, is your other SSD attached to the same adapter ?
 
Joined
Feb 2, 2019
Messages
4
Motherboard
Dell 9010
CPU
i7-3770/Q77
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thanks, @trs96! You're probably right in that I'm getting sidetracked by benchmarks/tests. (Guess it was more of a curiosity)

To that point, while RPH, may not have used the BM test as I did, I also tested in AmorphousDiskMark (after a reboot). As you can see, my write speeds are significantly different.

My other SSD is actually connected to a port on the MB and not the adapter with the goal being maximum performance from the Nvme.

Overall experience with the machine has been really good. Beats my 2012 Mac Mini hands down. On the Hack, I'm running 24gb of ram, installed a MSI RX 580 8gb (single fan) gpu and the new drive. Final Cut Pro and Davinci Resolve 15/16 both work well.

Thanks for the input!!

Screen Shot 2019-04-18 at 2.35.26 PM.png
Screen Shot 2019-04-18 at 2.37.03 PM.png
 
Last edited:
Top