Contribute
Register

[Guide] Install 10.11 on HP EliteBook/ProBook/others with Clover UEFI

Status
Not open for further replies.
Joined
Dec 2, 2011
Messages
8
Motherboard
Mac
CPU
Intel Core 2 Duo
Graphics
Nvidia 8400M GS
Mac
Classic Mac
Mobile Phone
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Hello. I have HP ProBook 4540s 15'' i5, Graphic card Intel HD 4000 with AMD.

Install El Capitan -- OK
First Boot -- OK
HP ProBook Installer -- OK
Restart -- OK
Repair permissions, restart -- sound OK and Blackscreen
Boot from USB -- OK
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

when i check my system..i cant find 1 port available ..1 pic from IOReg and 1 pic from AppleUSBXHCIPCI
Now, what should i do ? i should rename port in AppleUSBXHCIPCI like IOReg ? :beachball:
View attachment 153428View attachment 153427

Create a port injector appropriate for your hardware. Refer to the u430 example.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Hello. I have HP ProBook 4540s 15'' i5, Graphic card Intel HD 4000 with AMD.

Install El Capitan -- OK
First Boot -- OK
HP ProBook Installer -- OK
Restart -- OK
Repair permissions, restart -- sound OK and Blackscreen
Boot from USB -- OK

Press your brightness up key.
 
Joined
Oct 3, 2013
Messages
167
Motherboard
HP Probook 4340s
CPU
Interl i5 Ivy Bridge
Graphics
Intel hd4000
Mac
Classic Mac
Mobile Phone
  1. Android
Joined
Oct 28, 2012
Messages
18
Motherboard
HP EliteBook 840G1
CPU
I5-4300U
Graphics
Intel HD4400
Mac
Classic Mac
Mobile Phone
  1. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Create a port injector appropriate for your hardware. Refer to the u430 example.
<key>HS01</key>
<dict>
<key>UsbConnector</key>
<integer>255</integer>
<key>port</key>
<data>AQAAAA==</data>
</dict>
sorry but field <data> is endcode Base64 from locationId or Port get from IOReg ?
 
Joined
Nov 10, 2011
Messages
1,341
Motherboard
GA-H77N-WIFI F4
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. Android
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Hm, I don't get it. Installed El Capitan in another partition today. Everything works fine. Everything except the audio. I have installed the AppleHDAIDT.kext in /S/L/E (the one for ID 76D9), I have added the kext patch AppleHDA 8419D411 -> D9761D11 and the HDMI audio patch AppleIntelFramebufferCapri 040600000004000081000000 -> 040600000008000006000000. Clover injects ID 12 (just in case, the DSDT has already that ID too) and still have nothing. According to Kext Wizard, the right AppleHDA (version 999.69c1) has been loaded. The HDMI audio works like it should, but the speakers are dead. What have I missed?
 
Joined
Jan 24, 2012
Messages
23
Motherboard
Gigabyte Z97
CPU
Intel Core i7 4790
Graphics
NVidia GTX770
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Hm, I don't get it. Installed El Capitan in another partition today. Everything works fine. Everything except the audio. I have installed the AppleHDAIDT.kext in /S/L/E (the one for ID 76D9), I have added the kext patch AppleHDA 8419D411 -> D9761D11 and the HDMI audio patch AppleIntelFramebufferCapri 040600000004000081000000 -> 040600000008000006000000. Clover injects ID 12 (just in case, the DSDT has already that ID too) and still have nothing. According to Kext Wizard, the right AppleHDA (version 999.69c1) has been loaded. The HDMI audio works like it should, but the speakers are dead. What have I missed?

Same problem here
 
Joined
Sep 25, 2012
Messages
528
Motherboard
Asus ROG STRIX Z390-F
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Try PBI CE 6.4.4 Beta. If it does not work, send me /var/log/install.log again.

Worked for me on my 4340s, works like a dream now :thumbup:
 
Joined
Sep 15, 2012
Messages
40
Motherboard
HP Probook 4530s A7K05UT
CPU
Intel i7-2720QM
Graphics
Intel HD3000
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

You have to wait for some hours after new installation to make OS X settle down.
The Spotlight indexer is probably quite active, especially if you have a lot of files.

Ah ok, that makes sense. I upgraded to an i7 from the original i3 a while back, so it can get pretty toasty when it's running full blast. Awesome in the winter though lol. Thanks!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Install 10.11 beta on HP EliteBook/ProBook/others with Clover UEFI

Can you be more specific?

Post #1 has recommendations for WiFi/BT hardware.
 
Status
Not open for further replies.
Top