Contribute
Register

[Guide] Install 10.11 on HP EliteBook/ProBook/others with Clover UEFI

Joined
Jul 24, 2015
Messages
127
Motherboard
Gigabyte Z270N-WIFI
CPU
Intel Core i7-7700K
Graphics
AMD Radeon RX 560, Dell U3417W (3440x1440)
RehabMan, do I still need HPFanReset.efi and ACPIPoller.kext if I patch my DSDT with PBI "reading only"?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
RehabMan, do I still need HPFanReset.efi and ACPIPoller.kext if I patch my DSDT with PBI "reading only"?
Doesn't hurt to keep both, but strictly speaking, you don't need either with that patch.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
So does that mean that both options are possible?
Post #1977 says to use the Clover installer. Clover Configurator is not the Clover installer. It is completely unrelated to Clover. I don't use Clover Configurator for anything directly involving my EFI partition.
 
Joined
Jan 27, 2013
Messages
204
Motherboard
HP Elitebook 8570w/Clover
CPU
Intel Core i7-3630QM/QM77
Graphics
Nvidia K1000M 1920x1080
Mac
Classic Mac
Mobile Phone
I see a DSDT.aml and several SSDT.aml files in the origin folder under ACPI.

In the patched folder I only see DSDT.aml and SSDT-1.aml. Are only these 2 loaded during boot?
 
Joined
Jul 24, 2015
Messages
127
Motherboard
Gigabyte Z270N-WIFI
CPU
Intel Core i7-7700K
Graphics
AMD Radeon RX 560, Dell U3417W (3440x1440)
Doesn't hurt to keep both, but strictly speaking, you don't need either with that patch.
Ok, but with quiet patch both are needed? Also if I patch my DSDT with latest PBI-CE, can I use new versions of HPFanReset and ACPIPoller from Bitbucket?

Why I asked was that I don't really know what happened yesterday. I have two usb sticks, Mavericks and El Capitan. Both are made by following PBI-CE instructions and files and nothing in the config.plist hasn't been edited "8570p with AMD".

Yesterday I had El Capitan installed, I don't remember if I used quiet patch or readings only and dunno if HPFanReset and ACPIPoller was installed. Anyway I plugged in the El Capitan USB and started to reinstall it. I left it there and and when I came back the installer was stuck with 1 second left. I noticed that the fan was off and laptop bottom was burning hot. I rebooted and got warning that laptop is halted because temperatures are too high. I let it cool down, rebooted and started the installer again. I noticed the fan didn't spin at all during the install and was again too hot, i mean i couldn't keep my hand longer than couple of seconds on the bottom near the cpu area.

I then removed battery and checked BIOS settings but all seemed to be ok there. I then tried Mavericks USB but it had the same problem. Then I wen't to BIOS and selected "fan always on when on AC", so I was able to install Mavericks. After the install I deselected fan setting in BIOS and booted to Mavericks with the USB. Then did everything as usual, I installed Clover 3333 into SSD following your guide, then patched DSDT with PBI-CE "readings only patch", installed FakeSMC, VoodooPS2 and AppleHDA into SSD. Then moved my config.plist into EFI and rebooted but fan was still off and after awhile laptop started to be really hot again.

I then thought there is something wrong with the plist and replaced EFI/clover folder with a backup I made from my last working Mavericks install "readings only patch". Then rebooted and fan was still off. Then I moved HPFanReset.efi into clover and rebooted and fan started to work again. Then I removed HPFanReset.efi, rebooted and fan was still working normally.

Do you have any idea why this happened? With 8570p+AMD -xcpm and dropoem "true" is needed. PBI-CE usb plist files had proper settings missing so that the fan and processor didn't work correctly on install, but how can this get stuck like this, even after install with working plist (-xcpm) and dsdt/ssdt i needed to add hpfanreset.efi briefly to get fan and processor steps working again.
 
Joined
Jan 29, 2013
Messages
715
Motherboard
HP Elitebook 8470p
CPU
Intel Core i5-3360m
Graphics
Intel HD4000, 1366x768
Mac
iMac
Classic Mac
Mobile Phone
iOS
It is supported but not getting updates. Obviously there are several problems including the fact it doesn't have the latest Clover, nor the latest kexts.

So with this in mind, if I wanted to upgrade, or create a new install usb would you suggest simply replacing the older kexts in EFI with the latest (extracted from the install.pp), keeping my config, DSDT, SSDT, and running the latest clover? or are there kexts in SLE that will also need replacing like ACPIbacklight for example, or can I re use the old ones?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
So with this in mind, if I wanted to upgrade, or create a new install usb would you suggest simply replacing the older kexts in EFI with the latest (extracted from the install.pp), keeping my config, DSDT, SSDT, and running the latest clover?
No idea what "install.pp" is.

Latest Clover is available on sourceforce.

And all kexts (even ACPI patches) used by PBI are available at my github.
 
Joined
Jan 29, 2013
Messages
715
Motherboard
HP Elitebook 8470p
CPU
Intel Core i5-3360m
Graphics
Intel HD4000, 1366x768
Mac
iMac
Classic Mac
Mobile Phone
iOS
No idea what "install.pp" is.

Latest Clover is available on sourceforce.

And all kexts (even ACPI patches) used by PBI are available at my github.

Im referring to any install app of OS X downloaded from app store.

If any kexts required are located on your github, hopefully I can work things out to not do too much destruction lol
 
Top