Contribute
Register

[Guide] Install 10.11 on HP EliteBook/ProBook/others with Clover UEFI

Joined
Jan 27, 2013
Messages
204
Motherboard
HP Elitebook 8570w/Clover
CPU
Intel Core i7-3630QM/QM77
Graphics
Nvidia K1000M 1920x1080
Mac
Classic Mac
Mobile Phone
I have my 10.11 installation now up to a level that it is good for daily use. Some features like screen brightness control are not working yet. I like to make a easily restorable or bootable backup of this configuration. Can you guys tell me how to do that and what tools to use. It would be nice to copy my config to my second hard disk and be able to boot from that when I want to experiment without risking my current config.
 
Joined
Jul 24, 2015
Messages
127
Motherboard
Gigabyte Z270N-WIFI
CPU
Intel Core i7-7700K
Graphics
AMD Radeon RX 560, Dell U3417W (3440x1440)
Try making sure firmware is loaded for your device when booting OS X...

Two ways:
- restart into OS X from Windows (eg. don't cold boot, but rather warm boot from Windows)
- use BrcmPatchRAM2.kext + BrcmFirmwareData.kext (EFI/Clover/kexts)
I added BrcmPatchRAM2.kext + BrcmFirmwareData.kext in EFI/Clover/kexts on USB, but still getting the same error. Any idea what could be the problem?

Edit:
I removed Bluetooth module from the laptop, but still the same kp.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I still need to get used to the UEFI "thing". And what consequences it has when moving from Legacy to UEFI. At the moment I have 10.11 on the first disk and Win 10 on the second disk in the upgrade bay. When I booted the laptop yesterday it showed the clover screen with mac os and windows 10 symbol. After choosing Windows 10 it booted. But now on reboot it boots Win 10 by default And not to clover anymore.

Has someone got a tip to avoid this?
It is covered in post #1 here, and in post #2 in my Clover guide...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have my 10.11 installation now up to a level that it is good for daily use. Some features like screen brightness control are not working yet. I like to make a easily restorable or bootable backup of this configuration. Can you guys tell me how to do that and what tools to use. It would be nice to copy my config to my second hard disk and be able to boot from that when I want to experiment without risking my current config.
You can create a backup with TimeMachine or even Disk Utility (a disk image).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I added BrcmPatchRAM2.kext + BrcmFirmwareData.kext in EFI/Clover/kexts on USB, but still getting the same error. Any idea what could be the problem?

Edit:
I removed Bluetooth module from the laptop, but still the same kp.
Please provide complete details in your profile/signature
(Profile/Settings link in upper right corner of this site)

Mobo: manufacturer/model + bootloader(Clover/Chameleon/Chimera)
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
Mobo: HP ProBook 4540s (Clover)
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx), and graphics capabilities. For a laptop, these details are important and affect critical installation procedures.

Note: When specifying your bootloader, if using Clover legacy, please be sure to specify "Clover legacy"). Specifying "Clover" will be assumed as "Clover UEFI"
 
Joined
Feb 14, 2014
Messages
95
Motherboard
HP ProBook 4540s (Clover)
CPU
i5-3320m/HM76 (Ivy Bridge)
Graphics
HD4000, 1366x768
Mobile Phone
Android, iOS
After an ordinary restart my screen turns off during the boot. I tried to boot in safe mode and recovery too but the same. I have no bootable usb how can i fix it without it? https://goo.gl/photos/Fy4QumWR4xEFd6Cg7
 
Joined
Jan 27, 2013
Messages
204
Motherboard
HP Elitebook 8570w/Clover
CPU
Intel Core i7-3630QM/QM77
Graphics
Nvidia K1000M 1920x1080
Mac
Classic Mac
Mobile Phone
You can create a backup with TimeMachine or even Disk Utility (a disk image).
Where does Disk Utility in 10.11 give me that option?
 
Joined
Jul 24, 2015
Messages
127
Motherboard
Gigabyte Z270N-WIFI
CPU
Intel Core i7-7700K
Graphics
AMD Radeon RX 560, Dell U3417W (3440x1440)
Please provide complete details in your profile/signature
(Profile/Settings link in upper right corner of this site)

Mobo: manufacturer/model + bootloader(Clover/Chameleon/Chimera)
CPU: detailed CPU model + motherboard chipset
Graphics: all graphics devices + laptop internal screen resolution

For example, typical Ivy laptop:
Mobo: HP ProBook 4540s (Clover)
CPU: i5-3320m/HM76
Graphics: HD4000, 1366x768

Use CPU-Z on Windows to find CPU (Core iX-xxx) and motherboard chipset (HMxx), and graphics capabilities. For a laptop, these details are important and affect critical installation procedures.

Note: When specifying your bootloader, if using Clover legacy, please be sure to specify "Clover legacy"). Specifying "Clover" will be assumed as "Clover UEFI"
Updated. Weird, I joined in 2013 when I helped nguyenmac to add AMD GPU support in PBI. Then I was away between 2014-2015 and when I logged in couple of days ago, everything in my profile was empty. My join date has also changed to 2014 and post count was two. There is also several pages missing from PBI Mavericks thread.

Has there been some data loss on the forums while I was away?
 
Top