Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Sep 18, 2012
Messages
860
Motherboard
HP_EliteBook_8x0G1
CPU
i7_4600U
Graphics
HD_4400 1366 x 768
tested new clean install 10.13.6 osx high sierra , clover 4701 rm verion, all worked as per guide
imo HFS+ is much faster than apfs

post install , installed the 2x 2020 security updates
bootup is very slow. verbose said
appleALCU.kext conflict , the way it was integrated as part for lilufriends.kext failed to load

removed appleALCU.kext from /L/E
boot up was no delays , quick

but no bluetooth. the icon has the zig zag through it
how to fix?




update.

maybe solved - post install order.

follow Rehabmans guide


before everything else

prepare customised config.plist , choose smbios for your system, eg MacBookPro11,1

use clover configurator to add in all the details, bios etc

post install,

install clover 4701 rm version to hdd or sdd

optional. add firewall vpn ntfs fuse etc

install silentknight


run silentknight , get smaller updates and install only
safari itunes mrt etc

do not install the big security updates yet

reboot

continue with post install guide
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,974
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
update.

maybe solved - post install order.

follow Rehabmans guide


before everything else

prepare customised config.plist , choose smbios for your system, eg MacBookPro11,1

use clover configurator to add in all the details, bios etc

post install,

install clover 4701 rm version to hdd or sdd

optional. add firewall vpn ntfs fuse etc

install silentknight


run silentknight , get smaller updates and install only
safari itunes mrt etc

do not install the big security updates yet

reboot

continue with post install guide
be careful with clover configurator as that can cause issues in corrupted config.plist's if not done correctly
 
Joined
Sep 18, 2012
Messages
860
Motherboard
HP_EliteBook_8x0G1
CPU
i7_4600U
Graphics
HD_4400 1366 x 768
update.

maybe solved - post install order.

follow Rehabmans guide


before everything else

prepare customised config.plist , choose smbios for your system, eg MacBookPro11,1

use clover configurator to add in all the details, bios etc

post install,

install clover 4701 rm version to hdd or sdd

optional. add firewall vpn ntfs fuse etc

install silentknight


run silentknight , get smaller updates and install only
safari itunes mrt etc

do not install the big security updates yet

reboot

continue with post install guide

update. temp solved audio

change order. install big updates 1st.

installed little snitch , the part where it was "updating boot cache" fixed whatever was causing the applealcu not to load and versbose says probable nnennory leek

tested shutdown startups

100% works 8x0g1 maybe different for other laptop configs, but --> must run rehabmans post install script after each boot up, brings back the audio icon and audio works etc.
else no audio.




possible solution.
make all references to applealc and especially applealcu to start finish before applehda in the boot up
dummies proof how to?

sudo kextstat output
shows
applealc at index 21,
applealcu at index 146

applehdacontroller at index 122






How to use AppleALC​


The only task you need to accomplish if your codec is supported is to load the kernel extension and see if it works. You can use your bootloader for that but remember to load AppleALC earlier than AppleHDA (see sudo kextstat output for more detail).


Note that Lilu must also be present for AppleALC to work.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,974
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
update. temp solved audio

change order. install big updates 1st.

installed little snitch , the part where it was "updating boot cache" fixed whatever was causing the applealcu not to load and versbose says probable nnennory leek

tested shutdown startups

100% works 8x0g1 maybe different for other laptop configs, but --> must run rehabmans post install script after each boot up, brings back the audio icon and audio works etc.
else no audio.

some one know better?
remove AppleALCU.kext it is not required for your hardware
 
Joined
Sep 18, 2012
Messages
860
Motherboard
HP_EliteBook_8x0G1
CPU
i7_4600U
Graphics
HD_4400 1366 x 768
agree forgot to copy paste from dummy config to actual config
be careful with clover configurator as that can cause issues in corrupted config.plist's if not done correctly
 
Joined
Sep 18, 2012
Messages
860
Motherboard
HP_EliteBook_8x0G1
CPU
i7_4600U
Graphics
HD_4400 1366 x 768
update. temp solved audio

change order. install big updates 1st.

installed little snitch , the part where it was "updating boot cache" fixed whatever was causing the applealcu not to load and versbose says probable nnennory leek

tested shutdown startups

100% works 8x0g1 maybe different for other laptop configs, but --> must run rehabmans post install script after each boot up, brings back the audio icon and audio works etc.
else no audio.




possible solution.
make all references to applealc and especially applealcu to start finish before applehda in the boot up
dummies proof how to?

sudo kextstat output
shows
applealc at index 21,
applealcu at index 146

applehdacontroller at index 122






How to use AppleALC​


The only task you need to accomplish if your codec is supported is to load the kernel extension and see if it works. You can use your bootloader for that but remember to load AppleALC earlier than AppleHDA (see sudo kextstat output for more detail).


Note that Lilu must also be present for AppleALC to work.

update - for better audio sound

use the newest current applealc kext.
 
Joined
Sep 18, 2012
Messages
860
Motherboard
HP_EliteBook_8x0G1
CPU
i7_4600U
Graphics
HD_4400 1366 x 768
I used to use little snitch but it can cause some real problems, consider trying Lulu

thanks, looks different. making fw rules isnt dummies proof eg only allow browser to browse on port 443 vs blocking the whole internet.

maybe setup a test mac to install all the other apps to check out the the bells and whistles or silence
 
Joined
Apr 28, 2022
Messages
135
Motherboard
HP 250 G6
CPU
i5-7200U
Graphics
HD620
thanks, looks different. making fw rules isnt dummies proof eg only allow browser to browse on port 443 vs blocking the whole internet.

maybe setup a test mac to install all the other apps to check out the the bells and whistles or silence
again it's open source which I think always deserves are support if possible and it does seem to work well.
Try removing little snitch, i've ended up reinstalling macos because it's screwed up the system.
Anyway hope it's of use to you
 
Top