Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,523
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Did a bios update was unable to boot tried a clean installation still it didn't work
in what way doesn't work? you need to be more specific

or go back to your bios version that did work
 
Joined
Feb 10, 2015
Messages
278
Motherboard
Hp Probook 450G4
CPU
Intel core i7 7500U
Graphics
Intel HD 620 & NVIDIA GeForce 930MX
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
in what way doesn't work? you need to be more specific

or go back to your bios version that did work
Can't even install Mac Os will try a bios downgrade
 
Joined
May 11, 2011
Messages
2,374
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Joined
Feb 10, 2015
Messages
278
Motherboard
Hp Probook 450G4
CPU
Intel core i7 7500U
Graphics
Intel HD 620 & NVIDIA GeForce 930MX
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Joined
Jun 3, 2021
Messages
6
Motherboard
HP ProBook 640 G2 (Clover)
CPU
i5-6300U/Skylake-U
Graphics
HD520, 1920x1080
Mobile Phone
  1. iOS
I have a triple boot setup in my HP ProBook640 G2 (Win10-Catalina-Ubuntu), my lap has an intel AC 7265 WiFi+BT card, I got WiFi working with the method of putting the Airportitlwm.kext inside the plugins of the IO80211Family.kext and putting that in Clover/kexts/Other, but my problem is that the bluetooth doesn't work unless the device i'm pairing is almost touching the laptop and i have no AirDrop, I tried with the IntelBluetoothFirmware.kext and the IntelBluetoothInjector.kext, but it didn't fix my problem.

Does anyone knows a way to get the AirDrop working with my setup?, since it's not an error report i don't know which files to attach to help fix this.
 
Joined
Feb 10, 2015
Messages
278
Motherboard
Hp Probook 450G4
CPU
Intel core i7 7500U
Graphics
Intel HD 620 & NVIDIA GeForce 930MX
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
Thanks let me try this
Did a clean EFI with opencore and everything is now working ,from USB ,HDMI plus audio, Headphones, WiFi.
 
Joined
Jun 5, 2011
Messages
49
Motherboard
ASUS Z490-A
CPU
i9 10900k
Graphics
UHD 630
Mac
  1. MacBook
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi, I would like to upgrade my 840G2 to big sur, how could translate this method to OpenCore? also I was thinking in keep the clover installation upgrading to the last versión, where i confines the appropriate quirks for clover?
 
Joined
Mar 28, 2021
Messages
21
Motherboard
HP Probook 450 G2
CPU
i5-5200U
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
For those having issues with high cpu and power usage, on HP Probook Laptops, 450G series install CPUFriend.kext. It helps in more refining power management. May work for other HP Laptops as well.

Make sure you have Lilu.kext installed as CPUFriend.kext is a lilu.kext plugin.

Hope this works
 
Last edited:
Joined
Mar 28, 2021
Messages
21
Motherboard
HP Probook 450 G2
CPU
i5-5200U
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I'm having issues with CMOS resets when running Big Sur with Opencore.
I tried the DisableRTCchecksum in Quirks, that didn't help. Then I tested with RTCMemoryFixup.kext and the method in boot arguments. That didn't help. I'm wondering what other issues would cause the CMOS reset as the troubleshooting guide at Dortania doesn't seem to point to anything but RTC issues. I do not get Safemode. Just reset notice each time on reboots or startups.
 
Top