Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Apr 2, 2015
Messages
52
Motherboard
HP 9470M
CPU
i7-3687U
Graphics
1600x900, HD 4000
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Read post #1 regarding download.sh and install_downloads.sh.

I didn't check anything else.
Earlier I installed a hackintosh on lenovo 580 and 4540s, I took advantage of the information in the forum and easily installed. The 9470m worked harder than I expected. I copy the final version of the HD efi folder to the usb efi folder. It opens on usb without any errors. But when I want to open it using the -v flag on the computer itself, it gives me errors in the appendix. Atheros, VM and lilu do not give errors when opening via usb.

:(



https://preview.ibb.co/b2N6M9/9470_1.jpg
https://preview.ibb.co/joLRM9/9470_2.jpg
https://preview.ibb.co/ktKaEU/9470_3.jpg
https://preview.ibb.co/bRNvEU/9470_5.jpg
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Earlier I installed a hackintosh on lenovo 580 and 4540s, I took advantage of the information in the forum and easily installed. The 9470m worked harder than I expected. I copy the final version of the HD efi folder to the usb efi folder. It opens on usb without any errors. But when I want to open it using the -v flag on the computer itself, it gives me errors in the appendix. Atheros, VM and lilu do not give errors when opening via usb.

:(



https://preview.ibb.co/b2N6M9/9470_1.jpg
https://preview.ibb.co/joLRM9/9470_2.jpg
https://preview.ibb.co/ktKaEU/9470_3.jpg
https://preview.ibb.co/bRNvEU/9470_5.jpg
Any change requires all new PR files.
 
Joined
Oct 11, 2015
Messages
189
Motherboard
Gigabyte Z270X-Gaming SOC
CPU
I7-7700K
Graphics
2x HD 7870
Mobile Phone
iOS
yeah finally working without USB
thank you rehab man

new problem I can't use brightness hotkey on keyboard (F9 & F10)..volume up (F7) and down(F6) is working
how to fix it ?
thank you
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
yeah finally working without USB
thank you rehab man

new problem I can't use brightness hotkey on keyboard (F9 & F10)..volume up (F7) and down(F6) is working
how to fix it ?
thank you
This ioreg shows you're booting from USB. Many features not available when booting from Clover configuration on installer USB.
Maybe you attached the wrong ioreg (please pay attention to what you're doing).
 
Joined
Oct 11, 2015
Messages
189
Motherboard
Gigabyte Z270X-Gaming SOC
CPU
I7-7700K
Graphics
2x HD 7870
Mobile Phone
iOS
This ioreg shows you're booting from USB. Many features not available when booting from Clover configuration on installer USB.
Maybe you attached the wrong ioreg (please pay attention to what you're doing).
sorry wrong files..I've reupload it
thank you
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
sorry wrong files..I've reupload it
thank you
This looks ok.
Attach kernel logs using debug VoodooPS2Controller.kext that show pressing of the brightness keys.

And one thing to check... make sure you didn't change the brightness key assignments in SysPrefs->Keyboard->Shortcuts. They must remain assigned to F14/F15, as that's what the keyboard driver expects to generate for brightness down/up.
 
Joined
Oct 11, 2015
Messages
189
Motherboard
Gigabyte Z270X-Gaming SOC
CPU
I7-7700K
Graphics
2x HD 7870
Mobile Phone
iOS
Attach kernel logs using debug VoodooPS2Controller.kext that show pressing of the brightness keys.
I don't know how to use debug
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I don't know how to use debug
You will find it in ~/Projects/_downloads/kexts.
Install with Terminal as per FAQ:
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
Reboot.
Press your brightness keys. Then upload kernel logs that show brightness keys being pressed.
Read here for info on kernel log:
https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/

Hopefully you already read my note regarding key assignments in SysPrefs->Keyboard and verified you did not change them.
 
Joined
Oct 11, 2015
Messages
189
Motherboard
Gigabyte Z270X-Gaming SOC
CPU
I7-7700K
Graphics
2x HD 7870
Mobile Phone
iOS
You will find it in ~/Projects/_downloads/kexts.
Install with Terminal as per FAQ:
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
Reboot.
Press your brightness keys. Then upload kernel logs that show brightness keys being pressed.
Read here for info on kernel log:
https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/

Hopefully you already read my note regarding key assignments in SysPrefs->Keyboard and verified you did not change them.
Suddenly it's work when I restart it
some bugs maybe
 

Top