Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,422
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I don’t know the changes in Catalina. Is it even possible to run a probook on Catalina fairly flawlessly? Has anyone done this already?
as long as you update your kexts and clover version, there shouldn't be an issue
 
Joined
Dec 11, 2011
Messages
168
Motherboard
HP ProBook 4440s-Clover
CPU
i5-3360M
Graphics
HD 4000, 1366x768
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
I don’t know the changes in Catalina. Is it even possible to run a probook on Catalina fairly flawlessly? Has anyone done this already?
I am currently running Catalina on my HP ProBook 4440s. Had to do manual kext updates as the ones provided by this guide do not work anymore. Clover HAS to be updated to the latest version, and your folders on your ESP cleaned up before it comes stable enough for use. Mine however is a bit more unstable than Mojave but I am running a Fusion Drive configuration, which plays havoc with the laptops EFI firmware when trying to boot.
 
Joined
Dec 12, 2017
Messages
108
Motherboard
HP EliteBook 850 G2-Clover
CPU
i7-5500U
Graphics
HD 5500, 1920x1080
Mac
MacBook Air
Mobile Phone
iOS
My trackpad is almost unusable. I get SEVERE cursor lag, jagged, choppy movement and two finger scrolling is extremely laggy, jumpy and sometimes unresponsive. Is anyone else having these issues. I thought maybe VoodooPS2Controller.kext might be the issue but not sure. Running Sierra 10.12.3 due to issues with Intel HD5500 on any higher macOS version.

UPDATE: Inexplicably the lag has vanished. I uninstalled and re-installed VoodooPS2Controller.kext and cleared the kextcache a few times. Hopefully the lag does not return:)

UPDATE 2: After waking the laptop from sleep the lag is back. Not sure what's causing it or why.

UPDATE 3: The issue seems to be a cheap replacement power supply. See

https://superuser.com/questions/367979/laptop-touchpad-response-badly-when-on-power-supply
https://superuser.com/questions/76649/laptop-touchpad-works-incorrectly-when-on-power-supply

My cheap replacement supply only has a two prong plug. The OEM HP supply is three prong and grounded. I'm on the road now but once I get back home I will confirm with the three prong OEM adapter and post here with my findings. If I unplug the cheap supply right now everything is smooth and consistent:) Sometimes you get what you pay for I guess.
 
Last edited:
Joined
Sep 16, 2017
Messages
19
Motherboard
GA-G41M-ES2L
CPU
Wolfdale 2.93 C2D E7500
Graphics
Gt 710 2GB
Mac
MacBook
Classic Mac
iBook, PowerBook
Mobile Phone
Android, iOS,
I am currently running Catalina on my HP ProBook 4440s. Had to do manual kext updates as the ones provided by this guide do not work anymore. Clover HAS to be updated to the latest version, and your folders on your ESP cleaned up before it comes stable enough for use. Mine however is a bit more unstable than Mojave but I am running a Fusion Drive configuration, which plays havoc with the laptops EFI firmware when trying to boot.
I have the same issue with Samsung SSD's. Its so annoying to cancel the disk scan every boot.
 
Joined
Dec 11, 2011
Messages
168
Motherboard
HP ProBook 4440s-Clover
CPU
i5-3360M
Graphics
HD 4000, 1366x768
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
I have the same issue with Samsung SSD's. Its so annoying to cancel the disk scan every boot.
Oh no, I have no issues with the actual SSD, but with the Fusion Drive configuration. I have to manually update Clover (installer won't recognize my ESP), and most of the scripts from this guide do not function, so I have to do everything manually which increases the likelihood of a failure to occur due to miss-typed commands and other things.
 
Joined
Sep 16, 2017
Messages
19
Motherboard
GA-G41M-ES2L
CPU
Wolfdale 2.93 C2D E7500
Graphics
Gt 710 2GB
Mac
MacBook
Classic Mac
iBook, PowerBook
Mobile Phone
Android, iOS,
Oh no, I have no issues with the actual SSD, but with the Fusion Drive configuration. I have to manually update Clover (installer won't recognize my ESP), and most of the scripts from this guide do not function, so I have to do everything manually which increases the likelihood of a failure to occur due to miss-typed commands and other things.
I'm leaving my 4440s on Mojave forever. You should write a guide to help these other guys upgrade.
 
Joined
Sep 19, 2012
Messages
723
Motherboard
hackintosh
CPU
i3
Graphics
intel
yes, as this guide uses an older version of clover that is not supported on Mojave and Catalina

i have used 4961 from the downloads section:

on my hack with no issues

Tried to make new fresh 10.14.6 usb installer with rehabmans clover version, and newest Clover_v2.4k_r4988, both usb installers boot up, but dont get to the setup install screen. just stays blank then after about 5 minutes resets system by itself.

also saw the folder structures are different between rehabmans Clover_v2.4k_r4701.RM-4963.ca6cca7c and Clover_v2.4k_r4988

anyone else tried noticed this stuff recently.

is there be an edit update of the OP for macos 10.14.6 ?

thanks
 
Joined
Apr 15, 2017
Messages
2
Hello everyone,
After several failed installations of Mojave on my HP Probook 640 G1 I'm almost giving up.

I've went through the installation, then on the following restart it starts on the installation with the progress bar and it ends. The next restart it always fail.
Does anyone have such a laptop with Mojave which can zip CLOVER folder to compare with mine and try to figure out what am I doing wrong.
I con't know much about this matters, but I would be grateful to have hackintosh installed.
 
Joined
Apr 15, 2016
Messages
72
Motherboard
HP Elitebook 840 G4
CPU
i5-7300U
Graphics
HD 620
Mobile Phone
Android
I'm planning to purchase a Dell dw1560 bcm94352z wlan card. But i'm afraid if there is any whitelist on HP Elitebook 840 G4 BIOS that prevents this card to word properly.
Do you know guys if it will work?
 
Joined
Sep 19, 2012
Messages
723
Motherboard
hackintosh
CPU
i3
Graphics
intel
Hello it's OK to update to the latest version of Clover just be careful as the directory structure of Clover changed with the transition from 2.4k to 2.5k. That was the issue I was having with 2.5K. My files in the EFI partition were in the wrong place after the change so I was not able to boot successfully. The folder structure, folder name, file names and location of drivers changed.
have you tried a fresh re-install of clover?

delete the clover efi folder created with 2.4k

install 2.5k , then copy your customised smbios config files into the new 2.5k clover folders?
 
Top