Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Joined
Oct 3, 2013
Messages
224
Motherboard
HP Probook 450 G6-Clover
CPU
i7-8565U
Graphics
UHD 620, 1920x1080
Mobile Phone
iOS
Thanks for the answer. Here you are.

Regards.
OK, is this clover folder from your hard drive or flash drive? Looks like you need to reinstall clover, your drivers/uefi folder is missing some crucial drivers, such as SMCHelper.efi, FSInject.EFI etc. Also, try using aptiomemoryfix.efi for your memory driver, or OSXAptioMemoryFixDRV3.

Is this the folder you are trying to boot from?
 
Joined
Mar 21, 2014
Messages
26
Motherboard
HP Probook 6470b
CPU
i5-3210M
Graphics
HD 4000
Mobile Phone
Android, iOS
OK, is this clover folder from your hard drive or flash drive? Looks like you need to reinstall clover, your drivers/uefi folder is missing some crucial drivers, such as SMCHelper.efi, FSInject.EFI etc. Also, try using aptiomemoryfix.efi for your memory driver, or OSXAptioMemoryFixDRV3.

Is this the folder you are trying to boot from?
Is this the folder you are trying to boot from?
Yes it is and it works, everything works. The problem is those 50 seconds

OK, is this clover folder from your hard drive or flash drive?
Actually it is a Crucial SSD. The USB clover folder of the USB does not behave this way: it is much faster and doesn't stop. The differences between USB clover folder and SSD clover are in "Clover->ACPI->Patched" after using Rehabman scripts and the adhoc config.plist for this Probook model. (but with the USB there is no sound and wrong USB ports as expected)

Looks like you need to reinstall clover, your drivers/uefi folder is missing some crucial drivers...
Yeap I know, maybe is this last Clover version (5098) because in previous 2.5K Clover versions that folder does exit although they missed the ACPI folder structure. Lot of noise in Clover lately.
Nevertheless I will give it another try and if it does not create the folder I will create it and copy those EFIs in it.


Also, try using aptiomemoryfix.efi for your memory driver, or OSXAptioMemoryFixDRV3
When using AptioMemoryFix or OSXAptioMemoryFixDRV3 I receive Error
Loading Kernel Cache (0x9)


When I got home I will inform you of the results of the tests.

Thanks.
 
Joined
Oct 3, 2013
Messages
224
Motherboard
HP Probook 450 G6-Clover
CPU
i7-8565U
Graphics
UHD 620, 1920x1080
Mobile Phone
iOS
Is this the folder you are trying to boot from?
Yes it is and it works, everything works. The problem is those 50 seconds

OK, is this clover folder from your hard drive or flash drive?
Actually it is a Crucial SSD. The USB clover folder of the USB does not behave this way: it is much faster and doesn't stop. The differences between USB clover folder and SSD clover are in "Clover->ACPI->Patched" after using Rehabman scripts and the adhoc config.plist for this Probook model. (but with the USB there is no sound and wrong USB ports as expected)

Looks like you need to reinstall clover, your drivers/uefi folder is missing some crucial drivers...
Yeap I know, maybe is this last Clover version (5098) because in previous 2.5K Clover versions that folder does exit although they missed the ACPI folder structure. Lot of noise in Clover lately.
Nevertheless I will give it another try and if it does not create the folder I will create it and copy those EFIs in it.


Also, try using aptiomemoryfix.efi for your memory driver, or OSXAptioMemoryFixDRV3
When using AptioMemoryFix or OSXAptioMemoryFixDRV3 I receive Error
Loading Kernel Cache (0x9)


When I got home I will inform you of the results of the tests.

Thanks.
OK, try installing clover from scratch on that drive. Then copy the patched SSDT to the patched folder. also copy the generated config.plist. Don't forget to place crucial kexts in Clover/Kext/Other. Also, be sure that you leave the EFI drivers selected by default. Add HFS+.efi if needed, and HPFanReset.efi if your model requires it (as per the guide).


If your USb drive boots fine and doesn't stop as you say, the issue could be the clover folder on the drive. If the fresh installation of clover doesn't work out, you can also try copying the patched SSDT files to the USB along with the generated config.plist, se if it still boots fine without pausing? This way we can try and determine where the issue comes from. But when performing these types of troubleshootings, we must change one thing at a time, so we can pinpoint the exact cause of the issue and thereby be able to solve it :)

Let us know what you find
 
Joined
Mar 21, 2014
Messages
26
Motherboard
HP Probook 6470b
CPU
i5-3210M
Graphics
HD 4000
Mobile Phone
Android, iOS
@djx8605

Several tests and everything remains the same.
So maybe is the next line to [AppleKeyStore...] that is causing the delay.

20191121_205743.jpg


if so, any clue about what to do?

Regards.
 
Joined
Mar 11, 2017
Messages
70
Motherboard
HP ProBook 6570b (Clover)
CPU
i5-3380M
Graphics
HD4000, 1600x900
Mac
MacBook Pro
Mobile Phone
Android
Guys, my laptop is not going to sleep after a few hours of booting in. Battery indicator stops working too after sometime. The brightness control also doesnt work properly last three points dont increase brightness at all sometimes. I have attached the debug files at the time my laptop is not going to sleep. I need it to go to sleep when i close the lid. Somebody can help me?
 

Attachments

Joined
Apr 6, 2012
Messages
2
Motherboard
HP EliteBook Folio 1040 G1
Graphics
HD 4400, 1920x1080
Hello,

I have followed the guide to install macOS Catalina on my HP EliteBook Folio 1040 G1 which is on the supported list of laptop but I have a couple issues (everything else works perfectly) :

- The battery status cannot be displayed even if I try and the battery state is at 0% (battery works in Windows)
- When I unplug the power while in MacOS, MacOS crash after a couple second then restart and crash while booting.
- My touchpad isn't detected in the Trackpad of System Preference.

Sound wasn't working but I was able to make it work by changing the layout-id to 84.

Note that I am currently running internet over a USB to Ethernet adapter while I wait for my compatible Wifi card to be shipped.

Anyone is able to help me with my setup ?

I've attached the correct generated debug files.
 

Attachments

Joined
Jun 4, 2016
Messages
82
Motherboard
HP elitebook 820 G3
CPU
I5-6200U (skylake)
Graphics
HD 520 1366x768
Will there be a Catalina guide similar to this one?
 
Joined
Dec 11, 2011
Messages
168
Motherboard
HP ProBook 4440s-Clover
CPU
i5-3360M
Graphics
HD 4000, 1366x768
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
Will there be a Catalina guide similar to this one?
Probably not, unless there is anyone willing to make a guide for these notebooks using updated kexts and scripts that will take into account the change that Catalina made that sets the system partition to Read-Only at bootup and other changes that I'm probably not mentioning.
 
Joined
Jun 4, 2016
Messages
82
Motherboard
HP elitebook 820 G3
CPU
I5-6200U (skylake)
Graphics
HD 520 1366x768
Probably not, unless there is anyone willing to make a guide for these notebooks using updated kexts and scripts that will take into account the change that Catalina made that sets the system partition to Read-Only at bootup and other changes that I'm probably not mentioning.
I don’t know the changes in Catalina. Is it even possible to run a probook on Catalina fairly flawlessly? Has anyone done this already?
 
Joined
Mar 11, 2017
Messages
70
Motherboard
HP ProBook 6570b (Clover)
CPU
i5-3380M
Graphics
HD4000, 1600x900
Mac
MacBook Pro
Mobile Phone
Android
I don’t know the changes in Catalina. Is it even possible to run a probook on Catalina fairly flawlessly? Has anyone done this already?
Mine is working flawlessly basically now....
 
Top